-   Linux - Desktop (
-   -   Problem: slackware: missed additional group "audio" when use slim (

e280s 06-18-2009 03:12 AM

Problem: slackware: missed additional group "audio" when use slim
1. I installed slim login manager on my slack12.2, when user logged into desktop with slim, run command "alsamixer", it greeted an error message:

alsamixer: function snd_ctl_open failed for default: No such file or directory
2. I have straced the alsamixer, and find that the problem is permissions. I have no permissions on /dev/snd/* and /dev/dsp, etc.
the default permissions just like this:

crw-rw---- 1 root audio 116,  0 2009-06-18 22:32 /dev/snd/controlC0
3. Now i'm in x-window logged in with slim, and run command "groups" or "id", find that i'm not a member of group "audio".
then i'm logged in from tty console, run "alsamixer", no errors, and run "groups" and "id", the result is : i'm a member of group "audio".

4. the problem is: if use slim, the addtional group audio will missed, but tty not.
I know, if I changed the permissions of the /dev/snd/*, this problem may be solved, but it's not a correct way.

Anyone can tell me why? Thx at first.

solved. add the groups manually.

e280s 06-18-2009 03:32 AM

the problem like this: via:


I had an identical issue, and the fix for me (after a few hours of searching) was, somehow the /etc/group file was modified to remove my username from most of the groups necessary to use the system, such as plugdev, audio, etc. The "backup" file was dated 1/10/2008 and was named /etc/group- (the trailing slash is part of the filename.)

So my fix just was 'sudo mv /etc/group- /etc/group'

To get sudo privledges back, I had to use a live CD to mount my root partition and re-add myself to /etc/sudoers.

I suspect the cause was a package update with an install script typo.

All times are GMT -5. The time now is 09:46 PM.