-   Linux - Desktop (
-   -   partial upgrade or update /home/user not found anymore on software raid0 partition (

streams &dragonflies 04-16-2011 03:13 AM

partial upgrade or update /home/user not found anymore on software raid0 partition
I have Ubuntu Studio Lucid 64 (pre-empt kernel) on a software raid 0 partition (md0). My /home is supposed to be on another raid 0 partition (md1).

I believe that in my tiredness I may have ran a partial upgrade which didn't succeed in loading the latest kernel -30, so I am still on -28.
I couldn't boot into my system anymore, so I tried recovery, and chose to repair broken pkgs, (also apt-get clean since I also had a message that my /boot partition was 100% full- which is ok now).
What I can do at this point is to boot into a blank desktop with no access to programs or my files etc....

I get

ERROR:could not update ICEauthority file /home/user.ICEauthority

nautilus could not create the following required folders
pls. create therse folders or set the permissions such that nautilus can create them.

I worked from TTY console or recovery console and attempted various recommended chown but get message that/home/usr is not found:

"/home/user" "file does not exist"

cat /etc/fstab
lists swap files only no / or /home ...Is this normal? If not how can I still be accessing / then? Other Ubuntu versions on same and other computers seem to have / and /home partitions in fstab. Could a partial upgrade that didn't get fully installed mess up fstab?

From terminal and cding to /home and typing:


ls -la
shows 2 lines with permissions etc ending in      .
but NO lines showing                              lost+found

here's an example of a working OS also on a md0 partition on another computer:


user@computer:/home$ ls -la
total 28
drwxr-xr-x  4 root        root          4096 2008-10-25 07:13 .
drwxr-xr-x 22 root        root          4096 2011-04-05 12:48 ..
drwx------  2 root        root        16384 2008-10-25 06:38 lost+found
drwxr-xr-x 69 user        user        4096 2011-04-15 21:16  user

Some posts suggest to remove and re-install nautilus but I beleive I need to fix /home first...For all I know it may have been just a partial update-I was so tired. I did a couple of other things that had changed the permissions, but I didn't rm anything for certain!
Are my home contents lost?
Pls. re-installating the whole distribution is NOT an option and re-installing home will be tricky with software raid....any solutions???

bhaslinux 04-16-2011 03:35 PM

If you have not done any rm or file system operations then it is very unlikely that you have lost any contents.

what does mdctl show ?

mdadm --detail --scan
will show you the current mdXXX being used (sometimes md0 moves as md1 ... )

mdadm --detail /dev/mdXXX
can you post that to us please ?

streams &dragonflies 04-16-2011 06:26 PM

Sorry, finished work today and now promised hubby to watch a movie on the computer in question, cause I have been at it for a couple of days (note: my generic non-raid Ubuntu boots fine)... ASAP afterwards, I will post it, check /proc/partitions and /proc/mounts and use DU disk utility as someone mentionned. Pls. bear with me, in case I have to reconstuct my software raid0, as I have never done anything like this, and don't want to mess things up furthur. I am worried since my multi drive/ OS set up was such a headache to get done, partly cause my MB had a quirk or 2, which I discovered only once 1/2 my OS were installed!

Ill take all the help I can find, thankyou!

streams &dragonflies 04-17-2011 12:33 AM

ok back...hope you'll get to see this, bhaslinux...
I was attempting to photograph my screen with the results, from my webcam on a long USB cable, but that was a fool's errand. Nope, I don't have a digital camera yet...

Looks like /home is missing from cat /proc/mounts! Its still listed by blkid, mdadm --detail/dev/md1, cat/proc/partitions, and cat /proc/mdstat. I'll try to list some details but that has to be it. Now the only problem is that blkid and sudo mdadm --detail/dev/md1 give different UUIDs for the raid partitions. Maybe it doesn't matter. I want to use nano and try to add the md1 device to cat /proc/mounts, but maybe I'll wait a little for a confirmation just to make sure...


sudo mdadm --detail/dev/md1
version: 00.90
creation time:  ....
raid level: raid 0
Array size: 77.44 Gig  72.41 Gig
raid device: 2
total devices: 2
preferred minor: 1
superblock is persistant
failed devices: 0
state: clean
UUID: 10ab42e0:8df64531:2e110cb:b1cc6cd8
events: 0.1

Note that I had to copy by hand so I ommitted one or 2 lines probably that seemed less relevant. Also here is

cat /proc/partitions:

9    1    70711168  md1
9    0    45212544  md0


sudo blkid
/dev/md1: label "U Studio L Home" UUID:63626aef-46d0-49cc-83ei-7810029217d2 Type
ext 4

I double checked and everything seems to correspond to the right /dev; for example my / is md0 and is around 45 Gigs total thus confirms that md1 is /home. BTW when if I changed permissions for a partition/directory and have a label like my /home above, without the _ between the words (U_Studio_L_Home) can this cause a problem? It seems to matter if I want it to be seen as a directory, correct?

Let me know if more info is needed!

bhaslinux 04-17-2011 08:00 PM

/etc/fstab does not seem to be normal either.
Did you try a manual mount ?

mount /dev/mdXXX /home
and then login again from GUI ?

and then login as root
mount /dev/mdXXX /home
login back as user and type
$ startx

streams &dragonflies 04-19-2011 01:16 AM

bhaslinux, I have some good news! Before I had a chance to see these instructions to add to /proc/mount, I kept trying to add /home to fstab with nano. I had tried using the UUID, /dev/md1 /home ext4 defaults 0 0 and /dev/md1 /home ext4 relatime 0 0 and finally /dev/md1 /home ext4 defaults 0 2. And it only worked until a second reboot, which at that point, I didn't expect it to!


cat /etc/fstab
 /dev/md1 /home ext4 defaults 0 2
 #UUID=f1a032cc-ec4c-4634-a05f-504ec83a87d5 /media/Ubuntu Multimedi
 ext4 users 0 0
 #UUID=f1a032cc-ec4c-4634-a05f-504ec83a87d5 /media/Ubuntu Multimedi
 ext4 users 0 0
 UUID=25494036-6939-4437-ad67-831238ff03cf swap swap sw 0 0
 UUID=a8263a1a-1b02-4535-a480-3509ac0d1d8b swap swap sw 0 0
 UUID=b628db22-8d88-437e-b09d-0aebd24e4036 /boot ext3 defaults 0 2
 UUID=0465eb55-7de7-4547-bd9d-ccd7fa350185 swap swap sw 0 0

Here is what my /proc/mount looks like now:


cat /proc/mounts
 rootfs / rootfs rw 0 0
 none /sys sysfs rw,nosuid,nodev,noexec,relatime 0 0
 none /proc proc rw,nosuid,nodev,noexec,relatime 0 0
 none /dev devtmpfs rw,relatime,size=2019908k,nr_inodes=504977,mode=755 0 0
 none /dev/pts devpts rw,nosuid,noexec,relatime,gid=5,mode=620,ptmxmode=000 0 0
 /dev/disk/by-uuid/5e77bf7c-3152-45f3-a2bf-b6a321538677 / ext4
 rw,relatime,barrier=1,stripe=32,data=ordered 0 0
 none /sys/fs/fuse/connections fusectl rw,relatime 0 0
 none /sys/kernel/debug debugfs rw,relatime 0 0
 none /sys/kernel/security securityfs rw,relatime 0 0
 none /dev/shm tmpfs rw,nosuid,nodev,relatime 0 0
 none /var/run tmpfs rw,nosuid,relatime,mode=755 0 0
 none /var/lock tmpfs rw,nosuid,nodev,noexec,relatime 0 0
 none /lib/init/rw tmpfs rw,nosuid,relatime,mode=755 0 0
 /dev/md1 /home ext4 rw,relatime,barrier=1,stripe=32,data=ordered 0 0
 /dev/sde2 /boot ext3 rw,relatime,errors=continue,data=ordered 0 0
 binfmt_misc /proc/sys/fs/binfmt_misc binfmt_misc
 rw,nosuid,nodev,noexec,relatime 0 0
 gvfs-fuse-daemon /home/myusername/.gvfs fuse.gvfs-fuse-daemon
 rw,nosuid,nodev,relatime,user_id=1000,group_id=1000 0 0
 /dev/sdb9 /media/UbuntuMiscellans ext4
 rw,nosuid,nodev,relatime,barrier=1,data=ordered 0 0
 /dev/sdb8 /media/MULTIMEDIA fuseblk
 0 0
 /dev/sdb2 /media/UbuntuMultimedia ext4
 rw,nosuid,nodev,relatime,barrier=1,data=ordered 0 0

As soon as I was back with /home/my username and nautilus working again, the message with /boot being full 100% came up so I followed instructions and checked my linux-images in synaptic: It confirmed that last kernel had installed in /boot but failed due to dependancies:

from synaptic error messages:


E:linux-image-2.6.32-30-preempt: subprocess installed
 post-installation script returned error exit status 2
 E: linux-image-preempt: dependency problems - leaving unconfigured
 E: linux-preempt: dependency problems - leaving unconfigured

 Udate manager: package installation failure:
 E: linux-image-2.6.32-30-preempt: subprocess installed
 post-installation script returned error exit status 2
 E: linux-image-preempt: dependency problems - leaving unconfigured
 E: linux-preempt: dependency problems - leaving unconfigured

I then I removed linux-image-2.6.32-30 & 2.6.32-21 & 2.6.32-25 pre-empt kernels (I marked the latter 2 for complete removal) and did:


sudo update-grub
Now everything works fine as before!!
I will keep note how to add lines in /proc/mounts for any future problems, because I wasen't using the right format so it gave me "invalid arguement". I will add more details if needed for anyone else who may run into a similar problem...

moshebagelfresser 11-25-2012 02:24 PM

E: Package linux-image-3.6.7-gnu needs to reinstalled
E: Package linux-image-3.6.7-gnu needs to reinstalled but I can't find an archive for it.

I would like to get rid of this altogether any ideas?

All times are GMT -5. The time now is 06:15 PM.