LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Desktop
User Name
Password
Linux - Desktop This forum is for the discussion of all Linux Software used in a desktop context.

Notices


Reply
  Search this Thread
Old 05-25-2011, 01:05 PM   #1
Phier
Member
 
Registered: Nov 2009
Posts: 31

Rep: Reputation: 0
nvidia driver overwriting X conf


Hi all,

I'm using a plasma TV as my desktop monitor. The Panasonic TX-PR42V20 to be precise.
This TV has a flickering issue at 50hz so i'm trying to force it to refresh at 60.
No matter what i put in my xorg.conf i revert back to an interlaced 50hz rate after starting X:

Code:
(II) NVIDIA(0): Setting mode "1920x1080_50i"
Currently my xorg.conf contains:

Code:
Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "UseEDIDFreqs" "False"
#    Option 	   "UseEdidDpi" "False"
#    Option         "UseEdid" "False"
    Option         "TwinView" "0"
#    Modeline       "1920x1080_60_0" 148.5 1920 2008 2052 2200 1080 1084 1089 1125 +HSync +VSync
    Option         "metamodes" "1920x1080_60_0 +0+0"
    SubSection     "Display"
        Depth       24
#        Modes      "1920x1080" 
    EndSubSection
EndSection
The commented out modeline above never worked for me, maybe it's in the wrong place?

I made it from examining the monitors EDID info:

Code:
	Mode 	"1920x1080"	# vfreq 50.000Hz, hfreq 56.250kHz
		DotClock	148.500000
		HTimings	1920 1968 2012 2640
		VTimings	1080 1084 1089 1125
		Flags	"+HSync" "+VSync"
	EndMode
	Mode 	"1920x1080"	# vfreq 60.000Hz, hfreq 67.500kHz
		DotClock	148.500000
		HTimings	1920 2008 2052 2200
		VTimings	1080 1084 1089 1125
		Flags	"+HSync" "+VSync"
	EndMode
and the output from starting X with a high verbosity:

Code:
[420689.629] (--) NVIDIA(0):   1920 x 1080 @ 60 Hz
[420689.629] (--) NVIDIA(0):     Pixel Clock      : 148.50 MHz
[420689.629] (--) NVIDIA(0):     HRes, HSyncStart : 1920, 2008
[420689.629] (--) NVIDIA(0):     HSyncEnd, HTotal : 2052, 2200
[420689.629] (--) NVIDIA(0):     VRes, VSyncStart : 1080, 1084
[420689.629] (--) NVIDIA(0):     VSyncEnd, VTotal : 1089, 1125
But even with this high verbosity, i'm not given any indication (other than NVIDIA) of what is causing the output to revert to 50i, and the "UseEDIDFreqs" option seems the useless.

If i manually change the refresh rate with nvidia-settings, xvidtune reports the newly set rate, but nvidia-setting continues to report 50hz, and the changes i made, if any, don't persist after i restart X.

Any suggestions or info i may have left out?

Cheers.
 
Old 05-25-2011, 06:02 PM   #2
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 17,225

Rep: Reputation: 2521Reputation: 2521Reputation: 2521Reputation: 2521Reputation: 2521Reputation: 2521Reputation: 2521Reputation: 2521Reputation: 2521Reputation: 2521Reputation: 2521
informing us as to your OS might help
also what version of the nvidia driver ? and is it a rpm .run .deb ???
is nouveau installed and use by default ?
if so is it blacklisted ?
 
Old 05-25-2011, 06:36 PM   #3
Phier
Member
 
Registered: Nov 2009
Posts: 31

Original Poster
Rep: Reputation: 0
Debian testing

Code:
ii  libgl1-nvidia-alternatives                    270.41.06-1                       simplifies replacing MESA libGL with GPU vendor libraries
ii  libgl1-nvidia-glx                             270.41.06-1                       NVIDIA binary OpenGL libraries
ii  libglx-nvidia-alternatives                    270.41.06-1                       simplifies replacing Xorg module libglx.so with GPU vendor library
ii  nvidia-common                                 20110426+1                        NVIDIA binary graphics driver support files
ii  nvidia-glx                                    270.41.06-1                       NVIDIA binary Xorg driver
ii  nvidia-kernel-common                          20110426+1                        NVIDIA binary kernel module support files
ii  nvidia-kernel-dkms                            270.41.06-1                       NVIDIA binary kernel module DKMS source
ii  nvidia-settings                               270.41.06-1                       Tool for configuring the NVIDIA graphics driver
ii  nvidia-vdpau-driver                           270.41.06-1                       NVIDIA vdpau driver
ii  nvidia-xconfig                                270.41.06-1                       X configuration tool for non-free NVIDIA drivers
nvidia-settings and nvidia-xconfig were installed manually from the unstable branch's .debs 'cause the ones available on testing are older versions, but the same behaviour occurs with them anyway.

Looks like you might be on to something with Nouveau...

Code:
ii  libdrm-nouveau1a                              2.4.24-2                          Userspace interface to nouveau-specific kernel DRM services -- runtime
ii  xserver-xorg-video-nouveau                    1:0.0.16+git20110411+8378443-1+b1 X.Org X server -- Nouveau display driver (experimental)

Code:
root@insomnia:/etc/modprobe.d# grep nouveau *
nvidia-installer-disable-nouveau.conf:blacklist nouveau
nvidia-installer-disable-nouveau.conf:options nouveau modeset=0
nvidia-kernel-common.conf:blacklist nouveau
root@insomnia:/etc/modprobe.d# lsmod |grep nouveau
nouveau               448363  0 
ttm                    47356  1 nouveau
drm_kms_helper         26825  1 nouveau
drm                   129853  3 nouveau,ttm,drm_kms_helper
i2c_algo_bit           12722  1 nouveau
power_supply           13283  1 nouveau
video                  17500  1 nouveau
i2c_core               19141  6 nouveau,drm_kms_helper,drm,i2c_algo_bit,nvidia,i2c_i801
button                 12810  1 nouveau
root@insomnia:/etc/modprobe.d# lsmod |grep nvidia
nvidia               9591809  48 
i2c_core               19141  6 nouveau,drm_kms_helper,drm,i2c_algo_bit,nvidia,i2c_i801
Not entirely sure how to read that. Is it the case where the nvidia drivers are blacklisting them, but something else is starting them later?

Last edited by Phier; 05-25-2011 at 06:57 PM.
 
Old 05-25-2011, 07:20 PM   #4
Phier
Member
 
Registered: Nov 2009
Posts: 31

Original Poster
Rep: Reputation: 0
It continues to happen with nouveau properly disabled.

Code:
[   384.052] (WW) NVIDIA(0): Panasonic-TV (DFP-1)'s EDID does not contain a maximum image
[   384.052] (WW) NVIDIA(0):     size; cannot compute DPI from Panasonic-TV (DFP-1)'s
[   384.053] (WW) NVIDIA(0):     EDID.
[   384.053] (==) NVIDIA(0): DPI set to (75, 75); computed from built-in default
[   384.053] (II) NVIDIA: Using 1024.00 MB of virtual memory for indirect memory
[   384.053] (II) NVIDIA:     access.
[   384.053] [   384.055] [   384.055] [   384.056] (II) NVIDIA(0): Setting mode "1920x1080_60_0+0+0"
[   384.132] [   384.132] [   384.132] [   384.132] [   384.133] [   384.147] (==) NVIDIA(0): Disabling shared memory pixmaps
[   384.147] [   384.147] [   384.147] (==) NVIDIA(0): Backing store disabled
[   384.147] (==) NVIDIA(0): Silken mouse enabled
[   384.147] [   384.148] [   384.148] (**) NVIDIA(0): DPMS enabled
[   384.149] (II) NVIDIA(0): [DRI2] Setup complete
[   384.898] (II) NVIDIA(0): Setting mode "1920x1080_50i"

Last edited by Phier; 05-25-2011 at 07:21 PM.
 
Old 06-01-2011, 05:41 PM   #5
Phier
Member
 
Registered: Nov 2009
Posts: 31

Original Poster
Rep: Reputation: 0
Anyone?
 
Old 06-01-2011, 05:55 PM   #6
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 17,225

Rep: Reputation: 2521Reputation: 2521Reputation: 2521Reputation: 2521Reputation: 2521Reputation: 2521Reputation: 2521Reputation: 2521Reputation: 2521Reputation: 2521Reputation: 2521
well this is as you said" Debian testing" TESTING
Quote:
nvidia-xconfig were installed manually from the unstable branch's .debs '
there is a reason it is called " unstable branch "

A testing only version .
using this version means you should already know how to solve problems and report back a software fix

I am not all that familiar with debain so...

it looks like hal is auto setting hardware settings - like it is supposed to .But ignoring the settings in custom config files

In your first post you say you changed it in nvidia-xconfig
Did you run that as root from the terminal ?
Or from the gui as a normal user ?

Run it as root from the terminal .
 
Old 06-01-2011, 06:33 PM   #7
Phier
Member
 
Registered: Nov 2009
Posts: 31

Original Poster
Rep: Reputation: 0
I tried unstable after trying testing as it often gives you new features and solves bug fixes, and i also said i tried the testing debs too. Testing is pretty damn stable by the way.
Yeah i ran nvidia-config as root.
I'll have a look into why and how hal might be changing hardware settings, but i would have thought if it was hal it would be logged as hal and not nvidia, like in my first code quote above.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
No xorg.conf when installing nVidia driver. glore2002 Slackware 2 08-31-2009 07:35 AM
nvidia driver configuration not possible: my xorg.conf riccisit Linux - Hardware 5 01-22-2008 06:05 PM
Livna nvidia driver keeps changing xorg.conf june3474 Linux - Software 1 05-24-2007 12:36 PM
dhclient is overwriting /etc/yp.conf interfering with domain access gdepp Linux - Networking 2 03-12-2007 07:56 PM
DHCP client overwriting resolv.conf... how to stop it? gauge73 Linux - Networking 6 05-04-2005 12:51 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Desktop

All times are GMT -5. The time now is 10:10 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration