LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Desktop
User Name
Password
Linux - Desktop This forum is for the discussion of all Linux Software used in a desktop context.

Notices


Reply
  Search this Thread
Old 02-25-2010, 04:00 PM   #1
orwell1984
LQ Newbie
 
Registered: Feb 2010
Posts: 8

Rep: Reputation: 1
nvidia color correction settings lost when monitor wakes up


I am using Debian 5 and have an Nvidia 8600 GT. I just installed the Nvidia drivers and everything works for the most part. The only problem I am having is when the monitor wakes up after being asleep the color correction settings are lost. As far as I know I have everything set up correctly in my xorg.conf I am using the settings that nvidia-settings created. When I log into my account and my xsession starts nvidia-settings --load-config-only is run so my settings load at start up. Its just when the monitor goes to sleep I have to run nvidia-settings --load-config-only again. I have checked and the .nvidia-settings-rc file when the monitor wakes up and all the settings are still there, but like I said I have to run nvidia-settings to restore them. Any help would be greatly appreciated.
 
Old 02-25-2010, 04:38 PM   #2
Mr-Bisquit
Member
 
Registered: Feb 2009
Distribution: FreeBSD, OpenBSD, NetBSD, Debian, Fedora
Posts: 770
Blog Entries: 52

Rep: Reputation: 68
Script can be loaded at boot in rc.local.
Or you can load from the terminal after you login.
 
Old 02-25-2010, 05:11 PM   #3
orwell1984
LQ Newbie
 
Registered: Feb 2010
Posts: 8

Original Poster
Rep: Reputation: 1
Thank you for your reply Mr-Bisquit, but unfortunately thats not the problem. The settings load fine on start up. I just added the command to Startup Programs under Sessions. To clarify My settings are there as soon as I start my x session. It is when the monitor goes into standby and comes back on that the settings are lost. To clarify more I mean when the monitor goes into standby while I am still logged in. My computer is on, I am logged in, and my x session is running with the correct settings. I leave for a while monitor goes to sleep I come back to wake it up but the settings are gone. For some reason they are not being loaded back into the xserver settings when this happens. So any other ideas?
 
Old 02-28-2010, 02:26 AM   #4
orwell1984
LQ Newbie
 
Registered: Feb 2010
Posts: 8

Original Poster
Rep: Reputation: 1
Almost a solution. I ended up having to reinstall lenny the other day due to swapping out hard drives the installing of other operating systems and all that fun stuff. Anyway this time my nvidia color correction settings were resetting when the screen saver would start. Turns out that quite a few people have experienced that. Although my first problem was some what different I think they both stem from the same root cause. So here is what I have come up with to "solve" the problem. There is no way to quick fix this. The fastest way to possibly fix this is to try and find a patch that will work and there are patches that do exist. If you really want to go the extra mile you could just try and edit the source code yourself. From what I can tell the bug has to do with when the screen fades out, so if you want to have a go at fixing that you can. If those two options don't sound good you could just switch to xscreensaver. Alternatively if you are like me and don't really care for a screen saver, you just don't want to have to run nvidia-settings -load-config-only every time your monitor wakes up you can just disable the screen saver altogether. So that is the best answer I could come up with I hope it helps.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Nvidia - Keep external monitor settings between reboots undoIT Linux - Hardware 4 07-12-2009 04:15 AM
REQ: Color correction pluging for The Gimp Zack069 Linux - Software 0 02-16-2008 08:38 AM
Printer needs color correction sueno Linux - Hardware 4 08-09-2007 04:23 AM
REQ: Gimp plugin fo automatic color correction and color masks Rick069 Linux - Software 1 04-15-2007 03:10 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Desktop

All times are GMT -5. The time now is 09:40 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration