-   Linux - Desktop (
-   -   My CentOS installation stops booting at udev service (

arijit_2404 11-09-2007 05:57 AM

My CentOS installation stops booting at udev service
Hi all,

I have just installed CentOS 5.
Installation was fine and I didn't encounter any problem.

But after installation was complete, I rebooted the machine.
And booting stops as soon as services starting.

starting udev:

here my booting stops and PC hangs. Tried many times to reboot(including Interactive mode) but it seems "udev" service is facing some problems and I didn't go further this point.

Please help me out of this problem.

My configuration:
AMD x2 3600+, ASUS M2NPV-VM, 1 GB RAM, 17" LG monitor
NVIDIA GF8600GT, USB mouse, PS2 Keyboard, Router based ADSL Internet connection

Brian1 11-10-2007 05:54 PM

How long did you wait? I would wait 5 to 10 minutes to see if anything happens.
You can try passing the following optins on the boot line.
noacpi irqpoll


arijit_2404 11-11-2007 03:09 AM

I have tried, "noapic", "acpi=off" and both didn't work.
I have waited more than 10 minutes, and PC hangs during this time. I had to press RESET button.

However when I have tried to install CentOS5 into my laptop (using same DVD), it installed and worked like a breeze.
So, I'm using CentOS 5 in my Lenovo N100 and till now, everything is fine.

But in case of desktop, it's not worked till today morning, so I installed fedora 8 instead.
I have Geforce 8600GT in desktop machine, could this be a problem? Since CentOS 5 is based on older version of Linux.

Brian1 11-11-2007 10:09 AM

No I doubt that is the issue. Both require nvidia drivers to be installed to work. Neither distro include nvidia do to legal issues. Pretty much Redhat is American made and needs to follow American law. Other distros like Ubuntu are other country and I guess follow thier laws as to what they can and can't do.

Sounded like a kernel issue with a piece of hardware. I have seen this with a firewire controller causing udev to stall. My guess the kernel Fedora uses has a fix for the troublesome piece of hardware.

It could have been the udev or hal packages have a fix. So if they were upgraded then maybe the system would be fine. Or upgrading the kernel may have resulted in the fix. Hard to say. Needless to say they are both Redhat type distros and use nearly the same confiugerd rpm packages and configuration files. It should be fine. It would make for a good challenge to determine what the bug was but would be a time consuming job if kernel and udev and hal package changes. But would not see why it would not run in the end.


All times are GMT -5. The time now is 09:38 PM.