-   Linux - Desktop (
-   -   Lost window controls in Gnome (Ubuntu 10.04) (

trentfox 04-27-2011 06:14 AM

Lost window controls in Gnome (Ubuntu 10.04)
Yesterday I upgraded Ubuntu 9.04 in steps to 10.04 LTS and everything was OK until I tried installing the new gnome shell. After that, all application windows were stuck at the top of the display, window controls were gone, and I could only run one application at a time. I tried uninstalling gnome shell, but that didn't help. I tried replacing gnome-shell with gnome-wm in Ubuntu-tweak and gconf2, but it still starts up in this state. If I issue a "gnome-wm --replace" command in a terminal, everything goes back to normal except I can only get one type of window control, and even this doesn't last after a reboot. When I installed kde, I can start up in kde and everything is fine there, but I want to run gnome, not kde. I'm sure I screwed up something when I installed gnome-shell, but can anyone suggest how I might recover?

Arcane 04-27-2011 06:52 AM

Hmm..just idea: If you can get into other DE like KDE you mentioned. Go there. Open terminal or even better - Synaptic package manager. Search for gnome shell or similar in synaptic search and see if you can uninstall it from there. Then if needed install previous shell or whole gnome again from same place. If you don't have synaptic type

sudo apt-get install synaptic
in terminal.

trentfox 04-27-2011 09:06 AM

Thanks for the suggestions, Arcane. I had previously uninstalled gnome-shell, so I went to Synaptic, found gnome files and reinstalled any ones that looked relevant, including metacity. But it didn't change anything. I'm sure that the problem is just a missing file, startup file or setting, but I don't know what it is yet. Other ideas?

Mr. Bill 04-27-2011 09:15 AM



sudo apt-get install ubuntu-desktop
Since Gnome is already installed, this will only download broken/missing packages.

Hope this helps.

EDDY1 04-27-2011 09:18 AM

If you
"apt-get install gnome"
it pulls in all dependencies

trentfox 04-27-2011 09:33 AM

Thanks for all of these suggestions; much appreciated. I finally figured out what the problem was by examining the Ubuntu-tweak settings on a working virtual machine. The problem was the wm wasn't set to be metacity. Once I did that, everything went back to normal. Phewww!

All times are GMT -5. The time now is 12:48 PM.