-   Linux - Desktop (
-   -   Login don't work properly (

a_minor 01-03-2009 10:13 AM

Login don't work properly
Hi all,

I suddenly and without any before change configuring , face with this problem that when I click(on login window)login as user( non-root) it show me this message that "can't authenticate login.." and I switch to shell environment(not graphical) and create a new user and when i wanted to set for it a password it accept the password but inform me that " the password file is locked.."

and that is amazing that if I login as user , it is succeded, but It only don't work in graphical login screen to authenticate it for entering appropriate password, it don't let me to do!

I don't what must i do to fix it, please glad me with your helpful idea,
thanks in advance

Simon Bridge 01-04-2009 01:57 AM

Please edit your profile to show your distribution and location - it is clear that English is not your first language, it may be possible that someone who speaks the same language as you can help.

From your post I understand that:

1. you cannot authenticate as a normal user from the graphical login
2. you can authenticate from a text-only login.

Try logging in with the graphical method again. When it fails, use a failsafe console, or other login which gets you a terminal. From there you can read the syslogs to see if it tells you what has happened:

dmesg | grep pam

a_minor 01-04-2009 10:11 AM


no, that isn't my first language, but that's my common problem that even with my big attempt to talk clear, but that is always disappointing attempt,
anyway thanks for this 1001th time of pointing to this problem by you:)
so, I try again to be clearer than before,


yes that's exactly problem that I have(number 1,2 that you countered), and when I logging in again in graphical mode , that was again this messagee : can't authenticate..
and when I restarted , linux booting in last seconds to completing stopped and these messages appeare:


ACPI: EC:missing comfirmations, switch off interrupt mode.
ACPI Exception (evregion-0419): AE_TIME, Returned by Handler for [EmbeddedControl] [20080609]
ACPI Error (psparse-0530): Method parse/execution failed [\_SB_.BAT0._BST] (Node f78150f0), AE_TIME
ACPI Exception (battery-0360): AE_TIME, Evaluating _BST [20080609]

and when I swith to tty6 and logging in successfully , I read the syslogs but there wasn't anything in it

Simon Bridge 01-04-2009 05:21 PM

Have you tried booting with irqpoll enabled?
Have you tried to find pam errors in the syslog?

Are you using KDE or Gnome (or other) version of fedora?


ACPI: EC:missing comfirmations, switch off interrupt mode.
Curious that you have an interrupt mention in connection with ACPI - lets rule this out: reboot with noacpi.
May be related to the failure to complete the boot process after unsuccessful authenticate.

However, some people cannot authenticate in fedora due to language settings.
This guy (Russian) had this trouble upon installation.
Language: At least now I have a proper context for your English - this means that I can use my knowledge of where you are from to help me understand what you are trying to say. For my part, I'll try to keep to proper English. What makes it more difficult is that this is a technical discussion, but we are still better off than relying on my Parsi. I con just about manage a "salaam aleikom".

Have you tried contacting TehLUG - these are gnu/linux enthusiasts in Tehran.

All times are GMT -5. The time now is 04:37 PM.