-   Linux - Desktop (
-   -   Linux on Old Pentium 233mhz PC - Grub issues....unknown filesystem (

williamsc47 07-08-2013 08:26 AM

Linux on Old Pentium 233mhz PC - Grub issues....unknown filesystem
Hi all,

Very new here and to linux so please bare with me...I also apologize if this is all covered elsewhere.

I have just installed Lubuntu 10.04 on a Pentium 233mhz 256mb ram PC with a very small 3.5GB HDD. It apparently installed ok.

However, when I try to reboot I get the following:

verifying DMI pool data
error: unknown file system
grub rescue>

I have tried using the boot-repair cd but was unable to find a copy that support my CPU as it always says "requires cmov" which is also why I went with an older version of lubuntu.

I have tried using rescatux but this does seem to help.

Any suggestions or guidance would be greatly appreciated


zhjim 07-08-2013 08:45 AM

Grub has various stages of booting. Which rougly go like this. MBR (stage1)->filesystem (stage2). As you have the prompt of grub rescue I assume your MBR is okay but grub is not finding its files on the filesystem. Which it also tells you with unknown filesystem.
Depending on how you setup your partitions and the age of your computer it might be possible that the /boot directory is to far of to be read by the bios so grub can't find its "working" files or can't read the whole parition it needs. (Not really sure about it).

but as you have a rescue console we should get grub to boot. Use the ls command to see which drives and partitions grub sees. We need to find the partition which holds the /boot directory. So do a ls (hd0,msdos1)/ to (hd0,msdos4)/ (Watch for the ending / its important). You should be looking for the partition that gives an output similar to vmlinuz-version initrd.img-version /grub. If you only have one big partition something like this should get you going.

set prefix=(hd0,msdos1)/boot/grub
insmod linux
insmod normal

For seperate parition

set prefix=(hd0,msdos#numberofpartition#)/grub
insmod linux
insmod normal

This loads some grub modules and starts the normal mode. After this you should get the normal grub prompt. If not we can try to fire the kernel by han

set root=(hd0,msdos1)
linux /boot/vmlinuz-your-version-here root=/dev/sda1
initrd /boot/initrd.img-your-version-here

If all this fails, please provide the output of ls, ls (hd0,msdos1)/ ls (hd0,msdos2)/ ... (hd0,msdos10). The number after msdos states your partition and does not need to count up to 10. Just give the ls of each drive [hd0 ... hd4] and each partition on each drive.

camorri 07-08-2013 08:49 AM


error: unknown file system
What file system did you create during the install?

Did you delete the old partitions, and create new ones?

Just a guess, this hardware had some version of windblows on it? Possibly a NTFS file system? Is it still there? If yes, then I don't think you can boot from it.

Can you boot from a live CD? If yes, then you can look at the /dev directory, and see what partitions the kernel knows are there. 'ls /dev/sda*' or 'ls /dev/hda*' will list the partition devices. Post the results. The above commands without the quotes, just what is between them. You can run a 'df' command also. My guess is it will list nothing. df will show mounted file systems. If the file system is ntfs, then they can not be mounted until after a successful boot.

williamsc47 07-08-2013 10:01 AM


Thanks for your quick replies

If I type ls at the grub rescue prompt it displays the following:

(hd0) (hd0,1) (fd0)

As for having windows installed, yes I did have windows ME installed previously but this has been completely removed and the HDD reformatted and then left as unpartitioned free space, which i then let lubuntu use entirely, which created an ext 4 partition as well as a swap partition.

Not sure what to do from here?

camorri 07-08-2013 10:18 AM


which created an ext 4 partition as well as a swap partition.
That is good.

Can you boot the system from a CD? If yes, then we need to look into your grub config. I'm not all that familiar with grub 2. I used grub legacy for a long time, now I use lilo.

There are people here that can help with grub2. You may find some useful information here -->

allend 07-08-2013 11:28 AM


my CPU as it always says "requires cmov" which is also why I went with an older version of lubuntu.
It is becoming increasingly rare for kernels to be compiled so that they will support this type of CPU.

Came across this that seems to fit with your problem.
The fix there was to ensure that the BIOS settings for the hard disk were correct.

snowpine 07-08-2013 11:32 AM

Lubuntu 10.04 is obsolete and completely unsupported in 2013. I recommend to upgrade your hardware so you can run the current release:

williamsc47 07-08-2013 11:39 AM


I am able to boot the live CD so will do that when I get back.

The fact that lubuntu 10.04 is out of date is of little importance to me as the machine will only be used a for a single purpose, which is actually to share a broadband connection over dial-up with a Sega Dreamcast games's known as a PC-DC server

I did wonder about the bios myself so I tried changing various setting but nothing has worked so far? :(

williamsc47 07-08-2013 11:47 AM

1 Attachment(s)
Ok, I have attached a grub.txt copy of my cfg file...anybody have any clues from that?

camorri 07-08-2013 12:30 PM

This file shows no initrd file being loaded. I also see this command

insmod ext2
which is loading a ext2 driver. So, you may not have an ext4 driver loaded. I do not know how buntu kernels are configured, the ext4 driver may ( or may not ) be compiled into the kernel.

Given the error, and no initrd file, and no sign of the ext4 driver, its a good bet this is the problem.

FYI, an initrd file is used to load drivers and other code not compiled into the kernel, before the kernel is fully loaded.

There are two ways to fix this. One, load ext4. This requires changing the grub setup.

Two, re-install, and format for ext2.

Have a look at the link I posted for information on how to change grub2.

rokytnji 07-08-2013 12:56 PM


The fact that lubuntu 10.04 is out of date is of little importance to me as the machine will only be used a for a single purpose, which is actually to share a broadband connection over dial-up with a Sega Dreamcast games's known as a PC-DC server
Since only one purpose.

Give this a try to repair grub in Lubuntu


Get a CD including Boot-Repair:
- Boot-Repair-Disk is a CD that automatically runs Boot-Repair at start-up.
- or: Boot-Repair is also included in all Linux Secure disks.
Another way is with a Parted Magic cd and using supergrubdisk2 in the boot menu.
Supergrubdisk and other good tools included in Parted Magic and I keep one like a wrench
in a tool box. I am not sure how well it will boot on you old hard ware though. Worth a shot though.

Edit: A floppy made supergrubdisk2 should boot just fine on that unit though.

John VV 07-08-2013 03:19 PM

with only 3.5 gig drive
and with it split into 4 partitions
it is likely nothing will be able to install into any of those partitions
they will be way TOO small

just use ONE partition only
the whole drive as / -- sda1
force /boot to install to /
and force /home to install to /
and no swap partition
or if you must then a 512 meg SWAP

yancek 07-08-2013 03:45 PM

When you installed Lubuntu, you should have seen a screen near the beginning labelled "Preparing to Install Lubuntu". It would indicate how much space is needed for an install. I don't have 10.04 but, on 11.10 it is 4.1GB. If you ever get this working, I doubt you will have much luck with it if you need to install any software.

If you are getting unknown filesystem, what filesystem do you have? You can get that info with the command: df -T if the partitions are mounted or with parted /dev/sda print all. You could also post what gparted shows since it should be on the Live CD of Lubuntu.

williamsc47 07-08-2013 06:34 PM

2 Attachment(s)
Ok, well I decided to try re-installing lubuntu 10.04 onto an ext2 partition as camorri suggested, but unfortunately that made no difference...same problem. I have attached the new grub.cfg file just in case its useful.

I also ran the df -T command which produced the following


ubuntu@ubuntu:~$ df -T
Filesystem Type 1K-blocks Used Available Use% Mounted on
aufs aufs 125360 4592 120768 4% /
none devtmpfs 118476 176 118300 1% /dev
/dev/sr0 iso9660 533482 533482 0 100% /cdrom
squashfs 513664 513664 0 100% /rofs
none tmpfs 125360 0 125360 0% /dev/shm
tmpfs tmpfs 125360 4 125356 1% /tmp
none tmpfs 125360 84 125276 1% /var/run
none tmpfs 125360 0 125360 0% /var/lock
none tmpfs 125360 0 125360 0% /lib/init/rw
I also ran GParted which I captured and also attached.

As for the HDD size, I didn't notice the install saying anything about a minimum size, but it does appear to install ok at a size of about 1.3gb. the setup also creates a 203mb swap partition automatically

I have attempted to use the boot-reapir disk previously but it fails due to lack of cmov support....but I will have a look at the other suggestions tomorrow if I get a chance...thanks

I don't know if any of this is useful...but thank you to everyone who has tried to help so's very much appreciated


camorri 07-08-2013 07:06 PM

The last attaced grub.txt file appears empty. Is this a different file than the first grub.txt file you uploaded? Could you upload it again?

All times are GMT -5. The time now is 10:35 PM.