-   Linux - Desktop (
-   -   KMix can't be found when I'm signed into my personal username (

beezum88 08-09-2006 08:05 PM

KMix can't be found when I'm signed into my personal username
Hello, everyone,

I guess I should begin by saying that I don't know anything about Linux...yet.

That said, I just recently installed SUSE Linux 9.3 on my desktop. It's really great, but there are some annoying problems. One of them is the fact that sound won't play when I'm signed in to my personal username.

When I installed Linux, I set up KDE to autologgin to a generic user. In this username, the sound works fine. When, however, I "Switch User" and loggin to my username, the sound doesn't work. When I clicked on the KMix icon on the bottom bar, It said that KMix could not be found--rather than pop up with a volume-control window, as it does in the generic user. Once, the sound did work while I was logged into my username, but I don't remember the circumstances, and haven't been able to reproduce it.

Thanks for the help,

"Computers are like Old Testament Gods: Lots of rules and no mercy."
--Joseph Campbell

shakumafu 08-09-2006 08:28 PM


start by running kmix via the kmenu and see what happens. you could also try reninstalling it, maybe its corrupted, who knows? what are some other problems that you are having?

beezum88 08-09-2006 10:20 PM

Update on the problem
Tried opening with kmenu, still doesn't work. It brings up a window that's labelled as KMix, with an empty drop-down box labeled "Current Mixer".

I have discovered the circumstances in which KMix works, though. It works with the user on Screen 1 and nowhere else. If I log out of the generic user in order to log in to my username, KMix works, but if I have two sessions running at once, i.e. generic user and me, KMix only works on the one that was opened first. So I can get it to work, but why won't it work on two sessions at once?

shakumafu 08-10-2006 10:17 PM

thats really messed up. i cant think of any reason why that would be the case. try reinstalling it and seeing if that works or try installing the gnome desktop environment, it uses a different program for managing sound

All times are GMT -5. The time now is 09:46 PM.