LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Desktop
User Name
Password
Linux - Desktop This forum is for the discussion of all Linux Software used in a desktop context.

Notices


Reply
  Search this Thread
Old 05-11-2011, 03:06 PM   #1
clpc
LQ Newbie
 
Registered: Nov 2009
Location: England
Distribution: Arch Linux
Posts: 5

Rep: Reputation: 0
Keyboard numeric keypad


In Gnome in the keyboard layout there is a section where you could click a checkbox that said something like...
"Make <Shift+Home> and <Shit+End> work as in MS Windows"

Basically it makes <Shift+Home> and <Shift+End> highlight text.
This works fine on the dedicated End and Home buttons, I am referring only to the Home and End buttons on the numeric keypad.

I am now using Xfce4 and this feature does not seem to be available.

Can anyone tell me how I can set this either on the CLI or desktop environment. I am well used to hacking away at linux but I just cannot find anything to give me an idea of what needs to be done.
 
Old 05-12-2011, 02:01 AM   #2
David the H.
Bash Guru
 
Registered: Jun 2004
Location: Osaka, Japan
Distribution: Debian + kde 4 / 5
Posts: 6,834

Rep: Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976
The gui settings are basically just a front-end for setxkbmap. kde's dialog is nice because it shows you exactly what command is generated from your choices. The -option setting that does what you want is numpad:microsoft.

I can't for the life of me parse what you're talking about with the numberpad though. Do you mean that this setting only works with the numberpad, doesn't work with it, you want it to only work with it, you don't want it to only work with it, or what?

In X, the numberpad cursor keys can be used by first hitting shift+numlock. See this page for details: http://www.tuxfiles.org/linuxhelp/movecursor.html

Other than enabling/disabling them as above, that I don't think there's any way to set the numberpad functions separately.
 
Old 05-12-2011, 05:28 AM   #3
clpc
LQ Newbie
 
Registered: Nov 2009
Location: England
Distribution: Arch Linux
Posts: 5

Original Poster
Rep: Reputation: 0
Thumbs up Problem SOLVED

Thankyou very much, that did exactly what I was after.

I think my description of the problem was a bit confusing.
I didn't want to change/alter any other keys, I just wanted the change to only affect the numeric keypad.

Thanks again, old habits die hard, I have been using Linux for 6 years now and I just cannot easily change habits from when I used Windows for may years.

For anyone else reading this the final command is as follows.

sudo setxkbmap -option numpad:microsoft
 
Old 05-12-2011, 12:27 PM   #4
MTK358
LQ 5k Club
 
Registered: Sep 2009
Posts: 6,443
Blog Entries: 3

Rep: Reputation: 721Reputation: 721Reputation: 721Reputation: 721Reputation: 721Reputation: 721Reputation: 721
Mark the thread as solved.

Also, I don't think you need sudo. Did you try without it?
 
Old 05-12-2011, 06:33 PM   #5
David the H.
Bash Guru
 
Registered: Jun 2004
Location: Osaka, Japan
Distribution: Debian + kde 4 / 5
Posts: 6,834

Rep: Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976
MTK358 is right. Like most X-affecting programs, setxkbmp should be run by the user who owns the X-session in question. This will generally be the user you logged in as.

Also, after looking at it a bit closer, it's a "numpad" option, so I guess it only affects that in any case.
 
Old 05-13-2011, 04:13 AM   #6
clpc
LQ Newbie
 
Registered: Nov 2009
Location: England
Distribution: Arch Linux
Posts: 5

Original Poster
Rep: Reputation: 0
Thumbs up Solved

Yes I did realize that the sudo is not needed.
I have placed it in my ~/.bashrc file.

SOLVED

Thanks again
 
Old 05-13-2011, 09:09 AM   #7
MTK358
LQ 5k Club
 
Registered: Sep 2009
Posts: 6,443
Blog Entries: 3

Rep: Reputation: 721Reputation: 721Reputation: 721Reputation: 721Reputation: 721Reputation: 721Reputation: 721
Again, mark the thread as solved.
 
Old 05-14-2011, 04:14 AM   #8
clpc
LQ Newbie
 
Registered: Nov 2009
Location: England
Distribution: Arch Linux
Posts: 5

Original Poster
Rep: Reputation: 0
Solved

according to one of your moderators I have marked it as solved.
See here http://www.linuxquestions.org/questi...solved-727779/

The link above would be a clickable link but the LQ page about tags isn't loading and I have more important things to do.

But either way do you not think your posts are just banging out a command and nothing else. "Mark it as solved"

I wonder how many times it would take me to carry on just marking a post as solved the way I have before your proverbial penny drops and you recognise that perhaps this member doesn't know how to mark the post as solved in such a way to satisfy LQ.

Much better would be to ask me to mark the post as solved by supplying me with a link that explains how I do that.

So instead of getting this post solved we have now changed topics and are into a discussion about marking threads as solved, a discussion that I don't really have the time for.
 
Old 05-14-2011, 02:37 PM   #9
David the H.
Bash Guru
 
Registered: Jun 2004
Location: Osaka, Japan
Distribution: Debian + kde 4 / 5
Posts: 6,834

Rep: Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976
There's a big highlighted link at the top of every thread you start that will mark it for you. I also mention another way to do it in my signature.

But in any case we do assume that you can figure some things out on your own.

If you can't, then why not simply ask us politely, instead of complaining about it?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Numeric keypad on keyboard not responding dayers Ubuntu 9 10-10-2010 05:42 AM
Numeric keypad and Java stormbr Slackware 0 06-04-2009 11:46 PM
Numeric Keypad not working in KDE Slack1_more Slackware 7 04-22-2008 03:50 PM
Numeric keypad behavior zeppelin1 Linux - Newbie 2 06-02-2007 04:30 AM
Numeric keypad arrow keys arielgr Linux - Newbie 2 08-23-2005 11:04 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Desktop

All times are GMT -5. The time now is 03:48 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration