-   Linux - Desktop (
-   -   kde4 refuses to retain the screen resolution that I choose. (

edbarx 10-14-2010 03:46 PM

kde4 refuses to retain the screen resolution that I choose.
I am currently using kde4 in Debian (Squeeze). I need to use a lower resolution than the one selected by kde4. Every time I change it to suit my needs, after rebooting in kde4, the resolution changes and the highest one supported by the GPU is automatically selected.

Please note, that I was never comfortable with native resolutions. More often that not, I change to one that is lower. I am using kde4 screen resize module that temporarily succeeded to change the screen resolution to that which I need.

I also tried to create an empty xorg.conf file with file permissions that allow everyone to write to it without success. The screen resolution applet, only changes the screen resolution for the current session, without bothering to save the changes so that they can be used by the successive boots.

Is there a way out of this labyrinth?

vectordrake 10-14-2010 04:16 PM

Are you trying to make this change as the root user? You'll likely have to do it as root.

edbarx 10-14-2010 05:07 PM


Originally Posted by vectordrake (Post 4127586)
Are you trying to make this change as the root user? You'll likely have to do it as root.

I tried to run the screen resize applet with root privileges but it failed to initialize itself and exited gracefully informing me that it couldn't initialize itself. Here is the error message:


root@edbarx-pc2:/home/edbarx# krandrtray
display-randr(2145): KUniqueApplication: Cannot find the D-Bus session server:  "Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken."

display-randr(2144): KUniqueApplication: Pipe closed unexpectedly.

edbarx 10-16-2010 03:27 PM

An alternative to reducing the resolution is to use more readable fonts i.e. bolder although not bold as real bold characters. This used to happen when I used an NVIDIA GPU but now I am using an intel GPU. Is there a good document that I can consult to create a custom xml file to replace /home/myusername/.fonts.conf?

As a side note: I am not exactly a Linux beginner. I have been using Debian for the past five years or so. Please, give me a true kick start with my new laptop. :)


vectordrake 10-16-2010 03:37 PM

This post on this Arch list seems to have an answer that might work for you.

edbarx 10-16-2010 03:59 PM

Thanks for the link. I read the linked thread for more information. It seems that it may work.

Thanks a lot.

vectordrake 10-16-2010 07:41 PM

I hope that this is the most elegant solution, at least until they decide to incorporate a proper fix in the DE.

mecelec415 10-17-2010 06:52 PM

gday I dont really know much so may be of no help any if your using KDE would that make xorg.confg the file config file for the grahic driver ?edit it and set the screen res there? its in etc/x11
after looking at my xorg.conf Have you tried the XFdrake to change the res ?

All times are GMT -5. The time now is 07:22 AM.