LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Desktop
User Name
Password
Linux - Desktop This forum is for the discussion of all Linux Software used in a desktop context.

Notices


Reply
  Search this Thread
Old 11-28-2009, 11:40 PM   #1
nglbrkr
Member
 
Registered: May 2005
Location: hiroshima
Distribution: debian
Posts: 75
Blog Entries: 9

Rep: Reputation: 17
KDE logout options


When logging out of KDE 3.5 on my debian lenny laptop, I have an option of shutting down the machine.

However, when logging out of KDE 3.5 on a debian-edu lenny laptop, the only option is "end current session". Debian-edu is debian configured for schools, and is very close to debian.

No-one on the debian-edu list seems to know how to get the option to shut down the machine, so it doesn't seem to be something they have done.

Does anyone know how I can enable the shutdown option from the logout dialogue? I suppose it must be somewhere in the KDE settings, but I can't find it.

thanks
nigel
 
Old 11-29-2009, 02:35 AM   #2
David the H.
Bash Guru
 
Registered: Jun 2004
Location: Osaka, Japan
Distribution: Debian + kde 4 / 5
Posts: 6,848

Rep: Reputation: 2013Reputation: 2013Reputation: 2013Reputation: 2013Reputation: 2013Reputation: 2013Reputation: 2013Reputation: 2013Reputation: 2013Reputation: 2013Reputation: 2013
The logout/shutdown settings are included in the login manager (kdm) module.

Assuming the debian-edu version hasn't been modified, of course.
 
Old 11-29-2009, 06:18 PM   #3
nglbrkr
Member
 
Registered: May 2005
Location: hiroshima
Distribution: debian
Posts: 75

Original Poster
Blog Entries: 9

Rep: Reputation: 17
I have tried everything I can see in /etc/kde3/kdm/kdmrc, but nothing will give me those logout options.

I have read some kubuntu threads about 3d video drivers, but I don't think that can be it, since the exact same laptop running plain lenny has the shutdown options.

However, if video drivers can disable shutdown, then it sounds like something buggy going on, so perhaps my quest for the right conf file will be in vain.
 
Old 11-29-2009, 10:52 PM   #4
David the H.
Bash Guru
 
Registered: Jun 2004
Location: Osaka, Japan
Distribution: Debian + kde 4 / 5
Posts: 6,848

Rep: Reputation: 2013Reputation: 2013Reputation: 2013Reputation: 2013Reputation: 2013Reputation: 2013Reputation: 2013Reputation: 2013Reputation: 2013Reputation: 2013Reputation: 2013
I was thinking more about the gui control center, actually, which is where I find the shutdown settings.

My kdmrc has the following entries:

Code:
[Shutdown]
BootManager=Grub
HaltCmd=/sbin/halt
RebootCmd=/sbin/reboot

[X-*-Core]
AllowNullPasswd=false
AllowRootLogin=false
AllowShutdown=Root
AutoReLogin=true
ClientLogFile=.xsession-errors-%s
Reset=/etc/kde3/kdm/Xreset
Session=/etc/kde3/kdm/Xsession
Setup=/etc/kde3/kdm/Xsetup
Startup=/etc/kde3/kdm/Xstartup

[X-:*-Core]
AllowNullPasswd=true
AllowShutdown=All
NoPassEnable=false
NoPassUsers=
ServerCmd=/usr/bin/X -br
Maybe these will help you.
 
Old 11-30-2009, 05:51 AM   #5
JZL240I-U
Senior Member
 
Registered: Apr 2003
Location: Germany
Distribution: openSuSE Tumbleweed-KDE, Mint 18.3+19.3, MX-18, Mandrake
Posts: 4,439

Rep: Reputation: Disabled
Go to the Kcontrol-Center as root or use YAST. It is either in groups and users or in security, I forget where exactly. You can enable / disable the feature there user-specifically.
 
Old 11-30-2009, 06:47 AM   #6
nglbrkr
Member
 
Registered: May 2005
Location: hiroshima
Distribution: debian
Posts: 75

Original Poster
Blog Entries: 9

Rep: Reputation: 17
Quote:
Originally Posted by JZL240I-U View Post
Go to the Kcontrol-Center as root or use YAST. It is either in groups and users or in security, I forget where exactly. You can enable / disable the feature there user-specifically.
Its under Login Manager, and is already set to "everybody", as is my kdmrc (thanks David, but mine is the same as yours - "All"), so there must be something else going on. I had a suggestion about kiosk mode, but I can't find anything in there either.

This is frustrating, since I'm in a school, and kids are loggin out and leaving the laptops on instead of shutting them down.

I appreciate your suggestions
 
Old 11-30-2009, 06:59 AM   #7
JZL240I-U
Senior Member
 
Registered: Apr 2003
Location: Germany
Distribution: openSuSE Tumbleweed-KDE, Mint 18.3+19.3, MX-18, Mandrake
Posts: 4,439

Rep: Reputation: Disabled
As a workaround you might change the command of the button to /sbin/halt ...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Logout and Cancel are only options in KDE Menu jvk Fedora 3 12-17-2008 09:39 PM
How do I disable "shutdown" and "restart" options in KDE logout screen for all users? maxgsp Linux - Distributions 1 12-12-2008 03:18 PM
Three LOGOUT options instead of one --> how? phodopus Linux - Desktop 9 02-18-2008 02:59 PM
FC6 logout options cj5cowboy Linux - Desktop 3 09-08-2007 12:18 PM
gnome logout/ more options jaa1180 Debian 8 07-08-2004 03:24 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Desktop

All times are GMT -5. The time now is 07:27 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration