LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Desktop (https://www.linuxquestions.org/questions/linux-desktop-74/)
-   -   K3b dies: "symbol lookup error" (https://www.linuxquestions.org/questions/linux-desktop-74/k3b-dies-symbol-lookup-error-477638/)

repentorperish 08-26-2006 05:52 PM

K3b dies: "symbol lookup error"
 
Hi.

I have been using k3b successfully on my slack 10.2/2.6.13 system for a few months. Now, when I select Tools -> Burn CD Image... the application dies silently. If I start from the command line, I get

Code:

k3b: (K3b::cutToWidth) not able to cut text to 29!
k3b: (K3bCdImageWritingDialog) slotToggleAll()
k3b: symbol lookup error: /opt/kde/lib/libk3b.so.2: undefined symbol: _ZN3KIO9NetAccess12mostLocalURLERK4KURLP7QWidget

I have been able to burn isos to CD successfully in the past. I first had this problem today with 0.12.16; I just removed this package and reinstalled; then removed again and installed 0.12.17 -- all with the same error at the same point. in case this is of any use to anybody (somebody with a similar error talked about these links being wrong):

Code:

/opt/kde/lib$ ls -l libk3b*
-rwxr-xr-x  1 root root    1757 2006-08-23 18:21 libk3b.la
lrwxrwxrwx  1 root root      15 2006-08-26 22:00 libk3b.so -> libk3b.so.2.0.0
lrwxrwxrwx  1 root root      15 2006-08-26 22:00 libk3b.so.2 -> libk3b.so.2.0.0
-rwxr-xr-x  1 root root 1877824 2006-08-23 20:01 libk3b.so.2.0.0
-rwxr-xr-x  1 root root    1690 2006-08-23 18:08 libk3bdevice.la
lrwxrwxrwx  1 root root      21 2006-08-26 22:00 libk3bdevice.so -> libk3bdevice.so.2.0.1
lrwxrwxrwx  1 root root      21 2006-08-26 22:00 libk3bdevice.so.2 -> libk3bdevice.so.2.0.1
-rwxr-xr-x  1 root root  258556 2006-08-23 20:01 libk3bdevice.so.2.0.1

Anybody have any ideas what the problem might be?

Cheers,

RoP.

xode 08-28-2006 01:00 AM

The quickest way for you to fix the problem might be for you to completely uninstall k3b and then reinstall the latest version of k3b that worked properly. Further, you will also want to delete any k3b configuration data directories for those users that were using k3b.


All times are GMT -5. The time now is 10:15 PM.