-   Linux - Desktop (
-   -   Javascript problems in Firefox 15 (or recent versions) (

Ilgar 10-03-2012 03:54 PM

Javascript problems in Firefox 15 (or recent versions)
Hi all,

I want to find out if there's anyone having the problems I describe below. By the way, I'm no Linux noob, the reason I'm asking here is my belief that if this were a common problem there would have been tons of web pages or bug reports about it but I can't find anything useful in Google. So I suspect that there is something wrong with my specific configuration.

The problem is that, with Firefox, Javascript doesn't seem to work properly on some pages. For example, Facebook is totally broken: The account menu at the upper right corner doesn't open at all. Auto-complete or auto-find of names in text entry boxes don't work, etc. Everything works well using Chromium.

As I don't use Facebook often, I can live without it, but in the recent days LQ's "Forum Tools" pull down menu stopped working, too. I was using it to mark all the messages as read, for example. Now when I click the link, instead of seeing a menu, I'm taken down to the bottom of the page where the menu entries are listed as links. And again, everything works as it should if I use Chromium.

And yes, I've confirmed this problem with all add-ons disabled (in safe mode), and I've even deleted my old ~/.mozilla/firefox directory to start over.

The weird thing is that I've seen the Facebook issue in Windows, too (haven't checked for LQ, though). So my problem may not be Linux-specific, but as I said, if Firefox had such a bug, huge numbers of people would notice it, but I can't find similar bug reports. Is it just me or what?

Oh btw, I have Javascript enabled, of course. I don't remember exactly when the issues began, but certainly they came up in the recent versions of Firefox (maybe >= 11 ???). I'm running Slackware 14.0, upgraded from 13.37 a few days ago.

SecretCode 10-04-2012 12:27 PM

Although you've started in safe mode and deleted .mozilla/firefox, I wonder if creating a new Linux user account and testing in that would be informative.

I haven't seen such issues in recent versions of Firefox, specifically not here. But I recall seeing symptoms like that with vBulletin boards when the pages did not load completely. Either because the server was being slow (there were some issues at LQ a few weeks ago but none that I'm aware of now) or because of local network issues. The fact that you've seen issues on Windows too does suggest network issues to me.

Do you have any hosts redirection? Are you going through an http-caching proxy server? Do you have good quality internet speed, latency, jitter and packet loss?

Ilgar 10-04-2012 02:00 PM

I just tried Facebook under a new account and it worked correctly. But I need further trials, because the symptoms I listed above sometimes disappear. Also,

- I have ADSL connection. I observed these problems under different wi-fi connections, too. So I don't think it is a network issue.

- There is no problem about loading pages. It is the stuff requiring Javascript that gets broken. Even when the JS error console doesn't report anything the problems occur.

- I observed the Facebook issue under windows on a different computer at a totally different location. That was what made think that Firefox was the problem.

Although some of these tests were made at different locations, they were all using the connection provided by the same ISP. But if it is the ISP, why do IE or Chromium work just fine?

SecretCode 10-04-2012 02:24 PM

I agree network problems are certainly not the only possible cause - but still possible. The page can appear loaded, but separate js files might be required and fail to load. It's possible that IE & Chromium have different behaviour in terms of retrying or not presenting the page at all if not all parts are available. And there's no guarantee that ADSL connections are good! They can have high attenuation or poor signal to noise ratio.

I just don't see how the symptoms can be related to javascript in Firefox if you found them after erasing your firefox profile (so you had all default settings). They don't affect everyone, after all.

Ilgar 10-04-2012 02:36 PM

I'm quite sure the ADSL line is OK. One of the places I used my computer was only 200m away from the telecom company's local hub! The control panel of the ADSL modem I'm using right now doesn't report any packet errors.

Ilgar 10-04-2012 02:39 PM

And also, the "Forum Tools" menu here was working up until a few days ago. I don't remember if it stopped functioning at the same time as my upgrade to Slackware 14.0, but I was using the same Firefox version on Slackware 13.37 anyway.

All times are GMT -5. The time now is 11:25 AM.