-   Linux - Desktop (
-   -   Icons missing from KDE4 system tray (

Mleahy 10-26-2009 07:55 PM

Icons missing from KDE4 system tray
Hello all,

I'm currently running Fedora 10 64-bit, with KDE 4.3 installed from the Red Hat KDE repos. It seems that recently (i.e., within the past couple days) something has changed that is now causing system tray icons to not be displayed properly for gnome or kde3-based applications (e.g., pidgin, gSTM, or knetworkmanager).

I just upgraded to KDE 4.3.2, although this started happening before that update with KDE 4.3.1.

Does anybody know what could be the cause? I hadn't rebooted my computer for a week or so, so any updates that came through over that time could be the source of the problem.

In any case, I've tried moving the .kde folder in my home directory to a backup location to see if it was a problem with the KDE configuration, but that didn't seem to resolve the problem.

Any suggestions would be really appreciated.


foodown 10-26-2009 08:25 PM

Check for any updates to your display drivers or X11 packages . . . try rolling those back and see if it doesn't solve the issue.

At one point before the 13.0 release, there was an X11 update to Slackware-current that caused similar system tray issues as well as crashes from compositing errors. The Slackware team quickly rebuilt the packages repairing the issue.

If rolling back the updates does solve the issue, I'd notify the Fedora development team.

Mleahy 10-26-2009 08:33 PM

There haven't been any recent updates for x11 or display drivers that I can tell from yum.log - certainly not since the last time I rebooted and had icons that worked.

There is a new kernel however - I'll reboot into an older one and see if that fixes it.

Mleahy 10-26-2009 08:41 PM's the kernel.

The icons work fine in, but go screwy in I had updated just over a week ago.

It's not quite what you suggested, but making me take another look helped me spot the problem.


All times are GMT -5. The time now is 08:14 AM.