Download your favorite Linux distribution at LQ ISO.
Go Back > Forums > Linux Forums > Linux - Desktop
User Name
Linux - Desktop This forum is for the discussion of all Linux Software used in a desktop context.


  Search this Thread
Old 07-20-2011, 04:30 PM   #1
LQ Newbie
Registered: May 2006
Posts: 2

Rep: Reputation: 0
howto get hi res screens with Ubuntu 10.04 and ATI Rage XL card

I can only get 640x480 as highest resolution. Dell 2650 with ATI rage xl 8 mb card in it. Can't change the card. Some suggestions are to change the xconf file, but it doesn't exist, appparently X functions now in the kernel!?
Sooo, how the heck do I get the higher resolutions???
Old 07-21-2011, 08:46 AM   #2
Registered: Dec 2009
Location: Germany
Distribution: Whatever fits the task best
Posts: 17,148
Blog Entries: 2

Rep: Reputation: 4863Reputation: 4863Reputation: 4863Reputation: 4863Reputation: 4863Reputation: 4863Reputation: 4863Reputation: 4863Reputation: 4863Reputation: 4863Reputation: 4863
Which distribution? Do you have the drivers installed?
If there is no xorg.conf file just create one.
Old 07-21-2011, 08:59 AM   #3
LQ Guru
Registered: Sep 2003
Location: Bologna
Distribution: CentOS 6.5 OpenSuSE 12.3
Posts: 10,509

Rep: Reputation: 1978Reputation: 1978Reputation: 1978Reputation: 1978Reputation: 1978Reputation: 1978Reputation: 1978Reputation: 1978Reputation: 1978Reputation: 1978Reputation: 1978
Once I successfully set a higher resolution using the xrandr utility. It was on Scientific Linux 6, but the procedure should be the same on Ubuntu. You need xrandr provided by x11-xserver-utils and cvt provided by xserver-xorg-core. Here is what I've done:
#  Check the current available resolution
xrandr -q
#  Compute a new mode (1280x1024)
cvt 1280 1024
#  Define the new mode (use the Modeline given by the previous command)
xrandr --newmode "1280x1024_60.00"  109.00  1280 1368 1496 1712  1024 1027 1034 1063 -hsync +vsync
#  Add the new mode
xrandr --addmode VGA1 1280x1024_60.00
#  Test the new resolution
xrandr --output VGA1 --mode 1280x1024_60.00
If all goes well you have to make changes permanent, by editing /etc/gdm/Init/Default (I assume you use GNOME) and add the last three xrandr commands as above. Then in System --> Preferences --> Display choose the new resolution and apply. Hope this helps.
Old 07-22-2011, 12:02 AM   #4
LQ Newbie
Registered: May 2006
Posts: 2

Original Poster
Rep: Reputation: 0
resolution of resolution problem

Thanks. I'm using Ubuntu 10.04. Thing is, the wise Ubuntuistias seem to have put all the display stuff in the kernel. Why the $#^%&$% I don't know, I thought the kernel was not supposed to have that kind of stuff in it but what the heck.
I'll try making a .conf file, colucix, and your suggestion.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Ubuntu 9.10 and ATI Rage 128 graphics card Jeff91 Linux - Hardware 2 04-10-2010 12:01 AM
grafic card ati rage xl code88 Linux - Hardware 2 12-24-2006 04:39 AM
ATI drivers for old ATI Rage LT Pro card? Kramer Linux - Hardware 7 12-22-2005 09:55 AM
OpenGL with ATI Rage card neomage Linux - Hardware 1 12-31-2003 07:45 AM
ATI 3D Rage Pro Video Card kystandardbred Linux - Hardware 4 02-14-2003 04:22 PM > Forums > Linux Forums > Linux - Desktop

All times are GMT -5. The time now is 03:34 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration