LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Desktop
User Name
Password
Linux - Desktop This forum is for the discussion of all Linux Software used in a desktop context.

Notices


Reply
  Search this Thread
Old 07-06-2016, 01:59 AM   #1
ronaldv
Member
 
Registered: Sep 2003
Location: Amsterdam
Distribution: Mandrake 10.1/2006
Posts: 57

Rep: Reputation: 16
Thumbs up High CPU by Xorg on Linux Mint Mate and Ubuntu + Mate


Hi,

i had a problem with both Linux Mint Mate 17.3 and Ubuntu 16.04 + Mate desktop (different machines). After some time (from minutes to hours) the Xorg process would jump to high cpu (100% of 1 thread) and never slowing down again.

After disabling several programs/extensions/add-ons i found that disabling 'Compositing' in the Windows Manager solved the issue.

This can be configured in the Desktop Settings -> Windows.

The Linux Mint was running the marco window manager. For ubuntu i can't tell.
 
Old 07-10-2016, 01:33 PM   #2
wagscat123
Member
 
Registered: Jan 2009
Location: Maryland-Pennsylvania border, USA
Distribution: openSUSE 15.1, Tumbleweed, macOS 10.12, Ubuntu 18.10/19.04, Mageia 6, and Linux Mint 19.1
Posts: 760
Blog Entries: 11

Rep: Reputation: 107Reputation: 107
Quick question - how old is your hardware? Better, what hardware are you using and what is its specs?
 
Old 07-11-2016, 03:00 AM   #3
ronaldv
Member
 
Registered: Sep 2003
Location: Amsterdam
Distribution: Mandrake 10.1/2006
Posts: 57

Original Poster
Rep: Reputation: 16
Well the hardware is recent enough:

Intel(R) Core(TM) i5-3337U CPU @ 1.80GHz
6 GB memory
VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09)
OpenGL vendor string: Intel Open Source Technology Center
OpenGL renderer string: Mesa DRI Intel(R) Ivybridge Mobile
OpenGL core profile version string: 3.3 (Core Profile) Mesa 11.2.0

The other system that shows the problem is even more recent.
 
Old 07-12-2016, 12:22 PM   #4
wagscat123
Member
 
Registered: Jan 2009
Location: Maryland-Pennsylvania border, USA
Distribution: openSUSE 15.1, Tumbleweed, macOS 10.12, Ubuntu 18.10/19.04, Mageia 6, and Linux Mint 19.1
Posts: 760
Blog Entries: 11

Rep: Reputation: 107Reputation: 107
That's odd. It didn't occur with older versions of Mint. So what are specs of the other machine, and which ones are running Ubuntu MATE and Mint 17.3 MATE?

If it's the same hardware, and wasn't present in older versions of Mint and Ubuntu, it may be a software bug.
 
Old 07-12-2016, 02:45 PM   #5
wagscat123
Member
 
Registered: Jan 2009
Location: Maryland-Pennsylvania border, USA
Distribution: openSUSE 15.1, Tumbleweed, macOS 10.12, Ubuntu 18.10/19.04, Mageia 6, and Linux Mint 19.1
Posts: 760
Blog Entries: 11

Rep: Reputation: 107Reputation: 107
What happens when you try running another GTK based fat free DE like XFCE? Or just another DE/window manager in general? And with the Marco (MATE's Metacity) window manager?
 
Old 07-14-2016, 03:11 AM   #6
ondoho
LQ Addict
 
Registered: Dec 2013
Posts: 11,617
Blog Entries: 9

Rep: Reputation: 3076Reputation: 3076Reputation: 3076Reputation: 3076Reputation: 3076Reputation: 3076Reputation: 3076Reputation: 3076Reputation: 3076Reputation: 3076Reputation: 3076
i don't see how the behavior can be consistent on 3 completely different (different distro, different hardware) machines, so can you give more detail?

generally and from what info you provided, i can say that hardware accelaration on newer intel chips/gpus is not working perfectly yet; that COULD explain why disabling compositing helps.

Last edited by ondoho; 07-14-2016 at 03:13 AM.
 
1 members found this post helpful.
Old 07-26-2016, 07:19 AM   #7
dherik
LQ Newbie
 
Registered: Jul 2016
Posts: 1

Rep: Reputation: Disabled
Hi!

I have the same problem using Mate Desktop 1.12.1 with Ubuntu 16.04. I'm using Intel graphics too.

Quote:
After disabling several programs/extensions/add-ons i found that disabling 'Compositing' in the Windows Manager solved the issue.
I will do that and confirm if it will resolve my problem too.
 
Old 04-11-2017, 07:27 AM   #8
rabinnh
LQ Newbie
 
Registered: Apr 2017
Posts: 1

Rep: Reputation: Disabled
For Mate, change to GPU rendering

To elaborate on the previous user's entry.

Download mate-tweak

Go to "Windows"

Change the Window Manager to use "GPU accelerated". If you're using Compiz

"Compiz (Advanced GPU accelerated desktop effects"

else

Marco (Compton GPU compositor)

Now your GPU will handle the load and CPU load will be reduced.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
MINT 17.3 MATE - mintmenu 100% cpu, and them change every 0.5 sec, berk0 Linux Mint 3 06-11-2016 02:36 AM
LXer: Linux Mint 17.2 “Rafaela” MATE RC Is Out and Based on MATE 1.10 LXer Syndicated Linux News 0 06-17-2015 11:32 PM
LXer: Ubuntu MATE 15.04 Arrives With MATE Desktop 1.8.2 and MATE Tweak LXer Syndicated Linux News 0 05-15-2015 09:30 AM
[SOLVED] Mate switched to cinnamon wthout permission mint-13-mate littlejoe5 Linux Mint 7 05-08-2014 10:54 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Desktop

All times are GMT -5. The time now is 04:08 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration