-   Linux - Desktop (
-   -   HAL (0.5.12) Keyboard and Mouse problems with GNOME 2.6; X.Org 1.5.3; Gentoo (

mdever44 11-19-2009 04:26 PM

HAL (0.5.12) Keyboard and Mouse problems with GNOME 2.6; X.Org 1.5.3; Gentoo
Recently tried to upgrade from GNOME 2.4 to 2.6, and I've been having troubles since. My chief problem is that my keyboard doesn't work when HALD is running. It works without it running, but unfortunately 2.6 pretty much requires HAL with Nautilus and such. I found a similar bug here:
but that doesn't seem to describe my situation as the key codes parsed by the apps seem to be constant, depending only on the key I press. Basically, when I try to type, it appears to be sending the key I pressed, with a bunch of garbage appended to it. I attempted to fix it by reinstalling HAL and X, but achieved nothing. Deleting config files in my home didn't work either. Eventually I got frustrated and decided to try running in root (I know that's stupid and something that I really shouldn't do). I got an error message that told me there was an error activating XKB config; and that the bug was in libxklavier, in X Server, or I was using an incompatible libxkbfile with X. It told me to run

xprop -root | grep XKB

gconftool-2 -R /desktop/gnome/peripherals/keyboard/kbd
So I did. Here are their outputs:

xprop -root | grep XKB
_XKB_RULES_NAMES_BACKUP(STRING) = "evdev", "evdev", "gb,pl", ",winkeys", "grp:caps_toggle, gp_led:caps,compose:ralt
_XKB_RULES_NAMES(STRING) = "evdev", "evdev", "gb,pl", ",winkeys", "grp:caps_toggle, gp_led:caps,compose:ralt


gconftool-2 -R /desktop/gnome/peripherals/keyboard/kbd
layouts = []
options = []
model = compaqeak8

I'm not completely sure if that eak8 is meant to be there or was appended by pressing enter, but the keyboard is a compaq. Another bug report I noticed from X was this:

Failed to load module "dri" (module does not exist, 0)
The XKEYBOARD keymap compiler (xkbcomp) reports:
> Error: No Symbols named "winkeys" in the include file "pl"
>                        Exiting
> Abandoning symbols file "default"

I have a suspicion that this is the cause of all my woes, but found little in my search for a resolution. I'm guessing that the first error is unrelated. In any case, here is my xorg.conf file:

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 1.0  (buildmeister@builder62)  Tue Jul 28 19:51:18 PDT 2009

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 1.0  (buildmeister@builder62)  Tue Jul 28 19:48:57 PDT 2009

Section "ServerLayout"
    Identifier    "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"

Section "Files"

Section "Module"
#    Load          "evdev"
    Load          "glx"

Section "ServerFlags"
    Option        "AllowEmptyInput" "off"
    Option        "Xinerama" "0"

Section "InputDevice"

    # generated from data in "/etc/conf.d/gpm"
    Identifier    "Mouse0"
    Driver        "mouse"
    Option        "Protocol"
    Option        "Device" "/dev/input/mice"
    Option        "Emulate3Buttons" "no"
    Option        "ZAxisMapping" "4 5"

Section "InputDevice"

    # generated from default
    Identifier    "Keyboard0"
    Driver        "kbd"

Section "Monitor"
    Identifier    "Monitor0"
    VendorName    "Unknown"
    ModelName      "SAMSUNG"
    HorizSync      30.0 - 81.0
    VertRefresh    56.0 - 75.0
    Option        "DPMS"

Section "Device"
    Identifier    "Device0"
    Driver        "nvidia"
    VendorName    "NVIDIA Corporation"
    BoardName      "GeForce 8600 GT"
    Option        "VBERestore" "true

Section "Screen"
    Identifier    "Screen0"
    Device        "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option        "TwinView" "0"
    Option        "TwinViewXineramaInfoOrder" "CRT-0"
    Option        "metamodes" "1280x1024 +0+0; nvidia-auto-select +0+0"
    Option        "ADDARGBGLXVisuals true"
    SubSection    "Display"
        Depth      24

Thanks in advance.

markush 11-20-2009 05:50 PM

Hello mdever44 and welcome to LQ,

I experienced a peculiar behavior of my keyboard recently. I got a new computer and therefore did a completely new install of Gentoo. I'm not running Gnome but fvwm2.

I have deleted my xorg.conf. If hal is properly configured one will need no xorg.conf. Be aware, that you have to copy the necessary fdi-files to /etc/hal/fdi/policy/. You'll find this files in /usr/share/hal/fdi/policy/10osvendor. You'll need at least the file for the keymap and input (the mouse). One may configure the 10-keymap.fdi file for other keyboards than "us". The fdi-files use XML.

This works with Gentoo and Slackware properly but since I had a problem with my German keybindings I use the setxkbmap command within my .xinitrc.


mdever44 11-20-2009 08:03 PM

Well, copying 10osvendor over to /etc/hal/fdi/policy didn't help. I did some searching on configuring HAL, but I couldn't find anything other than the LFS book; which didn't say much. Running "setxkbmap us" (I want a us keymap) didn't help; and removing xorg.conf prevented X from finding a screen. So I'm still stuck. Any other ideas?

markush 11-21-2009 05:44 AM



Originally Posted by mdever44 (Post 3764507)
... Running "setxkbmap us" (I want a us keymap) didn't help

well, since "us" is the default you don't have to configure this.

Did you upgrade xorg-server as well? It maybe possible that there is an incompatibility in the versions of xorg and Gnome. I refer to this thread: Did you "emerge --sync" before reinstalling xorg? What is the output of "emerge -Dupv xorg-server?


mdever44 11-21-2009 11:51 AM

I tried updating xorg to 1.6, still no results. I don't think that the incompatibility is between xorg 1.5 and gnome; as I also run xfce and it suffers from the same problem when HALD is running.
The output of "emerge -Dupv xorg-server" basically told me it was going to upgrade xorg and told me it would update xorg to 1.6 and install a few more packages.

markush 11-21-2009 12:22 PM


Originally Posted by mdever44 (Post 3765019)
I tried updating xorg to 1.6 ....

You tried ... did you update or not?

Well, may be that it is not an incompatibility between xorg and Gnome but xorg and hal.
I'd recommend to perform an upgrade of the whole system since if I understood correct that your system once ran properly (before upgrading Gnome).

I'm running Gentoo amd64 on 3 Computers with the latest updates installed and my systems are running properly (with fvwm as a Windowmanager).

If you need more help please post the output of "emerge -Dupv xorg-server" and the settings for the inputdevices (and graphics-adapter) in your make.conf


mdever44 11-21-2009 12:54 PM

The update was successful. I should have posted "emerge -Dupv xorg-server" before, but I expected it would just tell you I was reinstalling xorg 1.6 (I missed the update flag). That was not the case, and here is the output now:

emerge -Dupv xorg-server

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild    U ] net-misc/mDNSResponder-212.1 [107.6-r5] USE="-debug -doc -java" 1,575 kB [0]
[ebuild    U ] sys-devel/autoconf-wrapper-7 [6] 0 kB [0]
[ebuild    U ] sys-libs/timezone-data-2009p [2009m] USE="nls" 179 kB [0]
[ebuild    U ] media-libs/tiff-3.9.2 [3.8.2-r8] USE="cxx%* jpeg zlib -jbig (-nocxx%)" 1,387 kB [0]
[ebuild    U ] sys-apps/baselayout-1.12.13 [] USE="unicode -bootstrap -build -static" 264 kB [0]
[ebuild    U ] sys-devel/gcc-4.4.2-r1 [4.4.2] USE="fortran gcj graphite gtk mudflap nls nptl openmp (-altivec) -bootstrap -build -doc (-fixed-point) (-hardened) -ip28 -ip32r10k (-libffi) (-multilib) -multislot (-n32) (-n64) -nocxx -objc -objc++ -objc-gc -test -vanilla" 20 kB [0=>1]
[ebuild    U ] sys-libs/glibc-2.9_p20081201-r4 [2.9_p20081201-r2] USE="nls -debug -gd -glibc-omitfp (-hardened) (-multilib) -profile (-selinux) -vanilla" 0 kB [0=>1]
[ebuild    U ] dev-db/mysql-5.0.84-r1 [5.0.70-r1] USE="berkdb community%* perl ssl -big-tables -cluster -debug -embedded -extraengine -latin1 -max-idx-128 -minimal -profiling% (-selinux) -static" 35,973 kB [0]
[ebuild    U ] dev-lang/php-5.2.11-r1 [5.2.11] USE="berkdb bzip2 cli crypt exif gdbm iconv imap ipv6 mysql mysqli ncurses nls pcre posix readline reflection session sockets spell spl ssl sysvipc threads truetype unicode xml zlib (-adabas) -apache2 -bcmath (-birdstep) -calendar -cdb -cgi -cjk -concurrentmodphp -ctype -curl -curlwrappers -db2 -dbase (-dbmaker) -debug -discard-path -doc (-empress) (-empress-bcs) (-esoob) -fastbuild (-fdftk) -filter (-firebird) -flatfile -force-cgi-redirect (-frontbase) -ftp -gd -gd-external -gmp -hash -inifile -interbase -iodbc (-java-external) -json -kerberos -kolab -ldap -ldap-sasl -libedit -mcve -mhash -msql -mssql -oci8 -oci8-instant-client -odbc -pcntl -pdo -pic -postgres -qdbm -recode -sapdb -sharedext -sharedmem -simplexml -snmp -soap (-solid) -sqlite -suhosin (-sybase) (-sybase-ct) -tidy -tokenizer -wddx -xmlreader -xmlrpc -xmlwriter -xpm -xsl -yaz -zip" 11 kB [0]
[ebuild    U ] net-fs/samba-3.0.37 [3.0.36] USE="acl cups ipv6 pam python readline syslog -ads -async -automount -caps -debug -doc -examples -fam -ldap -oav -quotas (-selinux) -swat -winbind" 22,868 kB [0]

And my make.conf stuff:

INPUT_DEVICES="keyboard mouse"

I'm updating the rest of my stuff now; and will follow up on whether that fixed things or not. Thanks so far.

markush 11-21-2009 01:20 PM

You should add "evdev" to your inputdevices and try "emerge -pv xorg-server" if this changes something. If there is a difference, I'd recommend to rebuild xorg-server. But I'm not sure if this points in the right direction.


mdever44 11-21-2009 02:27 PM

I already tried adding evdev; it had no effect. I finished upgrading everything; no effect. I guess I'm re-emerging world tonight... How fun. Probably easier just to start everything over. Anyways, thanks for trying to help markush

markush 11-21-2009 02:38 PM

Well, be sure to add "-nls" (no "national language support") to your use-variables since with "us"-settings you will not need it although it's in the default for the desktop-profile.

Good luck.


All times are GMT -5. The time now is 06:48 AM.