-   Linux - Desktop (
-   -   Gui not working after system shut down unexpectedly (ubuntu 12.04) (

vignesh4sh 11-19-2012 05:33 AM

Gui not working after system shut down unexpectedly (ubuntu 12.04)

my machine shutdown unexpectively due to cable fault
when i start the machine.Graphical mode is not worked. only konsole has opened.
i tried "startx" command.

unable to connect to x server
server error
server terminal with error
After then
I installed "apt-get install kde"
I getting blue screen not even that konsole mode.Blue screen with login options not root and sudo users.
I used recovery mode also.but its saying gnome not supported
I struggling with this. please give me any idea.
my remote server auth keys are there in this machine.


malekmustaq 11-20-2012 12:51 AM

Have you tried running file system check after the unexpected shutdown?


~# fsck /filesystem_partition
There should be no need to reinstall KDE if it was running before hand.

vignesh4sh 11-20-2012 02:55 AM

Thanks for reply

Now, i am able to use gui mode by using single user mode


# service kdm start
# startx
But, by default, i not able to use gui mode and terminal mode.
Getting error


saned disabled

Stopping System V runlevel compatibility
then stucked


malekmustaq 11-20-2012 12:20 PM

I hope somebody from the ubuntu corner will come in, I cannot figure out with assurance. Cases like that I usually clear off the garbage:


sudo find /var -iname \*kde\*\*cache\* | xargs rm -fr
and also


sudo find /tmp -iname \*.kde\* | xargs rm -fr
You may try delete the lock nodes at the /tmp:


sudo find /tmp -iname \*lock | xargs rm -f
Press Ctl+Alt+Del to reboot. It might work.

Hope that helps. Good luck.

frankbell 11-20-2012 08:33 PM

Another test you could to, while logged into single user mode, is to create a new user. Then try logging in to regular mode as the new user. If the new user is able to log in and have functionality, odds are that one of the hidden dot-configuration files in your /home/[username] directory got scrambled in the mess.

You could try renaming one of them as root, then testing your login, and repeating until you identify the culprit. I'd start with the ones directly related to your desktop environment.

Alternatively, you could transfer your data to the new /home/[username] and go on with your life.:)

All times are GMT -5. The time now is 04:10 PM.