-   Linux - Desktop (
-   -   Gnome missing all interface and windows but log's in ... (

sulobaidsuevin 02-21-2014 03:43 PM

Gnome missing all interface and windows but log's in ...
:scratch:It is strange, before i used the PartedMagic DiskClone utility on a separate thumb drive i think i still had a full Gnome interface to log into but now all it has in it is docky, the cursor and the wallpaper. I wish i knew the shut down command for terminal because i can access it via docky's Terminator shortcut still from inside Gnome :confused:. I typically use cinnamon as default but when i noticed i could not install, download and change themes i began to inspect the shell. Within the gnome-tweak-tool under the theme section it shows a triangle with an ! in it and say's "could not list shell extension's". So i began to think it was something wrong with Gnome so that is how i found i had no Gnome interface. :banghead:

Currently i am trying to understand a few things 1st priority to last:

1: How to repair Gnome safely and get my interface back the way it was. :study:

2: Why can't i copy my disk i need to retain it for a backup, when i do it reads bad/black sectors in gparted. I have all sort's of software and tool's to deal with partitioning and diagnostics as well as 3 PC's. This worked yesterday before i went too far at testing/developing further to fast. (Those notes and log's i did keep/rescue - yay!

-SOLVED THIS ISSUE. I did what i did before and loaded the original before cloning and let them sit in PartedMagic for a bit before cloning them and lastly enlarged the partitioning structure on / and /home folder leaving the 1GB swap and 512 /boot partitions alone.

3: What is a "PangoWarning" -A problem i have no idea wear to post about but i think is system/font related since it occurred shortly after adding more fonts, i been documenting the variation of process ### 's. The specific error for this is as follows, (wear "###" is one 3 digit set each log-in of the list hear after the error):

(Process:###): Pango-WARNING **: failed to choose a font, expect ugly output. engine-type='PangoRenderFc',Script='latin'

208, 235, 247, 236, 228, 221, 217, 238, 233, 237, 205, 234, 209, 232, 240, 214, 242, 209 and 241.

4: For a system as described below, what would be a decent way to check and repair the overall system stability?

It is also important to realize that i have been developing a custom system for nearly a year now that can not be re-made or re-installed and it was made via a base install of Debian Linux Mint, (i forget which version number and name i.e. XFCE or Mate and wish i could find that info but not sure how safely at the moment.) The basic spec's are as follows:
Debian Kali Linux 1.0
kernel: 3.10-2-486
Processor: Intel Core Duo CPU L2400 @ 1.66GHz
LMDE Cinnamon Edition

:banghead: I spent weeks searching Google for 3 and 4 but 1 and 2 are recent,i searched DuckDuckGo and others and can not find a matching set of issues to a similar system to safely attempt tampering with this, i hope there is an expert out there who can help. As i continue my search for answers i will update this post.

Any one willing or trying to think of a way to help would be best from my experience to simply treat this no different than you would for Debian Linux Mint. It should work.

I am not sure what info or requirements would be necessary to find the information to share the necessary data to help analyze the problem and work to a solution, please advise and i will do my best. I really need to rescue what i have and will definitely learn from my mistakes. Thank you sincerely, Apology's for my bad English grammar/spelling. :o

Retrying to copy the disk, the original still booted fine but dose not have a Gnome session interface to it so the clone will not likely have one either, i am planning to use the clone as a test environment for this repair effort. I let the source disk and target disk sit for appx. 20 minutes before proceeding with the cloning via PartedMagic's CloneZilla feature, so far it actually cloned this time but the final part is to increase the / and /home partition size. I am taking a 32 GB disk and making it a 64GB disk with the exact same system.

2nd Update:
Ok, i am in the clone typing currently, very strange because i don't think simply letting it set 20 minutes was all of the reason this worked. I think in another part when i noticed it failed i used the original and it must have triggered something to reload or remake and the combination allowed it to copy. Noted.
So, leaving off, i recovered the files from the previous messed up system clone using PartedMagic also. I recovered what i thought would be the most useful/telling files intact entirely from the point of crash as follows:
Dissecting those should be a good thing.
Now that i have the old experiment in front of me original files i can give a bit more details. I figured i had better get some option's installed to my system before there no longer available because of support issues or whatever i fear i may be too late, i hope not. I did adjust the firewall settings on my modem and rougher both to be more Linux friendly for now but that is temporary. The files i was trying to improve on were various programs, the list is huge so per request i will provide it, applets, GTK Themes, MDM, Screenlets, Splash Screens, Various themes, backgrounds, icon's and i wanted to look into updating the source list from the online source list generator at but i had to go to Kali's site and Mint's site for the rest. I dunno if this is quite right but i got the following from the 3 yet have not changed from the old ones:
sudo gedit /etc/apt/sources.list
deb debian main upstream import
deb testing main contrib non-free
deb testing/updates main contrib non-free
deb testing main non-free

deb stable main contrib non-free
deb-src stable main contrib non-free

deb wheezy-updates main contrib non-free
deb-src wheezy-updates main contrib non-free

deb wheezy/updates main contrib non-free
deb-src wheezy/updates main contrib non-free

deb kali main non-free contrib
deb kali/updates main contrib non-free

deb-src kali main non-free contrib
deb-src kali/updates main contrib non-free

deb kali-bleeding-edge main

If a GPG error occurs do this:

gpg --keyserver --recv-key ED444FF07D8D0BF6
gpg -a --export ED444FF07D8D0BF6 | sudo apt-key add -

(Wear "ED444FF07D8D0BF6" is an example key number, replace with key number listed in the error to fix missing key issues.)

apt-get update

Most of them succeeded but still some failed, the following are the failed:

Err debian/main Sources
404 Not Found

Err debian/main i386 Packages
404 Not Found

W: Failed to fetch 404 Not Found

W: Failed to fetch 404 Not Found

It was at about this point i began noticing system wide instability's. Then it broke. But as i type, Gnome is STILL missing from the clone from its very beginning. Hmmm.

Before all that, i said previously hear i had been experimenting with installing some programs. Specifically:
Resulted in a "E: Sub-process /usr/bin/dpkg returned an error code (1)"
So i ran sudo apt-get install -f but alas... no joy So i then ran:
sudo -i
rm -rf /var/lib/dpkg/info/cheese.*
apt-get remove cheese
apt-get install cheese

"cheese" = package name as example not installed

And some wear along the way while this was happening, rather than leave it set i couldn't resist and found out i have GTK 2 and 3 both some how.

I thought running:
sudo dpkg --configure -a
sudo apt-get install gnome-shell
Would recover the Gnome interface but yet again no joy. Currently, i am not planning anything too drastic but i am gonna keep researching this Gnome issue and hope some one out there can help. Good stuff hear and i hope it helps. Been thinking also i should use something like FireFTP to download an entire repository near its end and keep a copy on one of my N.A.S.'s and point the old .iso's from my library to it instead of online sorta make my own private repo.

Regarding my original comment wishing i had the shutdown command: it turns out i did and it failed there when used. Considering i have many eBook's on Linux programming, development and implantation i should know this and read more.

One more thought i had was if i knew for sure which folders i needed to copy what i needed to replace/overwrite what is wrong i do have a 3rd setup i could do this threw PartedMagic's file browser and maybe run a boot repair on it, theoretically that may work if the files are not vastly tied to all of the system like it seems? I am becoming "terminally ill" from all the time spent in it, yea... i was warned long ago, lol! Cheer's y'all!

Update 3:
I did a lot of reaserch so far and hear is a list of some of what i tryed and the result thus far:

sudo /usr/bin/gdk-pixbuf-query-loaders --update-cache
and restarting gnome-shell

Result: Absolutly nothing noticable even after restart.

gconftool --recursive-unset /apps/panel && killall gnome-panel && sudo apt-get remove --purge gnome-panel && sudo apt-get install gnome-panel

Result: (When it asked for me to choose a display manager i chose gdm3 instead of mdm.)
Gnome failed completely, Gnome Flashback shouldn't even be present and it was the same issue and cinnamon failed completely also. Recloned disk again at this point. I did what i did before and loaded the original before cloning and let them sit in PartedMagic for a bit before cloning them and lastly enlarged the partitioning structure on / and /home folder leaving the 1GB swap and 512 /boot partitions alone.

To force Gnome to rewrite its panel menus with default values, enter the following command into a terminal:

mv ~/.config/menus/ ~/.config/menus/ && mv ~/.config/menus/ ~/.config/menus/

Result: mv: cannot stat '/home/username/.config/menus/': No such file or directory.

To force Gnome to recreate its panels with default values, enter the following commands into a terminal:

gconftool --recursive-unset /apps/panel (This wipes the panelís settings)

rm -rf ~/.gconf/apps/panel (This deletes the panelís folders and files)

killall gnome-panel (This forces the panel to close and restart)

Result: "killall gnome-panel" returned message: No process found. The first two did notthing visable. Restarted. No change.

yum install -y gnome-globalmenu-common gnome-applet-globalmenu

Edit: Instead of "yum" it should be "sudo apt-get".

Result: E: Unaible to locate package gnome-globalmenu-common E: Unaible to locate package gnome-applet-globalmenu

Trying to go threw software manager and investigate probable causes and effect as well as what may be missing.
gnome-shell (Was not installed so i am installing it. I chose MDM when asked to choose a display manager. Time took to install: about 3 hours.) after 4 hours i shutdown with the stuck screen and it refused to boot past the pango warning error screen at loading. Recloned.

I tried this from terminal via sudo apt-get install gnome-shell
Result: Failed! Started launching a new version i dont want and the same thing happened to the Cinnamon interface that happened with the Gnome one and BOTH were messed up as described in issue 1 of the 4.

Trying to go threw software manager and investigate probable causes and effect as well as what may be missing.
Trying: gnome-shell (Was not installed so i am installing it. I chose MDM when asked to choose a display manager instead of mdg3, yes i have multiple managers but only use one while the other must be hear and dormant for Kali to work. Time took to install: about 3 hours.) after 4 hours i shutdown with the stuck screen and it refused to boot past the pango warning error screen at loading. Re-cloned. Attempting threw terminal later on. Suspecting the app "Terminator" is causing various issues and system instability's also.

Recloning, copyed the Gnome files from a seperate instalation to place into the damaged one.
When that was complete i logged strait into the Gnome session and it did log in with start menu's and all that was missing with one major setback; no file manager would open. It said "Not found". basicly.

So now i am copying the same files from inside Cinamon interface, logging into gnome again and attempting to force the session manager to save the session. That faile3d so i am re-coppying the same files from PartedMagic and when i log back in i am going to try gnome-save-session to force it to stick if it loads.

Re-copying the same folder system did bring back the Gnome interface again, I brought up the root terminal and entered gnome-save-session and it was an invalid command. This time i pressed Alt+F2 and type gnome-session-properties then carefully reviewed the startup programs and unchecked a few needless ones and then proceeded to the second tab wear i then checked the box to enaible it to "Automaticly remember running aplications when logging out". I hit close to save and typed "Exit" in terminal then clicked log out, when i got to the log in window i clicked actions then shutdown. Clean booted. I logged into Cinnamon at this point, opened file manager to show desktop and shutdown, then logged back into Gnome. Instead it logged me into Cinnamon, i tryed restarting 3 times and it was the same; i select Gnome session and it loads the Cinnamon oneinstead EVEN IF i click on Cinnamon - yep.. its's Cinnamon. Lol. Now i loaded back into the PartedMagic USB and reloaded the files but now added all the /media/sdb7/usr/share laibled "Gnome" in it. No Joy but darn close because i can get Gnome back for one session log in then after it is entierly gone again!

These are the placment and names of the files copyed:

File System > usr > lib




What am i missing hear?

Problems 1 & 3 & 4 are yet unresolved.

arizonagroovejet 03-15-2014 01:42 PM


Your system is totally borked. Re-install it. If you don't have a back up of your important files then boot the machine from a Live CD, attach a USB drive and copy your home directory to it.

The Ubuntu install is CD is a Live CD, openSUSE also do Live CDs.

Your post is pretty much unreadable. Some formatting would help, such as wrapping the commands and contents of files in CODE tags (look for the # button in the toolbar when composing a post).

sulobaidsuevin 03-15-2014 02:15 PM

Yep, already planned to reinstall since Virtualbox can't recognize the kernel. I actually didn't intend to mess that up, just add the tool's and a few other parts non-kernal related.

As for backup i just clone my system simply, i tried the other software for backing up and have not been very impressed with it so far.

Fixed Gnome and the Pango error by simply updating those parts.

Lastly, i did not write this so that just any one can answer it, you must know what your looking at. I didn't expect an answer to any specific part but those were the only issues. This is a complex task that can be done if one is very careful. I have been doing this for a few years now to become as familiar hands on as possible with major parts of Linux and to shape something that suits my needs and is stable. I need to see what i CAN do and what is available then fill the gaps safely in order to achieve the goal of having a good system once and for all. I don't keep much on the system so no worries.

Thanks for your reply, i am sorry but your reply dose not answer any of the questions though.

All times are GMT -5. The time now is 05:08 PM.