LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Desktop
User Name
Password
Linux - Desktop This forum is for the discussion of all Linux Software used in a desktop context.

Notices


Reply
  Search this Thread
Old 08-24-2017, 07:01 AM   #16
Timatekore
Member
 
Registered: Mar 2013
Location: Planet Earth
Distribution: open SuSE, Knoppix, Android, Puppy
Posts: 37

Original Poster
Rep: Reputation: Disabled

Quote:
Originally Posted by ferrari View Post
In addition to the above, it might pay to check the following as well...

Code:
grep "POLKIT" /etc/sysconfig/security
although I don't expect to see any PolKit privilege restrictions here (unless you explicitly set them).

Hmmm, so how do I read this?:
Quote:
## Path: System/Security/PolicyKit
## Description: Configuration of default PolicyKit privileges
## Type: list(set,warn,no)
## Default: set
## Config: set_polkit_default_privs
#
# SuSEconfig can check PolicyKit default privileges.
# Setting this variable to "set" will change privileges that don't match the
# default. Setting to "warn" only prints a warning and "no" will
# disable this feature.
#
# Defaults to "set" if not specified
#
CHECK_POLKIT_PRIVS=""
 
Old 08-24-2017, 03:19 PM   #17
ferrari
Senior Member
 
Registered: Sep 2003
Location: Auckland, NZ
Distribution: openSUSE Leap
Posts: 3,316

Rep: Reputation: 559Reputation: 559Reputation: 559Reputation: 559Reputation: 559Reputation: 559
Okay so that checks out as expected.
 
Old 08-24-2017, 05:54 PM   #18
ferrari
Senior Member
 
Registered: Sep 2003
Location: Auckland, NZ
Distribution: openSUSE Leap
Posts: 3,316

Rep: Reputation: 559Reputation: 559Reputation: 559Reputation: 559Reputation: 559Reputation: 559
Check the following privilege...
Code:
pkaction --action-id org.freedesktop.udisks2.filesystem-mount --verbose
For reference I get
Code:
org.freedesktop.udisks2.filesystem-mount:
  description:       Mount a filesystem
  message:           Authentication is required to mount the filesystem
  vendor:            The udisks Project
  vendor_url:        http://udisks.freedesktop.org/
  icon:              drive-removable-media
  implicit any:      auth_admin
  implicit inactive: auth_admin
  implicit active:   yes
If necessary, that can be modified by adding a custom entry to /etc/polkit-default-privs.local
Code:
org.freedesktop.udisks2.filesystem-mount auth_admin:auth_admin:yes
then run the following for it to take effect
Code:
sudo /sbin/set_polkit_default_privs
* You may need to logout and back in as well.

Reference:
https://doc.opensuse.org/documentati...policykit.html
 
Old 08-25-2017, 03:50 AM   #19
Timatekore
Member
 
Registered: Mar 2013
Location: Planet Earth
Distribution: open SuSE, Knoppix, Android, Puppy
Posts: 37

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by ferrari View Post
Check the following privilege...
Code:
pkaction --action-id org.freedesktop.udisks2.filesystem-mount --verbose
For reference I get
Code:
org.freedesktop.udisks2.filesystem-mount:
  description:       Mount a filesystem
  message:           Authentication is required to mount the filesystem
  vendor:            The udisks Project
  vendor_url:        http://udisks.freedesktop.org/
  icon:              drive-removable-media
  implicit any:      auth_admin
  implicit inactive: auth_admin
  implicit active:   yes
I thought you could be on to something here:
Code:
pkaction --action-id org.freedesktop.udisks2.filesystem-mount --verbose
org.freedesktop.udisks2.filesystem-mount:
  description:       Mount a filesystem
  message:           Authentication is required to mount the filesystem
  vendor:            The udisks Project
  vendor_url:        http://udisks.freedesktop.org/
  icon:              drive-removable-media
  implicit any:      auth_admin
  implicit inactive: auth_admin
  implicit active:   yes
But alas, my policy config file already has that entry you mentioned:
Code:
org.freedesktop.udisks2.filesystem-mount auth_admin:auth_admin:yes
org.freedesktop.udisks2.filesystem-mount-system auth_admin:auth_admin:yes
org.freedesktop.udisks2.filesystem-mount-other-seat auth_admin:auth_admin:yes

Last edited by Timatekore; 08-25-2017 at 03:55 AM.
 
Old 08-25-2017, 05:07 AM   #20
ferrari
Senior Member
 
Registered: Sep 2003
Location: Auckland, NZ
Distribution: openSUSE Leap
Posts: 3,316

Rep: Reputation: 559Reputation: 559Reputation: 559Reputation: 559Reputation: 559Reputation: 559
Hmmmm...does 'loginctl' list your user session as expected?

For reference, I get
Code:
dean@linux-kgxs:~> loginctl
   SESSION        UID USER             SEAT            
         1       1000 dean             seat0           

1 sessions listed.
There was a bug with openSUSE 13.2 where autofs being enabled could cause problems with loginctl being started properly and leading to issues like this.
https://bugzilla.opensuse.org/show_bug.cgi?id=905639

Anyway easy enough to disable autofs (if not needed) with
Code:
sudo systemctl disable autofs
then reboot.

An old openSUSE thread discussing different issue but same underlying cause...
https://forums.opensuse.org/showthre...table-(0-9-3-4)
 
Old 08-25-2017, 05:13 AM   #21
ferrari
Senior Member
 
Registered: Sep 2003
Location: Auckland, NZ
Distribution: openSUSE Leap
Posts: 3,316

Rep: Reputation: 559Reputation: 559Reputation: 559Reputation: 559Reputation: 559Reputation: 559
A less secure workaround would be allow inactive users to have removable media mounting privileges using
Code:
org.freedesktop.udisks2.filesystem-mount auth_admin:yes:yes
but probably best just disable autofs, (or even consider upgrading to Leap as 13.2 is EOL).
 
Old 08-25-2017, 04:38 PM   #22
Timatekore
Member
 
Registered: Mar 2013
Location: Planet Earth
Distribution: open SuSE, Knoppix, Android, Puppy
Posts: 37

Original Poster
Rep: Reputation: Disabled
I did the systemctl disable autofs thingy, and then a reboot - still no difference.
Plus, I also did an upgrade to LEAP 42.3 (already two days ago) - and still no difference.
 
Old 08-25-2017, 05:37 PM   #23
ferrari
Senior Member
 
Registered: Sep 2003
Location: Auckland, NZ
Distribution: openSUSE Leap
Posts: 3,316

Rep: Reputation: 559Reputation: 559Reputation: 559Reputation: 559Reputation: 559Reputation: 559
That bug only applied to openSUSE 13.2. It would be useful to see what is reported by loginctl for your user. Additionally, create a new user account (with YaST) and log in via that account. Does udisk mounting work as expected there?
 
Old 08-25-2017, 05:41 PM   #24
ferrari
Senior Member
 
Registered: Sep 2003
Location: Auckland, NZ
Distribution: openSUSE Leap
Posts: 3,316

Rep: Reputation: 559Reputation: 559Reputation: 559Reputation: 559Reputation: 559Reputation: 559
BTW, did you try setting the privilege config as per post #21 yet? That should allow both active and inactive users to mount removable media.
 
Old 08-26-2017, 04:47 AM   #25
ferrari
Senior Member
 
Registered: Sep 2003
Location: Auckland, NZ
Distribution: openSUSE Leap
Posts: 3,316

Rep: Reputation: 559Reputation: 559Reputation: 559Reputation: 559Reputation: 559Reputation: 559
As you mentioned that you're now running Leap, can you confirm that sddm is in use?
Code:
sudo systemctl status display-manager
If not, change it so that it is via YaST > System > /etc/sysconfig Editor. In particular, /etc/sysconfig/displaymanager should contain
Code:
DISPLAYMANAGER="sddm"
 
Old 08-26-2017, 05:10 AM   #26
Shadow_7
Senior Member
 
Registered: Feb 2003
Distribution: debian
Posts: 3,609
Blog Entries: 1

Rep: Reputation: 782Reputation: 782Reputation: 782Reputation: 782Reputation: 782Reputation: 782Reputation: 782
Is autofs even installed?

$ sudo apt-get install autofs

It's probably grabbed as a dependency if you go with the distro's installers defaults. Or grab them after the fact.

$ sudo apt-get install ubuntu-desktop
or
$ sudo tasksel install gnome-desktop

Depending on distro and such.
 
Old 08-26-2017, 05:12 AM   #27
ferrari
Senior Member
 
Registered: Sep 2003
Location: Auckland, NZ
Distribution: openSUSE Leap
Posts: 3,316

Rep: Reputation: 559Reputation: 559Reputation: 559Reputation: 559Reputation: 559Reputation: 559
AutoFS has nothing to do with desktop mounting of USB media. It's handled via udev/udisks and the DE concerned.
 
Old 08-26-2017, 09:23 PM   #28
Shadow_7
Senior Member
 
Registered: Feb 2003
Distribution: debian
Posts: 3,609
Blog Entries: 1

Rep: Reputation: 782Reputation: 782Reputation: 782Reputation: 782Reputation: 782Reputation: 782Reputation: 782
Quote:
Originally Posted by ferrari View Post
AutoFS has nothing to do with desktop mounting of USB media. It's handled via udev/udisks and the DE concerned.
I depends on your distro. Some have autofs mount media to /media/... when detected, independently of any WM/DE via autofs.
 
Old 08-26-2017, 10:26 PM   #29
ferrari
Senior Member
 
Registered: Sep 2003
Location: Auckland, NZ
Distribution: openSUSE Leap
Posts: 3,316

Rep: Reputation: 559Reputation: 559Reputation: 559Reputation: 559Reputation: 559Reputation: 559
Yes, I've seen that (at least for Debian derivatives), but Gnome and KDE have used udisks2 implementations for years. In any case there is an apparent problem with logind here (still awaiting loginctl output tp confirm that from the OP).
 
Old 08-28-2017, 08:45 AM   #30
Timatekore
Member
 
Registered: Mar 2013
Location: Planet Earth
Distribution: open SuSE, Knoppix, Android, Puppy
Posts: 37

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by ferrari View Post
Yes, I've seen that (at least for Debian derivatives), but Gnome and KDE have used udisks2 implementations for years. In any case there is an apparent problem with logind here (still awaiting loginctl output tp confirm that from the OP).
Code:
oginctl user-status johndoe
batuta (1000)
           Since: Tue 2014-07-08 02:00:21 CEST; 3 years 1 months ago
           State: active
        Sessions: *3
            Unit: user-1000.slice
                  ├─session-3.scope
                  │ ├─3273 sshd: johndoe [priv]
                  │ └─3278 sshd: johndoe
                  └─user@1000.service
                    ├─593 /usr/lib/systemd/systemd --user
                    └─598 (sd-pam)

Last edited by Timatekore; 08-28-2017 at 09:05 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How do automount scripts work? flyinggeorge Linux - General 1 08-03-2013 11:01 AM
CentOS 5.2 Automount isos in fstab \other methods that work?automount iso Frankly3D Linux - General 6 07-13-2008 12:34 PM
usb automount: how does it work? iam whoiam Linux - General 1 08-12-2006 02:44 AM
automount didnt work PinRojas Debian 7 07-05-2005 11:29 AM
how to make automount work? jaan kaer Linux - Hardware 3 02-21-2004 07:20 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Desktop

All times are GMT -5. The time now is 04:41 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration