-   Linux - Desktop (
-   -   Get invalid volume specification from shell script (

sadams54 11-03-2013 02:52 PM

Get invalid volume specification from shell script
I am trying to make a shell script to control volume on the system.

pactl -- set-sink-volume 0 -10%

that line works perfect from the command line. However if I create a shell script I get "invalid volume specification" when I run the script. The script has only one line in it which is shown above. I am not experienced in shell scripts so if I am doing something wrong, correct me. I called the script file and execute using the command sh I am so close to finishing this project and this is what stands in my way. PLEASE HELP.

I have changed the relative volume setting to a specific one and get same error.

Habitual 11-03-2013 04:30 PM


pactl \-\- set-sink-volume 0 \-10\%

P.S. Which "shell"?

sadams54 11-03-2013 08:36 PM

no joy
I tried your suggestion but still same problem. This is on Fedora 18. I was so hoping your thought would work. DARN THE LUCK

All times are GMT -5. The time now is 01:19 PM.