Welcome to the most active Linux Forum on the web.
Go Back > Forums > Linux Forums > Linux - Desktop
User Name
Linux - Desktop This forum is for the discussion of all Linux Software used in a desktop context.


  Search this Thread
Old 04-25-2007, 01:15 PM   #1
Registered: Nov 2003
Location: New Zealand
Distribution: Ubuntu 6.10/7.04
Posts: 51

Rep: Reputation: 15
GDM stuck using XDMCP / cant log in locally


I accidentally ticked some crazy box somewhere before rebooting my Ubuntu 7.04, it has goofed up my login screen.

After booting, it presents me with the XDMCP login screen. All it lets me do is search for XDMCP computers on the network, and NOTHING else. Clicking cancel returns me back to the same screen.

I don't understand how /etc/gdm/gdm.conf works, so I replaced it with factory-gdm.conf to try that.
I also installed XDM at some point during my fiddling and now I don't know what on earth I'm doing. After screwing about I ended up with the default 'Debian Linux' gui login screen.

Doing that lets me log into gnome/ubuntu but half my thingies dont work. It tells me GDM isn't running.

I replaced the /etc/gdm/gdm.conf with a happy version from a properly running Ubuntu 6.10. It didn't make any different.

After all this I have apt-get remove xdm and am now back to square one.

Whenever I boot, I am presented with a thingie which lets me choose which XDMCP computer I want to log into. Luckily I have my desktop to log into. (A side note - beryl works over XDMCP. Its VERY cool seeing 3D effects and a rotating desktop over a network connection.)

I'm really stumped. I would just like my Ubuntu to go back to logging in with GDM using the standard login prompt. Then I can go back to fiddling with silly ATI stuff with video.

Last edited by davoman; 04-25-2007 at 01:27 PM.
Old 04-26-2007, 09:20 AM   #2
Registered: Apr 2007
Location: Adelaide, Australia
Distribution: Ubuntu 8.10 and 7.10 server
Posts: 95

Rep: Reputation: 15
RE: GDM stuck using XDMCP / cant log in locally

Try letting the GDM chooser come up and then press Ctrl + Alt + F1 to get to a command line, then log in as root. Run "ps -aux | more" to identify xdm pid and X pid. Kill them both ("kill -SIGHUP pid_of_process") and then run "startx". Navigate your way back to that crazy little box you ticked, untick it and then save the settings and reboot... Hopefully that will fix it!

Good luck
Old 04-30-2007, 07:13 AM   #3
Registered: Nov 2003
Location: New Zealand
Distribution: Ubuntu 6.10/7.04
Posts: 51

Original Poster
Rep: Reputation: 15
Oh dude thank you so much. You're a little late though. I've already reformatted etc.
But thanks for going to the trouble of writing that out for me. I can find it on here the next time I good up my GDM. Cheers.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
XDMCP problem thru the gdm ?? abd_bela Debian 1 03-04-2007 02:37 PM
XDMCP and XDM, GDM Rostfrei Linux - Networking 5 09-26-2005 04:49 PM
GDM-XDMCP possible issue. LTSP quentusrex Ubuntu 1 07-07-2005 07:42 PM
xdmcp and gdm problems feffemannen Linux - Networking 0 02-01-2005 08:35 AM
gdm, vnc and XDMCP stopped working akidd Linux - Networking 10 12-25-2004 08:01 PM > Forums > Linux Forums > Linux - Desktop

All times are GMT -5. The time now is 02:47 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration