Welcome to the most active Linux Forum on the web.
Go Back > Forums > Linux Forums > Linux - Desktop
User Name
Linux - Desktop This forum is for the discussion of all Linux Software used in a desktop context.


  Search this Thread
Old 03-23-2013, 04:02 PM   #1
Senior Member
Registered: Oct 2005
Distribution: Slackware 14.1
Posts: 3,482

Rep: Reputation: 544Reputation: 544Reputation: 544Reputation: 544Reputation: 544Reputation: 544
Focus stealing when opening an app in KDE

KDE 4.10.1.

I have my VirtualBox machines configured to open in Desktop 2.

I have the KDE task manager configured to show only tasks from each desktop.

The VirtualBox windows correctly open in Desktop 2, but the window manager always changes the focus to Desktop 2. I don't want that. I want the app to start quietly in the background.

I changed the focus stealing level to something other than None. That sort of works in that the window manager does not force the focus to Desktop 2, but the window manager then creates a task manager icon in the Desktop 1 task bar that annoyingly flashes a few times.

As I have the task manager set to display tasks only from the current desktop, I don't know why the icon appears on Desktop 1 task bar.

The task icon text is also weirdly drop-shadowed.

I want to open the window in Desktop 2, no task bar icon to appear in Desktop 1, no flashing in Desktop 1, and no focus stealing. Just open quietly in the background in Desktop 2.

When I'm ready to work in the virtual machine I can press Ctrl-F2.

I tried some other apps, such as LibreOffice and some native KDE apps. Same results. Either the focus changes or the nagging task bar icon appears in Desktop 1 with the weird drop shadow font.

I disabled launch feedback for the virtual machines but the task bar icon still flashes in Desktop 1.

I probably would tolerate the flashing task bar icon in Desktop 1 if those weird drop shadow fonts weren't used. The flashing is temporary but for whatever reason, the drop shadow effect distracts me a great deal. Is there a way to stop the drop shadow effect?

Any idea how to fix this?

Old 04-02-2013, 05:56 PM   #2
Senior Member
Registered: Jan 2011
Location: Australia
Distribution: OpenSUSE
Posts: 1,396
Blog Entries: 7

Rep: Reputation: 166Reputation: 166
Hey mate, i use the workspaces very similar to you in kde. What you have may be a bug. Ktorrent doesn't work correctly with window rules like that, but that's the only one in my experience.

I don't think you can get it out of the task bar yet, (maybe in kde 4.10, i haven't tried it so i don't know)
As for the drop shadow, can you post a pic, because i don't know what you're taking about.
Old 04-06-2013, 05:21 PM   #3
Senior Member
Registered: Oct 2005
Distribution: Slackware 14.1
Posts: 3,482

Original Poster
Rep: Reputation: 544Reputation: 544Reputation: 544Reputation: 544Reputation: 544Reputation: 544
I posted a bug report.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post - possible to stop it stealing focus? catkin Linux - Software 4 10-05-2010 12:04 PM
Prohibit window focus stealing in KDE brianmcgee Linux - Desktop 6 07-28-2008 12:25 AM
Mouse Over Focus Stealing HOW TO TURN OFF Linux - Desktop 3 07-16-2007 03:28 PM
Focus Stealing Across Desktops - Firefox/T-bird vtel57 Linux - Desktop 0 05-15-2007 01:24 PM
How to stop gaim stealing focus? chrism01 Linux - Software 4 05-26-2006 01:40 AM > Forums > Linux Forums > Linux - Desktop

All times are GMT -5. The time now is 01:26 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration