-   Linux - Desktop (
-   -   fglrx driver problems on fc16 with HD 7770 (

smoothback 06-07-2012 01:33 AM

fglrx driver problems on fc16 with HD 7770

I'm having the damndest time trying to get the video drivers working on my install of fc16. I purchased an AMD Radeon HD 7770 and ever since I installed it most linux distros have been giving me hell because of the drivers. I've tried following the instructions from AMD's unofficial linux wiki to no avail. It's a fresh install of fc16, all I've pretty much done is run

yum update
yum update kernel
yum install kernel-devel kernel-headers gcc gcc-c++

as per the AMD wiki and I'm now at kernel version 3.3.7-1. I've tried catalyst 12.2, 12.3, and 12.4 and i keep getting

Uninstalling any previously installed drivers.
[Message] Kernel Module : Trying to install a precompiled kernel module.
[Message] Kernel Module : Precompiled kernel module version mismatched.
[Message] Kernel Module : Found kernel module build environment, generating kernel module now.
AMD kernel module generator version 2.1
doing Makefile based build for kernel 2.6.x and higher
rm -rf *.c *.h *.o *.ko *.a .??* *.symvers
make -C /lib/modules/3.3.7-1.fc16.i686/build SUBDIRS=/lib/modules/fglrx/build_mod/2.6.x modules
make[1]: Entering directory `/usr/src/kernels/3.3.7-1.fc16.i686'
  CC [M]  /lib/modules/fglrx/build_mod/2.6.x/firegl_public.o
/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c: In function ‘KCL_fpu_begin’:
/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:5804:28: error: ‘TS_USEDFPU’ undeclared (first use in this function)
/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:5804:28: note: each undeclared identifier is reported only once for each function it appears in
make[2]: *** [/lib/modules/fglrx/build_mod/2.6.x/firegl_public.o] Error 1
make[1]: *** [_module_/lib/modules/fglrx/build_mod/2.6.x] Error 2
make[1]: Leaving directory `/usr/src/kernels/3.3.7-1.fc16.i686'
make: *** [kmod_build] Error 2
build failed with return value 2
[Error] Kernel Module : Failed to compile kernel module - please consult readme.
[Reboot] Kernel Module : dracut

in the fglrx-install.log. If anyone has any ideas or wants to be so kind as to point out what the deuce I might be doing wrong or if I'm skipping any critical steps I would be forever in their debt. Also, thought I'd mention that I'm running dual monitors. Not sure if that's important at this particular juncture or if it makes a difference.


adamk75 06-07-2012 04:18 AM

Apparently the kernel in Fedora is too new for Catalyst 12.4. Even if you patched the fglrx DRM driver,
Fedora 17 uses X server 1.12, which is also too new for the latest release of Catalyst (12.4). The 12.6 beta driver supposedly works with this newer X server. You can either try locating the beta driver on-line, or you can wait for 12.6 to be released.


smoothback 06-07-2012 12:32 PM

Okay, I sort of had a feeling that's what might be going on based off a few posts I stumbled across and heresay from a co-worker. Do you think downgrading to fc15 or fc14 might give me better results? Because it seemed to work okay when I used Crunchbang Statler (minus x server crashes every so often) and even Xubuntu 11.10. I might go hunting for that beta driver anyway, but thanks a bunch for your input.

adamk75 06-07-2012 12:36 PM

Well, I definitely used fglrx with Fedora 15, but it was when F15 first came out. If I had to guess, I'd say that 12.4 should work with it. It might even be in the rpmfusion repos for F15.

smoothback 06-07-2012 01:50 PM

I'll keep that in mind if 12.6 gives me any trouble. For now, it's working and I'm considerably less frustrated. Thanks again Adam.

smoothback 06-08-2012 12:02 AM

Catylist 12.6 beta installed flawlessly with my current hardware config. Minus the stupid watermark in the corner, its working great so far...until I break another thing.

All times are GMT -5. The time now is 11:43 PM.