-   Linux - Desktop (
-   -   dual boot failure (

betula 09-05-2012 01:36 PM

dual boot failure

I was using Mint Maya successfully as a stand-alone OS on my pc. I thought I'd add PcLinuxOS as a second string but, made a mess of the boot menu choice. I now have PCOS only available. Mint doesn't show up at all on the boot-up choice screen.

When I was installing PCOS I tried entering /boot in its rightful place but Grub wouldn't accept it. I then removed / from the Mint entry and placed it the PCOS slot. All went well with the install but only PCOS shows up when booting.

So, please, how do I revive Mint from the dead? I don't mind which distro comes first as long as I get the choice of the two.

ReaperX7 09-05-2012 10:53 PM

Did you attempt to directly edit /boot/grub/grub.cfg by chance?

EDDY1 09-06-2012 12:40 AM

Reinstall grub in mint

betula 09-06-2012 03:21 AM

Thanks for your replies. I didn't attempt to edit /boot/grub/grub.config because I wouldn't know how to. And I don't really understand the stuff in the karrupswamy link.

It would, I'm sure, be easier to just re-install Mint. I don't mind doing this as I have nothing important to back up. So, what would the right entries be in the Grub part of the install?

Sorry to be thick...

yancek 09-06-2012 10:59 AM

Which bootloader? Grub Legacy with PCLinux or Grub2 with Mint? When you installed PCLinux, did you install its Grub to the master boot record? Or did you install it to its / partition and try to modify the Mint grub.cfg?

Since you are only able to boot PCLinux, I expect you have its Grub Legacy in the mbr. I use PCLinux as a base system with Grub Legacy in the mbr. I am using 2011 so I don't know if they have switched to Grub2, you will have to check. If you have a menu.lst file in PCLinux then you are using Grub Legacy. You can put an entry similar to the one below in the PCLinux menu.lst to boot Mint


title sda12-Mint12
root (hd0,11)
kernel /boot/grub2/core.img
You will obviously need to change the partition number on the root line to whatever is approriate. You may need to remove the (#) from before the savedefault and boot lines but I would leave it the way it is and try that first.

If this doesn't work, try googling "bootinfoscript", read the instructions download and run it to get information to post on your drives/partitions and boot files.

betula 09-07-2012 12:44 PM

Well, I've played around with booting and bootinfoscript for quite a while now. I haven't had any success with the command 'sudo ~/Downloads/bootinfoscript'. All I get is no such command or similar.

So I tried re-installing PcLinuxOS but only managed to reverse things - I now have Mint available but not PCLOS. I've searched and found that PCOS uses Grub Legacy and Mint uses Grub2. I strongly suspect that this is the root of the problem.

I think I'll be better off selecting two distros which use the same Grub. I don't wish to furkle about with matters that are beyond my level of understanding and competence so I'll close this thread and research distros and Grubs. No doubt I'll be back with questions later.

Many many thanks to you both for being so willing to help.

yancek 09-07-2012 02:32 PM


I haven't had any success with the command 'sudo ~/Downloads/bootinfoscript'. All I get is no such command or similar.
You were doing this on PCLinux and PCLinux doesn't use "sudo". There is a link in the Directions box at the site which explains how to run it. I've been booting several distributions which use Grub2 from my Grub Legacy on PCLinux for a couple of years without problem. Grub2 detects and boots the Grub Legacy partitions easily also. Grub2 is better in a number of ways.

All times are GMT -5. The time now is 08:57 AM.