-   Linux - Desktop (
-   -   Dropbox not sync-ing in KDE (

spoovy 03-12-2010 07:03 AM

Dropbox not sync-ing in KDE
I am trying to use dropbox on Fedora 12 KDE. I have untarred it and started the daemon, and it syncs OK, initially.

The problem is on subsequent boots, it doesn't sync. I have set up a symlink in '~/.kde/Autostart' to the dropbox daemon located at '~/.dropbox-dist/dropboxd', and when I start KDE the dropbox icon appears in the systray, so it appears that it has worked.

But it hasn't. New files added from another workstation are not present in the ~/Dropbox file; so it hasn't synced.

But if I kill the dropbox daemon and then restart it, dropbox syncs (the systray icon shows the sync-ing graphic, and newly added files appear in ~/Dropbox).

So why is this happening? How does the kill / restart daemon process I described differ from just starting the daemon via the symlink after a reboot?

Thanks in advance


irishbitte 03-14-2010 11:35 AM

Have you tried removing your own symlink, and reinstalling Dropbox? It sets up it's own autostart daemon, AFAIK

spoovy 03-16-2010 11:34 AM

You can't install it via RPM or deb without it bringing in Nautilus as a dependency, so you have to setup your own method of autostarting the daemon.

I've given up on being able to do this now anyway. I also tried creating a script to start it through the init process, which started the process ok, but it still didn't sync without being restarted manually each session. In the end I gave up and installed Nautilus.

All times are GMT -5. The time now is 07:10 AM.