-   Linux - Desktop (
-   -   Disable scaling for certain XWayland applications (

skerit 08-05-2020 08:58 AM

Disable scaling for certain XWayland applications
I'm running Gnome-shell with wayland, and it's working pretty well.
I'm using fractional scaling, so XWayland based applications are blurry, but most stuff I need actually supports wayland so it's not a big deal.

However: I would like to simply disable *all* scaling for certain applications, mainly games. They don't need any scaling, since they all have dpi/resolution settings in-game anyway. So now I'm playing on blown up 1080p resolutions on my 4K screen. Not good.

However: I can't find *any* help regarding this issue. Somehow, somewhere, it should be possible to disable this please.

ferrari 08-07-2020 01:37 AM

I don't have a definitive answer here, and really not even sure if what you're asking is really possible on a per application basis, but in any case this thread may be of interest...
and perhaps this as well...

skerit 08-07-2020 08:13 AM

I'm afraid not. The poster on Reddit also wanted to disable scaling, but because back then any kind of Xwayland applications were blurry on scaled Wayland sessions. Even when scaling with an integer value.
I think that has since been resolved. Xwayland applications no longer look blurry on a scaled wayland session (unless scaling with a fractional value)

But even then: it shouldn't scale games. At. All.

I took a look at the pull request on gitlab too, but as I'm finding time and time again they started to talk about specific wlroots/sway implementations :) Those guys get all the good bits.
I also found a mention of the "xownersize" command line application, but that doesn't compile against modern X/Xwayland versions anymore :(

ferrari 08-07-2020 03:45 PM

I can only suggest a bug report to help progress this.

All times are GMT -5. The time now is 04:01 AM.