LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Desktop (https://www.linuxquestions.org/questions/linux-desktop-74/)
-   -   directfb on FC8 on i386 (https://www.linuxquestions.org/questions/linux-desktop-74/directfb-on-fc8-on-i386-609049/)

ilkras 12-25-2007 10:27 AM

directfb on FC8 on i386
 
Hi. I installed FC8 on Dell Optiplex 745.
The directfb 1.0 is reportedly part of the distribution and the library /usr/lib/libdirectfb.so is present.
I installed samples from directfb.org, configured, built, installed and tried to run. It reported that cannot initialize since /dev/fb0 is absent. OK. It's really absent.
The question: what is wrong and how to make it working?
The aim: to develop sw on directfb on desktop linux.

Thanks

DKK 10-07-2008 01:05 AM

Directfb on fc8 on i686
 
Hi ,
I've installed Directfb1.3 on fc8 in Dell Opltiplex 170L machine.
Ive installed Directfb examples program and when tried to execute them, received following error.

~~~~~~~~~~~~~~~~~~~~~~~~~~| DirectFB 1.3.0 |~~~~~~~~~~~~~~~~~~~~~~~~~~
(c) 2001-2008 The world wide DirectFB Open Source Community
(c) 2000-2004 Convergence (integrated media) GmbH
----------------------------------------------------------------

(*) DirectFB/Core: Single Application Core. (2008-10-06 14:22)
(!) Direct/Util: opening '/dev/fb0' and '/dev/fb/0' failed
--> No such file or directory
(!) DirectFB/FBDev: Error opening framebuffer device!
(!) DirectFB/FBDev: Use 'fbdev' option or set FRAMEBUFFER environment variable.
(!) DirectFB/Core: Could not initialize 'system_core' core!
--> Initialization error!
(#) DirectFBError [DirectFBCreate() failed]: Initialization error!

Do anybody know how to open a frame buffer device on fc8.
Also please guide me what configuration options (say --enable-x11, etc...) to be set while building directfb(I've used all default options for building).

With Thanks,
Krishna


All times are GMT -5. The time now is 10:45 PM.