-   Linux - Desktop (
-   -   Debian Etch->Lenny upgrade: vncserver: fubar keyboard and unstable theme (

stolsvik 05-25-2009 09:01 PM

Debian Etch->Lenny upgrade: vncserver: fubar keyboard and unstable theme

I just upgraded from Debian 4 Etch to Debian 5 Lenny. This is on a "in the closet server", so I have 'vncserver' (Xtightvnc) running, connecting from my desktop box (Windows XP) to it using a tightvnc client. I'm running Gnome.

This setup has worked just nice all the time before upgrading.

After upgrade, I have two distinct problems:

1) The keyboard layout has become _really_ fubarred: Using the mouse, starting a terminal window: A lot of the keys seems randomly interchanged: 'a' is, granted, a. However, that's about it: 'b' is s, while 's' is b. Space is 7, Enter is space, while '/' is Enter - '7' is q. Shift is 1, Alt is 5, '5' is Backspace, while Backspace is seemingly nothing!
You get the point - I have NO idea what has happened!

2) The second problem is a bit difficult to explain, but here goes: The first impression is that the fonts are very small. However, there is obviously something strange going on with the "theming" support, as the terminal window flickers back and forth between what apparently is two themes. At first I just noticed that the text, in particular on the terminal's menus, for some brief instants became larger and more readable. But then I saw that all the decorations on the window also flickers back and forth. When the text is small (the "default"), it is a "nice" theme, with rounded window, rounded scrollbars etc. However, when the text is larger and more readable, it seems to be a very plain and "old-skool" squarish, greyish theme..

I've tried the most heavy-handed approach I could get at: Purge all packages relating to the windowing system, as efficient as possible: purge xserver-xorg (and I believe, purge gnome). That seemed to kill about 700 packages, and the system was basically reduced to a non-GUI server. However, upon reinstalling "gnome", thereby pulling in everything incl. xserver-xorg etc, I came back to _the exact same result_! So that did not work out, at all!

Any ideas would be VERY much appreciated!!

pljvaldez 05-26-2009 11:24 AM

For the keyboard layout you could try dpkg-reconfigure xserver-xorg and select the correct keyboard layout again. Or maybe try dpkg-reconfigure xtightvnc and see if that helps.

Have tried disabling themes? Or installing true type fonts (ttf-liberation)?

stolsvik 06-10-2009 09:47 AM

Thanks, but this didn't help.

Remember that vncserver (Xtightvnc) AFAIK implements an entire Xserver itself.

After doing the "reinstall" of gnome mentioned in the initial post, I got in the absurd situation that the system wouldn't boot. I thus frustratingly had to dig the machine out of the closet and find out what was wrong.

(Extremely annoyingly, the server just waited for an enter on the keyboard, due to absurdly provocative "resume: could not stat the resume device file", as if I gave a flying fuck about hibernate on a server - this apparently due to the evidently absurd 'uswsusp' package which the gnome package apparently had pulled in. Damn it. 'aptitide remove uswsusp' did that in.)

But this digging had me set up the monitor, which showed that gdm (xorg) actually didn't manage to start. After some fiddling with xorg.conf (Don't trust "If in doubt, choose the framebuffer option", as the damn framebuffer apparently wasn't present!?!), I got that working again.

Thus I can now tell that on when in such normal mode (with a "proper" monitor, mouse and keyboard), using xorg, everything works just perfect. While the situation described in the initial post is exactly the same.

But this readily points out that there seemingly is NO connection between xserver, and vncserver. In the "man Xtightvnc", it actually states "Xvnc is built inside the source code tree of XFree86, and shares many options with it.".

THUS, I still have BOTH problems - and I have a feel that they are somehow related. Both came after the update - both weren't there before the update.

stolsvik 06-10-2009 09:23 PM

It works! (mostly!)
So.. change vncserver!

aptitude remove tightvncserver
aptitude install vnc4server

Both the very small fonts, and keyboard problems, are now fixed. The fonts are exactly as they are on the actual monitor X session, and the keyboard works correctly.

However, I still sometimes get that flickering-stuff I mentioned initially, which seems like the menus and scrollbars, typically of the terminal windows, flicker "back to its undressed self", momentarily - and then the theme comes back on. This does not happen for the actual window decoration - only the "innards" of the window: The menu, and the scrollbar. Needless to say, I have never seen that before.

stolsvik 06-11-2009 01:04 PM

Continuing my monologue, I now believe that the reason for this flickering, is that the "Gnome Settings Deamon" is failing, and thus restarting. This because after a while, a window comes up informing me that this deamon has been stopped (or rather won't be restarted again) due to too many restarts.

After this, the system is stuck in the "old skool" view, with grayish, large-fonted menus, and squarish scrollbars. This is even evident in the Azureus running, showing the same type of decorations.

Any way to debug this?

All times are GMT -5. The time now is 04:01 PM.