Share your knowledge at the LQ Wiki.
Go Back > Forums > Linux Forums > Linux - Desktop
User Name
Linux - Desktop This forum is for the discussion of all Linux Software used in a desktop context.


  Search this Thread
Old 11-23-2007, 11:27 AM   #1
LQ Newbie
Registered: Nov 2007
Posts: 2

Rep: Reputation: 0
Could not able to play songs in My System

I am new to Red Hat Linux. I have installed Linux in my PC. I have dual OS in my system. (Other is XP). I have mounted a drive to linux which contains songs (in mp3 format). But when i try to play using XMMS the sound is not generated. But i am sure that sound card is installed properly because i heard the test sound after installation of linux. Can any one help me on this please.?

And I also want to know the syntax for auto mount command.

Thanks in Advance
Old 11-23-2007, 12:48 PM   #2
LQ Guru
Registered: Nov 2002
Location: Somewhere inside 9.9 million sq. km. Canada
Distribution: Slackware 14.1, 14.2
Posts: 5,163

Rep: Reputation: 522Reputation: 522Reputation: 522Reputation: 522Reputation: 522Reputation: 522
If you can play sounds on your system, I would suspect your problem is in XMMS configuration. Open XMMS, right click on xmms, and find the preferences. On the audio plugin tab make sure the output plugin is set according to the sound system you have installed. Most newer distros install ALSA. It could also be OSS ( Open sound system ), or even jack driver. This has to match your system, or you will get silence.

Also make sure you have the Mpeg 1/2/3 player input plugin installed for mp3 files.

Check what you have and post back if you have problems.
Old 11-23-2007, 12:52 PM   #3
Senior Member
Registered: Feb 2007
Location: Chilliwack,BC.Canada
Distribution: Slackware64 -current
Posts: 2,079

Rep: Reputation: 58
do you have codecs installed?
Old 11-26-2007, 10:58 AM   #4
LQ Newbie
Registered: Nov 2007
Posts: 2

Original Poster
Rep: Reputation: 0
Thanks a lot friends.
i have two ordinary jack speakers. I have tried with all the preferences of XMMS software. but none worked out.

i have not installed codecs in my computer. my system config is P4 intel 845GVSR motherboard.

Please Help me..

Thanks for once again..
Old 11-26-2007, 06:20 PM   #5
Senior Member
Registered: Feb 2007
Location: Chilliwack,BC.Canada
Distribution: Slackware64 -current
Posts: 2,079

Rep: Reputation: 58
you need to install codecs before you can play anything except ogg files
Old 11-27-2007, 12:26 AM   #6
LQ Newbie
Registered: Nov 2007
Posts: 3

Rep: Reputation: 0
syntax for auto mount fat32 command:
first mkdir in /mnt , added code like blow in /etc/fstabg
/dev/sda6 /mnt/e vfat defaults,codepage=936,iocharset=cp936 0 0
you can find your partition message with "fdisk -l"


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
I am not able to play Mp3 Songs In Red Hat 9,How To Play The Songs? vlovevj_patel Linux - General 10 03-23-2008 11:45 PM
How to Play Mp3 songs in fedora 6 logicrafi Linux - Software 6 11-17-2007 09:48 PM
Can't Play Ripped Songs In Amarok Harpo SUSE / openSUSE 1 03-18-2007 08:44 AM
how do i play songs from my ipod amolgupta Linux - Software 1 04-09-2006 04:03 PM
how to play songs in RHEL 4.0 ES version surapaneni Red Hat 2 03-22-2006 08:04 AM > Forums > Linux Forums > Linux - Desktop

All times are GMT -5. The time now is 01:38 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration