LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Desktop
User Name
Password
Linux - Desktop This forum is for the discussion of all Linux Software used in a desktop context.

Notices

Reply
 
LinkBack Search this Thread
Old 08-11-2013, 05:58 AM   #1
dragomir
LQ Newbie
 
Registered: Feb 2004
Posts: 9

Rep: Reputation: 0
Changing the Screen Resolution in OpenSuse 12.3 with nvidia driver to 1440x900


Hello everyone,

I am trying for a week already to set up the screen resolution to 1440x900 (this is Acer x193w) in my OpenSuse 12.3 but unfortunately without success. The highest resolution now is 1024x768. Could you probably help to solve this problem. Thank you in advance.

Best Regards
Dragomir

Here some additional information:
  • xrandr
Code:
 dragomir@ip-29-4:~> xrandr
Screen 0: minimum 8 x 8, current 1024 x 768, maximum 4096 x 4096
VGA-0 connected primary 1024x768+0+0 (normal left inverted right x axis y axis) 0mm x 0mm
   1024x768       60.0*+
   800x600        72.2     60.3     56.2  
   640x480        59.9  
   512x384        60.0  
   400x300        72.2     60.3     56.3  
   320x240        60.1
  • output lspci
Code:
dragomir@ip-29-4:~> /sbin/lspci -nnk | grep VGA -A2
00:05.0 VGA compatible controller [0300]: NVIDIA Corporation C51G [GeForce 6100] [10de:0242] (rev a2)
        Subsystem: ASRock Incorporation Device [1849:0242]
        Kernel driver in use: nvidia
  • xorg.conf
PHP Code:
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 304.88  (buildmeister@swio-display-x86-rhel47-14)  Wed Mar 27 15:36:45 PDT 2013

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 304.88  (buildmeister@swio-display-x86-rhel47-14)  Wed Mar 27 15:36:35 PDT 2013

Section "ServerLayout"
    
Identifier     "Layout0"
    
Screen      0  "Screen0" 0 0
    InputDevice    
"Keyboard0" "CoreKeyboard"
    
InputDevice    "Mouse0" "CorePointer"
    
Option         "Xinerama" "0"
EndSection

Section 
"Files"
EndSection

Section 
"InputDevice"

    
# generated from default
    
Identifier     "Mouse0"
    
Driver         "mouse"
    
Option         "Protocol" "auto"
    
Option         "Device" "/dev/psaux"
    
Option         "Emulate3Buttons" "no"
    
Option         "ZAxisMapping" "4 5"
EndSection

Section 
"InputDevice"

    
# generated from default
    
Identifier     "Keyboard0"
    
Driver         "kbd"
EndSection

Section 
"Monitor"
    
Identifier     "VGA-0"
    
ModeLine       "1440x900_60.00" 106.50 1440 1528 1672 1904 900 903 909 934 -hsync +vsync
    Option         
"PreferredMode" "1440x900_60.00"
EndSection

Section 
"Monitor"
    
Identifier     "Monitor0"
    
VendorName     "Unknown"
    
ModelName      "CRT-0"
    
ModeLine       "1440x900_60.00" 106.50 1440 1528 1672 1904 900 903 909 934 -hsync +vsync
    Option         
"PreferredMode" "1440x900_60.00"
    
HorizSync       28.0 55.0
    VertRefresh     43.0 
72.0
EndSection

Section 
"Device"
    
Identifier     "Device0"
    
Driver         "nvidia"
    
VendorName     "NVIDIA Corporation"
    
BoardName      "GeForce 6100"
EndSection

Section 
"Screen"
    
Identifier     "Screen0"
    
Device         "Device0"
    
Monitor        "Monitor0"
    
DefaultDepth    24
    Option         
"Stereo" "0"
    
Option         "nvidiaXineramaInfoOrder" "CRT-0"
    
Option         "metamodes" "nvidia-auto-select +0+0"
    
SubSection     "Display"
        
Depth       24
    EndSubSection
EndSection 
  • last section of Xorg.0.log
[PHP]
PHP Code:
[  1913.204] (**) NVIDIA(0): Using HorizSync/VertRefresh ranges from the EDID for display
[  1913.204] (**) NVIDIA(0):     device CRT-(Using EDID frequencies has been enabled on
[  1913.204] (**) NVIDIA(0):     all display devices.)
[  
2028.108] (WWNVIDIA(GPU-0): The EDID read for display device CRT-0 is invalid:
[  
2028.108] (WWNVIDIA(GPU-0):     unrecognized EDID Header.
[  
2028.108] (--) NVIDIA(GPU-0): 
[  
2028.108] (--) NVIDIA(GPU-0): Raw EDID bytes:
[  
2028.108] (--) NVIDIA(GPU-0): 
[  
2028.108] (--) NVIDIA(GPU-0):   00 ff ff ff ff ff ef 00  04 72 06 00 7a 5e 11 84
[  2028.108] (--) NVIDIA(GPU-0):   29 12 01 03 68 28 19 6b  2a 67 60 a2 5a e9 9e 23
[  2028.108] (--) NVIDIA(GPU-0):   13 50 54 bf ef 00 81 8f  81 80 95 0f 95 cd 01 01
[  2028.108] (--) NVIDIA(GPU-0):   01 01 00 01 01 01 9a 29  a0 d0 56 84 22 30 50 98
[  2028.108] (--) NVIDIA(GPU-0):   36 00 98 ff 10 00 00 1c  00 00 00 ff 00 4c 41 4d
[  2028.108] (--) NVIDIA(GPU-0):   30 38 30 33 39 34 32 31  31 0a 00 00 00 fd 00 37
[  2028.108] (--) NVIDIA(GPU-0):   4b 1e 53 0e 00 0a 20 20  20 20 20 20 00 00 00 fc
[  2028.108] (--) NVIDIA(GPU-0):   00 41 63 65 72 20 58 31  39 33 57 0a 20 20 00 3d
[  2028.108] (--) NVIDIA(GPU-0): 
[  
2028.108] (--) NVIDIA(GPU-0):   00 00 00 00 00 00 00 00  00 00 00 00 00 00 00 00
[  2028.108] (--) NVIDIA(GPU-0):   00 00 00 00 00 00 00 00  00 00 00 00 00 00 00 00
[  2028.108] (--) NVIDIA(GPU-0):   00 00 00 00 00 00 00 00  00 00 00 00 00 00 00 00
[  2028.108] (--) NVIDIA(GPU-0):   00 00 00 00 00 00 00 00  00 00 00 00 00 00 00 00
[  2028.108] (--) NVIDIA(GPU-0):   00 00 00 00 00 00 00 00  00 00 00 00 00 00 00 00
[  2028.108] (--) NVIDIA(GPU-0):   00 00 00 00 00 00 00 00  00 00 00 00 00 00 00 00
[  2028.108] (--) NVIDIA(GPU-0):   00 00 00 00 00 00 00 00  00 00 00 00 00 00 00 00
[  2028.108] (--) NVIDIA(GPU-0):   00 00 00 00 00 00 00 00  00 00 00 00 00 00 00 00
[  2028.108] (--) NVIDIA(GPU-0): 
[  
2028.108] (**) NVIDIA(0): Using HorizSync/VertRefresh ranges from the EDID for display
[  2028.108] (**) NVIDIA(0):     device CRT-(Using EDID frequencies has been enabled on
[  2028.108] (**) NVIDIA(0):     all display devices.) 
 
Old 08-11-2013, 08:19 AM   #2
aus9
Guru
 
Registered: Oct 2003
Posts: 5,055

Rep: Reputation: Disabled
Hi

I don't use opensuse but according to your xorg file, no setting has been changed since Mar 27 2013, so I am not sure if you knew you needed root powers to affect changes?

2) USE root powers to make a back up of your current xorg file suggest its called /etc/X11/xorg.conf-bak
and I assume you can boot a live cd to rescue if needed?

3) Now edit (temporary) your boot loader to append "single" without the quotes to boot up to root mode no graphics
input your root password
then try
Code:
nvidia-xconfig
check your distro has such a command, likely under /usr/bin before rebooting

4) once new xorg is created, check its contents if no change to sizes then sorry to have troubled you.
b) if contents are good, save it as its currently only a temp xorg file

good luck

PS if you don't want to try booting up in single mode, find out the name of your login manager and shut it down
not sure if you use /etc/init.d/<name> or service <name> boot up scripts

Last edited by aus9; 08-11-2013 at 08:22 AM.
 
Old 08-11-2013, 09:22 AM   #3
dragomir
LQ Newbie
 
Registered: Feb 2004
Posts: 9

Original Poster
Rep: Reputation: 0
Hi aus9,

thank you for your time and answer.
I think the date in the xorg.conf file have something to do with nvidia driver creation date - see the attachment.

Quote:
Originally Posted by aus9 View Post
Hi

I don't use opensuse but according to your xorg file, no setting has been changed since Mar 27 2013, so I am not sure if you knew you needed root powers to affect changes?
I think nvidia-xconfig and nvidia-settings are provided as part of the nvidia driver installation. They are available in my distro. Could you explain what would be the benefit of booting with the "single" parameter.

Quote:
3) Now edit (temporary) your boot loader to append "single" without the quotes to boot up to root mode no graphics
input your root password
then try
Code:
nvidia-xconfig
I executed the nvidia-xconfig but the created xorg.conf was the same as the xorg.conf.backup

Quote:
4) once new xorg is created, check its contents if no change to sizes then sorry to have troubled you.
b) if contents are good, save it as its currently only a temp xorg file
Next I will try to follow this

Quote:
if you don't want to try booting up in single mode, find out the name of your login manager and shut it down
not sure if you use /etc/init.d/<name> or service <name> boot up scripts
If you have some other ideas please share them with me. Thank you.
Attached Images
File Type: png snapshot1.png (1.3 KB, 3 views)
 
Old 08-11-2013, 07:53 PM   #4
aus9
Guru
 
Registered: Oct 2003
Posts: 5,055

Rep: Reputation: Disabled
Quote:
I executed the nvidia-xconfig but the created xorg.conf was the same as the xorg.conf.backup
so the contents date I mentioned is not the same as the date in your attachment of 11 August?

single mode means boot up to root user, no x login and no x started. More below

Quote:
I executed the nvidia-xconfig but the created xorg.conf was the same as the xorg.conf.backup
then ignore all of the other bits please from my earlier post.

2) Now that we have established that nvidia is giving you the same config.

we need to try and find out why xrandr is not showing your size

run
Code:
xrandr -q
if you don't get the 1440 number then

ask a neighbour to borrow their vga cable....yours may be bad
--if its not a vga cable then describe it....eg dvi hdmi etc

3) you could try brute force.
you need to be out of x
edit manually your xorg
su (to normal user)
startx

4) I run a debian system and my xorg has no resols in it.

what happens when you start the nvidia settings app.....and click on the resolutions button...under x server config?
eg attached


5) your xorg also says crt monitor ....thats bad!
http://crunchbang.org/forums/viewtop...2339%23p202339

same that link have a look at the xorg file at reply 7 that uses
BusID "PCI:1:0:0"
Option "UseEDID" "False"

that might help get around your current edid error

but does not explain why nvidia thinks you have a crt

good luck
Attached Images
File Type: jpg nvlq.jpg (194.8 KB, 2 views)

Last edited by aus9; 08-11-2013 at 07:56 PM. Reason: attach image
 
Old 08-11-2013, 08:21 PM   #5
aus9
Guru
 
Registered: Oct 2003
Posts: 5,055

Rep: Reputation: Disabled
ahh better suggestion for edid issue

check your bootloader, I assume its grub2 and look at your main menuentry you are using for the string

"nomodeset" without the quotes

better still, also stop some other video driver interfering ---search for--- nomodeset nouveau.modeset=0

2) if any missing then do this....assuming grub2

first time, at mbr screen press E for edit (a temporary edit not permanent)
go to the line for linux kernel press e for edit and append that string...you may like to write down
press enter
press b to boot

re-run xrandr -q command
if 1440 appears then
retry nvidia command

ONLY if it works you can make that boot code permanent
but I can't mind read so will wait to see what your replies are first
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't set 1440x900 screen resolution in puppy linux? realflow100 Linux - Newbie 4 06-16-2012 12:25 AM
I-INC 19" flat screen 1440x900 resolution problem widhari Linux - Hardware 1 08-06-2008 08:14 AM
10.2 OpenSUSE on a Dell Latitude 620- Cant get 1440x900 resolution zzzbk2002 Suse/Novell 4 08-15-2007 03:49 PM
changing screen resolution and frequency with nvidia-settings from the CLI Valkyrie_of_valhalla Linux - Software 12 04-15-2007 11:58 AM
Changing Video Driver and Screen Resolution kaplan71 Debian 4 12-22-2005 09:47 AM


All times are GMT -5. The time now is 05:03 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration