LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Desktop
User Name
Password
Linux - Desktop This forum is for the discussion of all Linux Software used in a desktop context.

Notices


Reply
  Search this Thread
Old 11-25-2009, 12:04 PM   #1
irishbitte
Senior Member
 
Registered: Oct 2007
Location: Brighton, UK
Distribution: Ubuntu Hardy, Ubuntu Jaunty, Eeebuntu, Debian, SME-Server
Posts: 1,213
Blog Entries: 1

Rep: Reputation: 88
change IMAP port from 143 to 8080


Hi folks,

Funny thing today, I'm trying to give plain old IMAP access to computers on a non-local network for my email server. Don't ask why, but it's the last resort.

Anyway, here's the thing. My server is SME server, and I cannot find for the life of me how to change the default IMAP port! There is nothing stored in
Code:
/etc/dovecot.conf
and I'm really beginning to pull my hair out.

I know SME server has things like
Code:
config setprop imap access public
for example, but I'm not finding anything about changing default ports.

Would really appreciate any help!
 
Old 11-25-2009, 12:33 PM   #2
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1985Reputation: 1985Reputation: 1985Reputation: 1985Reputation: 1985Reputation: 1985Reputation: 1985Reputation: 1985Reputation: 1985Reputation: 1985Reputation: 1985
just change the "listen" port in dovecot.conf, not exactly tricky to track this down: http://wiki.dovecot.org/MainConfig

but.. 8080??? don't run it on 8080 without very good reasons, probably firewall / proxy related.
 
Old 11-25-2009, 01:01 PM   #3
irishbitte
Senior Member
 
Registered: Oct 2007
Location: Brighton, UK
Distribution: Ubuntu Hardy, Ubuntu Jaunty, Eeebuntu, Debian, SME-Server
Posts: 1,213

Original Poster
Blog Entries: 1

Rep: Reputation: 88
By your reply, you probably think I'm messing about, but this is the complete contents of
Code:
/etc/dovecot.conf
Code:
#------------------------------------------------------------
#              !!DO NOT MODIFY THIS FILE!!
#
# Manual changes will be lost when this file is regenerated.
#
# Please read the developer's guide, which is available
# at http://www.contribs.org/development/
#
# Copyright (C) 1999-2006 Mitel Networks Corporation
#------------------------------------------------------------
maildir_copy_with_hardlinks = no
As you can see, there is one uncommented line at the end. I'm really not sure what it's in aid of, but leaving it there. There is no conf file. Thats what has got me stumped! I'm really looking for someone with a good idea of SME server to point me in the right direction, and I don't mind hacking about either!

BTW:
Quote:
but.. 8080??? don't run it on 8080 without very good reasons, probably firewall / proxy related.
it's a school I'm working in, government provided net connection, they will open five ports I think: 80, 25, 8080, 443, and one other I can't think of. Believe it or not, all these ports are open on this box. So I really need to route IMAP through 8080, since it is the only port available to me!
 
Old 11-25-2009, 01:05 PM   #4
irishbitte
Senior Member
 
Registered: Oct 2007
Location: Brighton, UK
Distribution: Ubuntu Hardy, Ubuntu Jaunty, Eeebuntu, Debian, SME-Server
Posts: 1,213

Original Poster
Blog Entries: 1

Rep: Reputation: 88
Just in case you're interested:
Code:
[root@mail ~]# dovecot -n
# 1.0.7: /etc/dovecot.conf
Error: Missing auth section for server default
Fatal: Invalid configuration in /etc/dovecot.conf
Code:
 ps ax | grep dove
 5375 ?        S      0:00 /usr/bin/tcpsvd -v -i ./peers -c 400 -C 12:421 per host concurrency limit reached\r\n -l 0 0 imaps sslio -vv -/ ../imap/ssl -C imapd.pem -u stunnel /usr/bin/imapfront-auth /usr/libexec/dovecot/imap
 6939 pts/0    S      0:00 less /etc/dovecot.conf
 6967 pts/0    S+     0:00 grep dove
Seems SME has some way of running in runlevel 7 all the time, and all config is done using the type of commands I showed earlier, 'config blah blah', which modify database settings?

Last edited by irishbitte; 11-25-2009 at 01:06 PM.
 
Old 11-25-2009, 03:56 PM   #5
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1985Reputation: 1985Reputation: 1985Reputation: 1985Reputation: 1985Reputation: 1985Reputation: 1985Reputation: 1985Reputation: 1985Reputation: 1985Reputation: 1985
Hmm ok, I've never been near SME, so wasn't at all aware how closed it appears to seem. I would imagine you could add a listen directive to the dovecot.conf, but if not, you could look to do a nat with iptables, to redirect inbound hits at 8080 to 143 on loopback. Unsure how to configure iptables on SME formally, but it seems to happen under the covers a fair bit... e.g. http://wiki.contribs.org/Ipsec
 
Old 11-25-2009, 04:36 PM   #6
irishbitte
Senior Member
 
Registered: Oct 2007
Location: Brighton, UK
Distribution: Ubuntu Hardy, Ubuntu Jaunty, Eeebuntu, Debian, SME-Server
Posts: 1,213

Original Poster
Blog Entries: 1

Rep: Reputation: 88
You've put me on the right track, will get a chance to have a look at this tomorrow, thanks for your help and observations Chris! Never really thought of using iptables, thought that was more routing from one host to another! I'll let you know how it goes....
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How do you change port 8080 to port 80? bt101 Linux - Networking 10 03-18-2009 03:44 AM
access 8080 web server port through squid running on 8080 sunethj Linux - Networking 11 05-18-2007 02:38 AM
enabling port 143 jay_gonzales Linux - Software 10 03-01-2004 04:39 AM
Couldn't open stream {localhost/imap : 143} in /usr/local/httpd/htdocs/view.php nshoboul Linux - Newbie 12 10-24-2003 02:23 PM
IMAP port 143 ... and I'm an I-dot onescrewloose13 Linux - General 2 09-19-2003 08:00 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Desktop

All times are GMT -5. The time now is 09:57 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration