-   Linux - Desktop (
-   -   CentOS & Windows7 dual boot problem (

rupeshm62 08-14-2012 08:02 AM

CentOS & Windows7 dual boot problem
I had installed First windows 7 & then CentOS 5.5 on my system. It was working fine that time. Today I formatted only windows drive (ie. C:/) & reinstalled windows 7 on the system, but its not showing CentOS option at boot screen. I know NTLDR got replaced with previous grub bootloader. So I boot to linux rescue mode from CentOS CD and tried to reinstall grub bootloader (grub-install /dev/sda) but it showing error as "could not find device or not a block device"

Please help me on this

Thanks & Regards,
Rupesh Thakur

yancek 08-14-2012 10:19 AM

Probably the simplest way to get help is to go to the site below, read the instructions for and download and run the bootinfoscript. This will give a lot of information on your drives/partitions and boot files. If that doesn't help, post the results.txt file here and someone will assist you:

rupeshm62 08-15-2012 01:44 AM

The problem has been resolved. Below are the steps taken to troubleshoot:

1) When I tried to go Linux Rescue mode it was giving me error like as "An error occurred trying to mount some or all of your system. Some of it may be mounted under /mnt/sysimage. Press <return> to get default shell"
2) I press enter to go to shell prompt.
3) I tried fdisk -l command to check partition. I was able to see linux partition.
4) Then tried command "chroot /mnt/sysimage" & the command got successful.
5) Then I checked mount point by df -h command.
6) I checked all the things like fdisk partition, fstab, grub.conf etc.
7) Then I realized that the partition no for / partition automatically got changed after reinstallation of Windows 7.
8) I changed the entries in fstab. Change /dev/sda10 for / partition & /dev/sda8 for /boot partition.
9) Then tried to boot linux. It showed me grub splash image screen. I entered on CentOS partition but it given me error 17:Cannot mount selected partition
10) Again I gone to rescue mode and checked all the things and done changes to (hd0,7) instead (hd0,9) in grub.conf
11) Now I am able to boot in CentOS successfully.

Rupesh Thakur

DavidMcCann 08-15-2012 11:36 AM

I've always thought the use of UUIDs instead of device names was an accident waiting to happen: thank you for confirming my prejudices!

All times are GMT -5. The time now is 03:09 AM.