LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Desktop
User Name
Password
Linux - Desktop This forum is for the discussion of all Linux Software used in a desktop context.

Notices



Reply
 
Search this Thread
Old 05-13-2009, 10:07 AM   #1
kayasaman
Member
 
Registered: Sep 2008
Location: Under the bridge where proper engineers walkover
Distribution: Various Linux, Solaris, BSD, Cisco
Posts: 443

Rep: Reputation: 32
CentOS 5.3 printer not showing up in some apps??


Hi,

I've recently been trying to check out CentOS 5.3 in desktop form, I have it as a server currently and am pretty happy with it!

Now this is just wierd: I have an HP Color Lasterjet printer 3500 which I installed via both CUPS and the internal print system-config-printer command. The printer is attached to an HP JetDirect EN3700 print server which works very well from MS Win...

Now the printer is setup and installed within the system which is fine I can see it from the CUPS web admin and the Admin -> printers app within the GUI. The printer also lists via lpstats command:

Code:
# lpstat -t
scheduler is running
system default destination: ColorLaserjet3500
device for ColorLaserjet3500: socket://en3700.optiplex-networks.com:9100
ColorLaserjet3500 accepting requests since Wed 13 May 2009 03:03:43 PM BST
printer ColorLaserjet3500 now printing ColorLaserjet3500-6.  enabled since Wed 13 May 2009 03:03:43 PM BST
        Printer is now on-line.
The strange thing is that alot of the apps within Cent can't see it, ie. Firefox, Evolution, OpenOffice2.3

Basically these are the most important apps.

I have installed the Sun version of OpenOffice 3 and that works fine.

I just don't understand what the problem could be, why Firefox et al can't see it???

If any one has any ideas I would be so greatful for the help!

Last edited by kayasaman; 05-13-2009 at 10:09 AM.
 
Old 05-15-2009, 04:17 AM   #2
unSpawn
Moderator
 
Registered: May 2001
Posts: 28,189
Blog Entries: 54

Rep: Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154
CUPS printing shouldn't be a problem with those applications. Is the printer recognized correctly by the GNOME, KDE, XFCE and other Desktop Environment printer configuration tools? With respect to Firefox you could check http://kb.mozillazine.org/PostScript_Module and http://kb.mozillazine.org/Problems_printing_web_pages for diagnostics. It may contain leads that could help troubleshooting.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Redhat Enterprise 5 showing as CentOS??? Are we being scammed? simonm Linux - Software 1 10-10-2008 09:54 AM
Red Hat Enterprise showing as CENTOS simonm Linux - Newbie 3 09-24-2008 11:26 AM
printer setup from Centos 5 to Vista home prem. on a headless centos pc ncsuapex Red Hat 6 03-10-2008 12:40 PM
DVD Writer not showing any more for CentOS 4 tool1248 Linux - Hardware 3 04-06-2007 10:59 AM
US Intl Keybd; Double quotes not showing in some apps Heinz Linux - General 6 01-10-2004 04:48 PM


All times are GMT -5. The time now is 07:24 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration