-   Linux - Desktop (
-   -   Can't remove cairo dock (

sgosnell 09-10-2013 03:17 PM

Can't remove cairo dock
Running Debian Sid.

Like a fool, I installed cairo dock on my wife's laptop. Now I want it gone, and can't get rid of it. In fact, I can't even do an update. When I run apt-get dist-upgrade, I get

The package cairo-dock-terminal-plug-in needs to be reinstalled, but I can't find an archive for it.
I've tried updating through smxi, and I get the same. I can't install a new kernel, can't upgrade, nothing, and I can't kill cairo dock. I've tried using synaptic, apt-get, aptitude, and everything else I can think of, and I can't get rid of cairo dock, or update the computer. I've tried editing sources.list, and that does nothing. Anyone have any ideas?

Update: I think I got it removed using dpkg.

sudo dpkg --forceall --purge cairo-dock-terminal-plug-in
seems to have done it. I'll be sure to remember to never touch cairo dock again.

frankbell 09-11-2013 09:51 PM

Why not come back and mark this thread as "SOLVED." It might help someone else.

sgosnell 09-22-2013 01:44 PM

I'm not yet certain it's solved. I had to be away from home for a couple of weeks, and I haven't had access to that computer to check. All I had time to do before leaving was to see that the dock was gone once, but no chance to reboot or anything else. I'll be home later today and should have a chance to check further sometime this week.

Finally got to boot the problem computer, and it seems cairo-dock is indeed gone. It seems a shame that one can't simply purge it, but has to purge the plug-ins separately. Oh well, it's gone and I won't install it again.

All times are GMT -5. The time now is 05:27 PM.