-   Linux - Desktop (
-   -   Can't enable compositing (

Dorax 08-06-2010 05:39 PM

Can't enable compositing
I am pulling my hair out these last few days. I cannot seem to enable compositing on my OpenSyse 11.3, KDE 4.4 desktop. I have a tc1100 tablet, with GeForce 420.

I uninstalled the nouveau driver and blacklisted it. Also set NO_MS_IN_INITRD to yes

Then compiled the proprietary nvidia legacy driver.

But it cannot enable compositing.

What can I try? How do I enable compositing?

Am I missing something, this should work out of the box right. Perhaps I should go for glx comp since my card is so old. What should I need to install of do to switch to glx and where can I check the compositing log?

Many many thanks!

Here is a copy of my current xorg.conf:


# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 1.0  (buildmeister@builder63)  Tue Jul 13 13:31:50 PDT 2010

Section "ServerLayout"
    Identifier    "Layout0"
    Screen      0  "Screen0"
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"

Section "Files"

Section "InputDevice"
    # generated from default
    Identifier    "Mouse0"
    Driver        "mouse"
    Option        "Protocol" "auto"
    Option        "Device" "/dev/psaux"
    Option        "Emulate3Buttons" "no"
    Option        "ZAxisMapping" "4 5"

Section "InputDevice"
    # generated from default
    Identifier    "Keyboard0"
    Driver        "kbd"

Section "Monitor"
    Identifier    "Monitor0"
    VendorName    "Unknown"
    ModelName      "Unknown"
    HorizSync      30.0 - 110.0
    VertRefresh    50.0 - 150.0
    Option        "DPMS"

Section "Device"
    Identifier    "Device0"
    Driver        "nvidia"
    VendorName    "NVIDIA Corporation"

Section "Screen"
    Identifier    "Screen0"
    Device        "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection    "Display"
        Depth      24
        Modes      "1600x1200" "1280x1024" "1024x768" "800x600" "640x480"
Section "Module"
Load "dbe"
Load "freetype"
Load "extmod"
Load "glx"

Section "Extensions"
Option "RENDER" "true"
Option "DAMAGE" "true"
Option "Composite" "Enable"

Drakeo 08-07-2010 10:25 AM

older cards may need theses tweaks with the drivers


Driver supported: nvidia driver version 1.0-9625 or later

For NVIDIA's rendering platform to function correctly, you must enable 32-bit ARGB GLX Visuals. They are enabled by default with nvidia driver versions 100.14.09 and later, but if you use an earlier version of the driver, you should verify that you have the following line in the either the Device or Screen section of your /etc/X11/xorg.conf file:
Option "AddARGBGLXVisuals" "true"

You should also ensure that the following line is in the Screen section of your /etc/X11/xorg.conf file:
DefaultDepth 24

If the nvidia-xconfig utility is installed, the following command will perform the above steps automatically:
nvidia-xconfig --add-argb-glx-visuals -d 24

(You may need to prefix that command with sudo or run it as the root user for it to work.)

alan99 08-09-2010 08:57 PM

Try adding this line also to your Screen section

Option "AllowGLXWithComposite" "True"

Dorax 08-10-2010 02:02 AM


Thanks a lot everybody. Tried that option, but it did not work. Perhaps the driver is to old to work with OS 11.3?

Since I really needed xrandr to work so that I could rotate the tablet's screen, I reinstalled and sticked to the nouveau driver. Under kde 4.4 however, compositing is still not working, but xrandr is...

Perhaps I should just update nouveau regularly, I read it was under active development. Perhaps it will start working in the near future....

All times are GMT -5. The time now is 11:48 AM.