-   Linux - Desktop (
-   -   Can't Connect Firefox 24 to (

neodaemon 10-23-2013 02:40 PM

Can't Connect Firefox 24 to
Two PC's: System76 Bonx7 (Ubuntu 13.10 x64) <and> a clone desktop (Ubuntu 12.04 x64)
Both run Firefox v. 24.0

From both computers, in Firefox (also tried with Chrome) - I cannot connect to -which is how I check my personal email.

I have a third computer, running Linux Mint 14 KDE, and same Firefox version. This computer connects to without a problem.

All computers are right next to each other, on the same gigabit switch, behind the same hardware firewall/router appliance.

I've rebooted, double-checked security settings, DNS, name resolution, etc. I've scoured these forums and Google for ideas - nothing. This is a recent development, though I can't be sure when exactly it started.

Any help or insight would be greatly appreciated. I have a support case open with Microsoft - but they are completely uninterested in helping - they actually advised me to switch to Internet Explorer.

For the record, I can open a (Windows VM) on my Linux box and connect just fine. But I don't use Windows as my main computer - I use a variety of Linux distro's. I use as a part of work - it sure would be nice to connect to it from Linux/Firefox.

Thanks all,

Habitual 10-23-2013 04:02 PM

noscript plugin installed?

neodaemon 10-23-2013 04:18 PM

No, the noscript plugin is not even listed - nor installed. I have DivX, iTunes, QuickTime, Shockwave/Flash, VLC, and WMP.
Thanks for your reply.

Habitual 10-23-2013 05:06 PM

Try a useragent addon to Firefox?

The User Agent Switcher should have some UAs to select, I'd think.
But here's one for IE8 just in case:
Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.0)

Let us know...

neodaemon 10-23-2013 05:50 PM

I installed User Agent 0.7.3 - and switched to IE 8, then IE 7. Both attempts failed exactly the same way. Also, I have Chrome installed, and it fails the same way too.

There are two things that are odd about this failure:

1. It takes a VERY long time for the Firefox browser to time out and give up. At least 10+ minutes.
2. When Firefix finally times out - I don't get an HTTP error code - even when I evaluate the http headers. I get all HTTP 200's, and a message saying "Server not found".

That seems more like a system security / bug rather than something browser-specific.

I have disabled all plugins/extensions/addons and tried again - same result. This is a fresh install of Ubuntu 13.10, and all current updates applied. On my other computer it's Ubuntu 12.04 with all the updates. It fails too.

Habitual 10-23-2013 05:59 PM

Bizarre, and I don't know. Sorry.

jefro 10-24-2013 04:55 PM

Boot a live cd or two on that system just to double check. I get the feeling it is a firewall issue but can't say for sure.

neodaemon 10-24-2013 09:54 PM

Yea, live CDs' all work fine. I reinstalled a 3rd time and it seems to be working now. It's either firewall, or some sort of cached redirection issue.

Thanks all,

neodaemon 10-27-2013 11:28 AM

Now the Live CD's cannot connect to Office365 either. All Ubuntu-based PC's stopped connecting to at the same time; while Linux Mint PC's and naturally Windoze PC's continue connecting just fine. All physically next to each other on same switch behind same soho router. Rebooted and power-cycled all network equipment and PC's. Fresh reinstalls of Ubuntu 13.10 x64, updates, patches etc. Nothing.

No progress on MS case; they hate Linux.

Seems to only affect Ubuntu distro's running Unity.

John VV 10-27-2013 01:58 PM

off hand it dose sound like a Microsoft issue . Hotmail needs the user agent set to win7 and IE8 or 9

it might be a Microsoft .net framework issue
as in it dose not run on nor MS os's

For accessing Microsoft's ONLINE office365 , use a Microsoft OS

lleb 10-27-2013 02:12 PM

i can say that office365 is horrid for trying to connect using any OS outside of a MS OS. i breaks under OSx, and it breaks under Linux. Welcome to the horrid and one of the worst mistakes companies/counties/school boards are making.

neodaemon 10-27-2013 03:06 PM

I couldn't agree more with the sentiments of this thread. I am so disgusted with M$. Now I'm facing the pain of moving mail providers; just when I got all the clients and phones configured...

John VV 10-27-2013 03:59 PM

there is a reason that the mime for MS
is Bill dressed as a ST borg
" we are the Microsoft ... resistance is futile ... "

neodaemon 10-28-2013 12:53 PM

Ok, so I started all over again with troubleshooting. Every time I installed any version of Ubuntu (12.x 13.x) I had the same problem - cannot connect to It takes 10+ minutes to timeout, then I get "Server not found". I can install Linux Mint, or Windows 7 on the same machine and then connect without a problem. I use DHCP on my home network, all clients get the same DNS servers, which are my ISP. On a hunch I tried statically assigning the DNS servers from another pair supplied by my work ISP. Bingo - connected right up. Then I statically assigned my home ISP DNS servers again - cannot connect. It appears so far, the only website affected by my ISP DNS is Unbelievable. So if anyone has a strange issue like this - try changing their DNS.

Problem solved.

All times are GMT -5. The time now is 02:40 PM.