-   Linux - Desktop (
-   -   Cannot use or configure X-CD-roast in Ubuntu 12.04-LTS (

achim_59 12-27-2012 12:48 PM

Cannot use or configure X-CD-roast in Ubuntu 12.04-LTS
Originally I tried using Brasero but it didn't work the way I wanted it to. There is subject of another thread

Unable to get what I wanted from Brasero, I downloaded an application I used to use years ago - X-CD-ROAST - in the hope that I could achieve what I wanted (i.e. burn some MP3s onto a CD). Unfortunately I didn't get very far past installing the software.

The first time I called it up through the applications menu I got the following message:

WARNING: No root configuration file found or not readable. The superuser must start and configure X-CD-roast first, before others can use it.
It is so long ago that I used it, that I cannot remember exactly what i did back then. Anyhow, I started a terminal, logged in as root and tried starting X-CD-roast. Well, let's be accurate here: I tried 3 different things:

> gksu xcdroast

> gksudo xcdroast

> su
> <my root password>
> xcdroast

The results were slightly different but all ended with the same error:

** (xcdroast:7858): WARNING **: The connection is closed
** (xcdroast:7858): WARNING **: Failed to access cdrecord. Please check the permissions and ownership of /usr/bin/cdrecord
Checking the permissions showed:
1. cdrecord is really a link to another executable: wodim
2. Octal permissions for wodim were originally 40755 (that's equivalent to rwxr-xr-x)
2. Chaning the octal permissions to 40777 (equiv. rwxrwxrwx) achieved nothing

I checked the man pages but found nothing helpful there. It allows you to specify where the config file is to be found but nothing about how to create one.

Can anyone help? I'd really like to get my system running the way it was before my switch to 12.04-LTS. At the moment the problems are coming along faster than I can fix them.

Any info is welcome.


teckk 12-29-2012 07:18 PM

Put all of the files into a directory

For a data DVD

growisofs -use-the-force-luke=tty -Z /dev/sr0 -J -r -speed=8 -dvd-compat -pad -graft-points burn/=/home/username/dir
For a data CD

genisoimage -J -r -pad -graft-points burn/=/home/username/path | cdrecord dev=/dev/sr0 speed=8    -
Audio CD

cdrecord -v dev=/dev/sr0 speed=8 -audio -pad *.wav
This is what I have

ls -l /usr/bin/wodim
-rwxr-xr-x 1 root root 401888 Sep 14  2011 /usr/bin/wodim

ls -l /usr/bin/cdrecord
lrwxrwxrwx 1 root root 5 Sep 14  2011 /usr/bin/cdrecord -> wodim

achim_59 12-30-2012 06:39 AM

Thank you.

From this, some google searches, and 2 other forums - Linux Forums and (indirectly) Ubuntu Forums - I now have a whole range of options to try. Surely one will work. Incidently, the permissions you list is a combination that I did try before I tried changing the wodim permissions.

I will give this another go when I finish hacking some JUnit tests together for my employer. I will be sure to post the results of my efforts here and elsewhere.

Thanks again.


achim_59 02-18-2014 11:41 AM

This is just by way of closing this off. I never did get X-CD-Roast working. My solution to the original problem was ultimately to use the standard CD-Burner (Brasero) and add the files which I wanted to burn one by one to the directory where the burner should read them. A very tedious undertaking when there are 180 files involved that need to be burned in just the right order. This process could be sped up by using an appropriate bash or perl script, which I still have not had time to write!

All times are GMT -5. The time now is 04:19 AM.