LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Desktop
User Name
Password
Linux - Desktop This forum is for the discussion of all Linux Software used in a desktop context.

Notices


Reply
  Search this Thread
Old 12-05-2013, 04:17 AM   #1
decenter
Member
 
Registered: Sep 2011
Distribution: Fedora release 21 (Twenty One)
Posts: 156

Rep: Reputation: 19
Cannot remove Microcode completely


Hello,

I have Ubuntu 12.04.3 LTS 64 bit desktop system. I recently installed microcode. Then I decided to uninstall it and went to synaptic and removed intel-microcode and microcode.ctl package. Then I did a reboot and even then I see this message on boot process,

Code:
dmesg | grep microcode
[    0.281345] perf_event_intel: PEBS disabled due to CPU errata, please upgrade microcode
[    6.751947] microcode: CPU0 sig=0x206a7, pf=0x2, revision=0x25
[    6.807795] microcode: CPU1 sig=0x206a7, pf=0x2, revision=0x25
[    6.808763] microcode: CPU2 sig=0x206a7, pf=0x2, revision=0x25
[    6.809622] microcode: CPU3 sig=0x206a7, pf=0x2, revision=0x25
[    6.810514] microcode: Microcode Update Driver: v2.00 <tigran@aivazian.fsnet.co.uk>, Peter Oruba

My question is these messages appear even after removing microcode from my system. I do not know why.

Please let me know the complete step for removing the microcode from the system.
 
Old 12-05-2013, 09:41 PM   #2
turtleli
Member
 
Registered: Aug 2012
Location: UK
Posts: 206

Rep: Reputation: Disabled
You cannot remove the default microcode, it's part of your CPU.

The microcode packages you installed (and removed for some reason) allows the CPU to use updated microcode, which fixes some incorrect processor behaviour that can occur under certain conditions.
 
Old 12-06-2013, 01:10 AM   #3
decenter
Member
 
Registered: Sep 2011
Distribution: Fedora release 21 (Twenty One)
Posts: 156

Original Poster
Rep: Reputation: 19
Quote:
Originally Posted by turtleli View Post
You cannot remove the default microcode, it's part of your CPU.

The microcode packages you installed (and removed for some reason) allows the CPU to use updated microcode, which fixes some incorrect processor behaviour that can occur under certain conditions.
But I didn't see this message previously. only after installing microcode, I see these messages. Also, I'm not seeing any message about microcode (or default microcode) on other Linux PC's.
 
Old 12-06-2013, 05:54 AM   #4
turtleli
Member
 
Registered: Aug 2012
Location: UK
Posts: 206

Rep: Reputation: Disabled
Tnose messages are output by the 'microcode' kernel module. If you prevent the kernel module from loading then the messages should disappear but the CPU will still use it's default microcode.

I have access to 3 Linux systems, all of them show the microcode messages, 2 of them update their microcode at bootup. Here are the messages from the system I'm currently using.

Code:
dmesg | grep microcode
[    0.051162] perf_event_intel: PEBS disabled due to CPU errata, please upgrade microcode
[    5.296520] microcode: CPU0 sig=0x206a7, pf=0x10, revision=0x1a
[    5.878875] microcode: CPU0 sig=0x206a7, pf=0x10, revision=0x1a
[    5.881899] microcode: CPU0 updated to revision 0x29, date = 2013-06-12
[    5.884152] microcode: CPU1 sig=0x206a7, pf=0x10, revision=0x1a
[    5.891650] microcode: CPU1 sig=0x206a7, pf=0x10, revision=0x1a
[    5.894365] microcode: CPU1 updated to revision 0x29, date = 2013-06-12
[    5.896684] microcode: CPU2 sig=0x206a7, pf=0x10, revision=0x1a
[    5.898977] microcode: CPU2 sig=0x206a7, pf=0x10, revision=0x1a
[    5.901615] microcode: CPU2 updated to revision 0x29, date = 2013-06-12
[    5.903776] microcode: CPU3 sig=0x206a7, pf=0x10, revision=0x1a
[    5.905667] microcode: CPU3 sig=0x206a7, pf=0x10, revision=0x1a
[    5.907861] microcode: CPU3 updated to revision 0x29, date = 2013-06-12
[    5.911574] microcode: CPU4 sig=0x206a7, pf=0x10, revision=0x1a
[    5.913437] microcode: CPU4 sig=0x206a7, pf=0x10, revision=0x1a
[    5.915625] microcode: CPU4 updated to revision 0x29, date = 2013-06-12
[    5.917480] microcode: CPU5 sig=0x206a7, pf=0x10, revision=0x1a
[    5.920378] microcode: CPU5 sig=0x206a7, pf=0x10, revision=0x1a
[    5.923601] microcode: CPU5 updated to revision 0x29, date = 2013-06-12
[    5.926477] microcode: CPU6 sig=0x206a7, pf=0x10, revision=0x1a
[    5.928281] microcode: CPU6 sig=0x206a7, pf=0x10, revision=0x1a
[    5.930385] microcode: CPU6 updated to revision 0x29, date = 2013-06-12
[    5.932178] microcode: CPU7 sig=0x206a7, pf=0x10, revision=0x1a
[    5.933963] microcode: CPU7 sig=0x206a7, pf=0x10, revision=0x1a
[    5.936052] microcode: CPU7 updated to revision 0x29, date = 2013-06-12
[    5.937793] perf_event_intel: PEBS enabled due to microcode update
[    5.939639] microcode: Microcode Update Driver: v2.00 <tigran@aivazian.fsnet.co.uk>, Peter Oruba
 
1 members found this post helpful.
Old 12-06-2013, 06:51 AM   #5
decenter
Member
 
Registered: Sep 2011
Distribution: Fedora release 21 (Twenty One)
Posts: 156

Original Poster
Rep: Reputation: 19
Yes, I went ahead to prevent the kernel module being loaded at boot time, then those messages disappeared but still Intel ask me to update microcode

Quote:
jessi@jessi-desktop:~$ lsmod | grep microcode
jessi@jessi-desktop:~$ dmesg | grep microcode
[ 0.281262] perf_event_intel: PEBS disabled due to CPU errata, please upgrade microcode
 
Old 12-06-2013, 08:26 PM   #6
turtleli
Member
 
Registered: Aug 2012
Location: UK
Posts: 206

Rep: Reputation: Disabled
I don't know how to remove that message but it is harmless and you can ignore it.

I am, however, curious about why you decided to uninstall the microcode firmware files though.
 
Old 12-09-2013, 01:17 AM   #7
decenter
Member
 
Registered: Sep 2011
Distribution: Fedora release 21 (Twenty One)
Posts: 156

Original Poster
Rep: Reputation: 19
Quote:
Originally Posted by turtleli View Post
I don't know how to remove that message but it is harmless and you can ignore it.

I am, however, curious about why you decided to uninstall the microcode firmware files though.
I un-installed because it takes some time to apply the update and it increases the boot time.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Completely remove KDE VisionIncision Slackware 4 10-03-2012 08:46 AM
Completely Remove xfce4 tux0r Linux - Software 2 09-11-2011 03:16 AM
Remove Exim4 Completely? carlosinfl Debian 15 06-24-2008 10:13 PM
How do I completely remove GRUB? AhrenBa Linux - Distributions 1 07-19-2006 12:32 PM
How to remove KDE completely openfun Debian 3 11-16-2005 07:23 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Desktop

All times are GMT -5. The time now is 04:27 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration