-   Linux - Desktop (
-   -   Cannot print on my HP1020 laser jet (

rkhyd 02-05-2009 12:12 AM

Cannot print on my HP1020 laser jet

I am not able to print using My Laser jet 1020 . The printer is setup alright..I can also see the jobs que in the print spooler. Can some one guide me as iam a newbie to debian..


jdkaye 02-05-2009 01:53 AM


Originally Posted by rkhyd (Post 3432674)

I am not able to print using My Laser jet 1020 . The printer is setup alright..I can also see the jobs que in the print spooler. Can some one guide me as iam a newbie to debian..


Some more information please. What desktop are you using? (kde? gnome? fluxbox?)
Do you have cups installed? the foomatic driver packages?

Does the printer light come on when you send it a job?

Is it a local or network printer? If local how is it connected? If networked, what kind of network?

These are all possibly key factors for solving your problem.

rkhyd 02-06-2009 01:03 AM

I am using GNOME desktop 2.14.3
The CUPS and foomatic drivers have been installed.
The printer light doesnt come on when the job is submitted..Only the power ON button is glowing..
So i checked for the connectivity of the printer using the dmesg command..and the output is as follows..

yash@debian:~$ dmesg | grep usblp0
drivers/usb/class/usblp.c: usblp0: USB Bidirectional printer dev 2 if 0 alt 0 proto 2 vid 0x03F0 pid 0x2B17


yash@debian:~$ usb_printerid /dev/usb/lp0
MFG:Hewlett-Packard;MDL:HP LaserJet 1020;CMD:ACL;CLS:PRINTER;DES:HP LaserJet 1020;FWVER:20051028;

So i understand that the printer is getting identified..

The printer is connected via USB and it is a local printer..
The printer works fine with windows..its not printing only in linux..
please let me know if there are any more debugging commands that should be tried out..


jdkaye 02-06-2009 11:41 AM

You might get more useful error messages if you try printing from the command line something like

cat somefile.txt > /dev/usb/lp0
or using the lpr command

rkhyd 02-07-2009 02:15 AM

I created a new txt file and then tried to print it..but no response from the printer..

debian:/home/yash# vi new.txt
debian:/home/yash# cat new.txt
This is a test file...
debian:/home/yash# cat new.txt > /dev/usb/lp0

So i removed and added the printer again..When i send a displays.. Job-Printing..and then the job disappears...but the document is not printed..

any further help!!!!

jdkaye 02-07-2009 03:07 AM

What desktop are you using? kde? gnome? Have you looked in the printer manager and does your HP seem to be correctly set up?
What are the relevant results of running


dmesg | grep Hewlett

pentode 02-07-2009 11:32 AM

Did you look at this:

There is reference to a necessary firmware upgrade.

theacerguy 02-07-2009 12:40 PM

well i tried for my deskjet f380 googleing
hp deskjet f380 drivers opensuse 10.3
for you it will be your printer and debian version
oh and this should be in the hardware section

jdkaye 02-09-2009 04:23 AM

FWIW, I just checked my printer manager (in KDE) and there is definitely a Laserjet 1020 driver on the list.

pentode 02-09-2009 03:05 PM

Did you see the reference to the required firmware upgrade?

rkhyd 02-10-2009 03:22 AM

yeah..i got it.. the site mentions "*** DON'T USE the foo2zjs package from: Ubuntu, SUSE, Mandrake/Manrivia, Debian, RedHat, Fedora, Gentoo, Xandros, EEE PC, Linpus, MacOSX, or BSD!"

I could not find this page..when googlind..thanks a lot pentode..

But i installed the driver and still the printer doesnt seem to respond..

This is the message i get..

"/usr/lib/cups/filter/foomatic-rip failed"

any more ideas..


KenJackson 02-11-2009 07:55 PM

I've spent more than my fair share of hours trying to make cups recognize my printer. These are the two things I had the most success with:
  • Use the browser interface, http://localhost:631/, delete the printer and create it again, and/or:
  • Use the command-line: /usr/sbin/cupsenable PrinterName (use your own printer name of course).

John VV 02-11-2009 08:11 PM

i have never had a problem using localhost:631 and it is a OLD HP 960c ( /dev/parport0 )

All times are GMT -5. The time now is 10:56 AM.