-   Linux - Desktop (
-   -   Cannot login with any user except in single user mode (

scheidel21 03-19-2008 02:47 AM

Cannot login with any user except in single user mode
I have a debian VM setup inside VirtualBox and I also have a 2003 server setup in a VM as well I was playing with getting linux to join a 2003 AD as a client for SSO, etc.... Well I followed a tutorial and it involved playing with PAM config files adding the winbind module to pam for use as authentication. I successfully joined the etch system to the domain shutdown, when I came back later and booted the VM the system came up and I could not login, not as a local user or an AD user, additionally console login did not even ask for a password after entering a username. logging in as root in single user mode, I accessed auth.log and the output I read was


kdm: :0[2496]: (pam_unix) auth could not identify password for <username>
login[2500]: PAM unable to dlopen(/lib/security/
login[2500]: PAM [dlerror: /lib/security/ cannot open shared object file: No such file or directory
login[2500]: PAM adding faulty module: /lib/security/
login[2500]: (pam_unix) auth could not identify password for <username>
I tried commenting out the references to in the config files, and rebooted back to normal mode but no change the same log and I can't login.

any ideas on how to unfubar the system?

scheidel21 03-19-2008 02:42 PM

Well I solved my inability to login, at least with local logins, instead of commenting out the lines using the I actually removed the lines, now to get AD working

All times are GMT -5. The time now is 09:27 AM.