Share your knowledge at the LQ Wiki.
Go Back > Forums > Linux Forums > Linux - Desktop
User Name
Linux - Desktop This forum is for the discussion of all Linux Software used in a desktop context.


  Search this Thread
Old 07-31-2007, 07:52 PM   #1
Registered: Jul 2004
Location: Lubbock, Texas
Distribution: Slackware 12.0 with Beryl 0.2.1
Posts: 334

Rep: Reputation: 30
Cannot disable the screensaver lock


As the subject implies, I cannot disable the screensaver lock, even though the "Require Password to stop" is unchecked. I have it setup to go into screensaver mode after 15 mins, then have the monitor go into standby mode after 30. This lock only is there when I leave the computer alone for awhile (~1hr+). I tested to see if the screensaver was triggering it by setting it to 1 min, then I tested to see if the standby was triggering it by the same method. Neither caused it.

I'm running KDE 3.5.7 using gdm (I have dropline GNOME installed). I can not say with confidence what change I made started this.

Any ideas?

Old 08-01-2007, 01:56 AM   #2
Registered: Mar 2004
Location: Austin, TX
Distribution: CentOS Fedora RHEL SLES Knoppix
Posts: 78

Rep: Reputation: 15
If you haven't restarted X try that first. If that doesn't work then try disabling all of the screensaver settings and log out. Just to sure, force restart X with <ctrl-alt-bksp>. Then log back in and re-setup your screensaver.

I've seen cases (although not recently) where changing screensaver settings don't take unless you restart X.

You may also want to bring up the Gnome Desktop and make sure everything is disabled there too. Is something causing Gnome to run in the background? Maybe there's some weirdness going on there?

If that doesn't work... Post a bug w/KDE, Gnome, etc...


Last edited by linuxles; 08-01-2007 at 02:02 AM.
Old 08-01-2007, 05:30 PM   #3
Registered: Jul 2004
Location: Lubbock, Texas
Distribution: Slackware 12.0 with Beryl 0.2.1
Posts: 334

Original Poster
Rep: Reputation: 30
I swear! My computer knows what I post on here! As soon as I posted this it knocked it off... but if it kicks back in I'll try out what you suggested...


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Disable screensaver for RealPlayer Plastech Linux - Software 6 08-22-2007 04:56 PM
Console screensaver won't disable jev-bird Linux - Software 0 10-13-2004 12:51 PM
screensaver lock? marlor Slackware 5 07-12-2004 03:10 AM
screen lock login ( from Screensaver) ptrbee Linux - Newbie 0 07-06-2004 08:42 AM
How to disable screensaver for some applications ... legroschat Linux - Software 5 08-28-2003 01:49 AM > Forums > Linux Forums > Linux - Desktop

All times are GMT -5. The time now is 11:57 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration