Help answer threads with 0 replies.
Go Back > Forums > Linux Forums > Linux - Desktop
User Name
Linux - Desktop This forum is for the discussion of all Linux Software used in a desktop context.


  Search this Thread
Old 07-01-2007, 02:11 AM   #1
Registered: Apr 2006
Location: calcutta, IND
Distribution: RHEL AS 4, openSUSE 10.2
Posts: 48

Rep: Reputation: 15
can't change permission of partitions as root !

i can't change the permission of any partitions mounted in /mnt through fstab !! the command gives no error. but when i ls -l then it remains as it was !! i am working as root!
this is my fstab:
server:~ # cat /etc/fstab
/dev/sda2 / ext3 acl,user_xattr 1 1
/dev/sda1 swap swap defaults 0 0
proc /proc proc defaults 0 0
sysfs /sys sysfs noauto 0 0
/dev/sda5 /mnt/sda5-data vfat defaults 0 0
/dev/sda7 /mnt/sda7 vfat defaults 0 0
/dev/md0 /mnt/md0-crit vfat defaults 0 0
/dev/sda3 /mnt/sda3-xp ntfs defaults 0 0
/dev/hda6 /mnt/hda6-song vfat defaults 0 0
is it bcoz that i'm using fat fs and fat doesn't support unix permission? then why as normal user i can't write to them?

thanx in advance .
Old 07-01-2007, 02:21 AM   #2
Simon Bridge
LQ Guru
Registered: Oct 2003
Location: Waiheke NZ
Distribution: Ubuntu
Posts: 9,211

Rep: Reputation: 198Reputation: 198
1. partitions do not have permissions... files do.
2. you change the use permissions of fat32 in fstab by using the umask option (man mount ... scroll down to fat32/vfat options)
3. yep, fat32 doesn't support file permissions. you cannot write to them as a normal user because the linux asserts permissions anyway, based on the mount options (defaults)... which makes the owner and group == root.
Old 07-01-2007, 05:27 AM   #3
LQ Guru
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 671Reputation: 671Reputation: 671Reputation: 671Reputation: 671Reputation: 671
You can also change the ownership and group ownership of the mounted partitions using the "uid" and "gid" options. You can enter either your UID & GID numbers or your user and group names.

I would recommend using "fmask" and "dmask" instead. Try adding the options "uid=yourusername,gid=yourdefaultgroup,fmask=117,dmask=007" in your /etc/fstab file for the vfat partitions.

That will give you rw- file access and rwx directory access for you and all members of your group.
Old 07-01-2007, 12:26 PM   #4
Registered: Apr 2006
Location: calcutta, IND
Distribution: RHEL AS 4, openSUSE 10.2
Posts: 48

Original Poster
Rep: Reputation: 15
thanks a lot , guys .

u both helped a lot.
needs a lot of study, right ?


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
root cannot change permission sharathkv25 Linux - General 1 05-05-2007 04:42 PM
Question on creating more partitions than default ones, i.e. /home,/root partitions casmac SUSE / openSUSE 1 12-20-2006 05:02 PM
e2fsck: root partitions and ro mounted partitions Clemente Linux - General 4 11-06-2006 09:32 PM
Partitions - permission denied Jeppex Linux - Newbie 3 09-12-2006 04:21 PM
Write Permission on Windows Partitions AndyYuen416 Mandriva 5 04-14-2006 09:29 PM > Forums > Linux Forums > Linux - Desktop

All times are GMT -5. The time now is 06:17 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration