-   Linux - Desktop (
-   -   Browsers and Xfce4 Suddenly Broken after Firefox 22 update (

gatoso 07-03-2013 10:56 AM

Browsers and Xfce4 Suddenly Broken after Firefox 22 update
Hi all!!

after installing Firefox 22 on Ubuntu 12.04 64 bits, opening it opening the youtube website and clicking on the adobe flash update link in a youtube video I tried to watch, am experiencing the following symptoms:

user@mycomputer:~$ google-chrome
Segmentation fault (core dumped)
user@mycomputer:~$ chromium-browser
Segmentation fault (core dumped)
user@mycomputer:~$ firefox

(firefox doesn't open at all anymore)

Moreover, I can't use into xfce4 anymore (I normally enter xfce4 from the tty command line using startxfce4 because I haven't found out how to set up the default dm)... it logs me in, but the mouse cursor has become an X and the xfce4-panels load and disappear repeatedly and I have to control-c startxfce4 (xfce4 startup log is available if anyone wants to see it).

I have tried removing .cache/xfce4, .cache/sessions, .config/autostart, .config/xfce4, .config/xfce4-sessions to no avail.

I also checked if there were any rootkits using both chkrootkit and rkhunter and they found nothing of interest.

Luckily, I have kde installed and can write this post on Opera, which still works.

All browsers as well as xfce4 were working perfectly fine before.

Thank you for taking time to read this and help me.

business_kid 07-03-2013 11:39 AM

Run ldconfig in case that fixes it.


ldd /path/to/binary |grep found
for every file that pukes. The correct output is nothing. Anything missing will show. Find or install them.

Also try

ldd /usr/bin/xfce4-session |less
and see if it's pulling libs from strange places. If the LD_LIBRARY_PATH or /etc/ causes the box to find a strange lib first, this could be an issue.

gatoso 07-04-2013 09:23 AM

I ran sudo ldconfig, then tried starting google-chrome and it didn't work.

I also ran ldd /usr/bin/google-chrome | grep found and got no output:

santiago@studio:~$ ldd /usr/bin/google-chrome | grep found

Have not tried ldd on xfce4-session yet.

One thing: when I run firefox with sudo, it works OK...

Running chromium-browser or google-chrome as root (specifying another user data dir to be able to) does not segfault, but does not start them either (data dir gets created and populated, though).

I also notice that synaptic has started to crash when trying to update packages... and some open gtk open file dialogs now simply hang... oops never happened before, I fear my system is getting corrupt... should I try with another kernel or upgrade the release?

Is there a way to "repair" your current Linux installation?

The disks seem to be OK since e2fsck does not complain.

Today I'll start to make a backup anyhow, just in case.

business_kid 07-04-2013 03:28 PM

When ldd |grep found produces nothing, it's good to run ldd /path/to/file, just to check it's finding libs and you're not checking a script or the like. ldd is for elf executables. It should list every linked library and the path to it. It there's no path, it says "not found"

I would agree that your system seems to be going unstable. Check in /var/log/messages for details of problems. You can also check dmesg o/p which logs different stuff. Slackware has a command
upgradepkg --reinstall [packages]
which simply reinstalls all installed packages. Apt-something may have a similar option. I'm not a debian man. You're on your own there.

If you can get some fix on what errors it's actually barfing on, we may be able to do something. Run files from an xterm so stdout errors will be trapped. You can read them off the xterm after it barfs. With xfce, open the startup script and run the individual commands. Read logs, and bootup messages. Find something, or you'll have to reinstall.

gatoso 07-06-2013 05:44 PM

thanks a lot for your time business_kid, I think what you say is probably helpful to solve my problem.

What I'm about to tell you is in many aspects the worst practice possible, but I finally grew tired of having to bare with all the bugs generated because of simple and undetectable permission issues.

After more than a decade of using Linux, both as superuser and sudoer, please let me conclude that, if you know Linux enough, are not in a corporate network, are the only user of your system, regularly back up your important files... then you might decide to ditch sudo. Permission issues are accountable for near 100% of the difficult to solve troubles users face when working under Linux.

Now I'm in paradise, I returned to the golden age where you are the superuser of your own system and everything works just as intended. Don't have time to care about permissions at all.

This sure is a radical solution but definitely worth trying.

business_kid 07-07-2013 10:13 AM

Youŕe flying as long as nobody gets in!

All times are GMT -5. The time now is 01:42 AM.