-   Linux - Desktop (
-   -   backup issues (

siawash 02-09-2009 03:36 PM

backup issues
Hi my pclinux grub kept giving error tmp directories full. Same thing for root and user.

I want to backup my home directory to my usb music player. When I boot into as text mode. I have an external usb drive with two ntfs partitions.
I also have an 18 gig COWON IAUDIO7 media player.

When I can use

cd /media

I get

disk/ disk-1/ disk-2/ I AUDIO7/ I AUDIO7-1

I can cd into disk, disk-1, disk-2 and don't recognize anything on the ntfs drive.

When I try to cd into I AUDIO7 i get "no such file or directory"

Please help I have to got to backup my /home directory

w1k0 02-09-2009 03:50 PM

I AUDIO7 directory's name has a space inside. Try cd "I AUDIO7" command (put directory's name in quotes).

siawash 02-09-2009 04:01 PM

that's great! Now I can go into the I AUDIO7 directory.

But now when I do

cp /home/username /media/"I AUDIO7"

I get

cp: omitting directory '/home/username'

siawash 02-09-2009 04:05 PM

and the strange thing is when I cd into I AUDIO7 and I AUDIO7-1 it does not show any of the files I recognize.

I did not deliberately create two partitions. So what is I AUDIO7-1?

repo 02-09-2009 04:05 PM


cp -R

siawash 02-09-2009 04:06 PM

In fact none of the disks show any files?????

siawash 02-11-2009 11:50 AM

could some body help me with this?

I cannot boot into kde

I have the console but don't know how to copy my home directory to external usb hard drive.

I can see the the drive when I do

cat /proc/scsi/scsi

i just don't know what the name of the drive is when I write to it.

Please help

repo 02-11-2009 11:56 AM

What is the output from

when, you plugin the drive?
What is the output from

fdisk -l
with the drive attached?

jschiwal 02-11-2009 12:10 PM

You could start by logging into the terminal as root and deleting all of the files in /tmp. Then reboot and see if you can login normally.,

To write to an ntfs filesystem, use the ntfs-3g filesystem. This is a fuse module. You may need to install the fuse & ntfs-3g filesystems.

You can try mounting your external drive manually. First you need to know which device it is. Monitor /var/log/messages while inserting the external drive. See which partition(s) is(are) detected.
sudo tail -f /var/log/messages

Another way is to use "fdisk -l" and see which partitions are ntfs:

/dev/sda4          23198      24322    9027584  17  Hidden HPFS/NTFS

You can look up details about a particular partition using "udevinfo".

udevinfo -q env -n sda4

Suppose that the external drive is /dev/sdb and the first ntfs partition is /dev/sdb1.

# make sure the fuse kernel module is loaded
sudo /sbin/modprobe fuse

# create a mount point under /mnt
sudo mkdir /mnt/ntfs_1

# mount the ntfs filesystem
sudo mount -t ntfs-3g /dev/sdb1 /mnt/ntfs_1 rw,uid=<yourusername>,fmask=0117,dmask=0007,utf8

# backup your /home directory
tar -C / -cxzf /mnt/ntfs_1/home_bu.tar.gz /home

Here I used the tar program. Since you are backing up to an ntfs filesystem, it won't save the permissions, attributes or acls for the files. Creating an archive backup, this metadata is saved as well.

You might want to read Section 5.2 of the "tar" info manual. It covers using the -g option for incremental dumps. You could use this option and backup only new files in the future.

siawash 02-11-2009 12:52 PM

many thanks for all the replies. First of all to clarify a few changes since my initial post. I had a spare drive which I formatted in reiser fs and using as external usb drive.

When I do fdisk-1 I get

/dev/hda1 swap ( bootable ) (start at 1) end at 219 id 82 swap ( blocks 1759086 )
/dev/hda2 / start at 220 end at 1422 / ( blocks 9663097 )
/dev/hda3 start at 1423 end at 7296 ( blocks 47182905 ) id 5 extended
/dev/hda5 start at 1423 end 7296 ( blocks 47182873) id 83 linux

If i remember correctly hda2 is root partition.
Swap is self explanatory
I know I had left arount 48 gig for /home but don't if if that translates into had3 or hda5. The whole hard drive is no more than 60 gigs.

Lower down from the fdisk table i have:

Disk /dev/sda: 160 GB 160041885696

Device boot: /dev/sda1
start: 1
End: 19457
Blocks: 156288321
Id: 83
System: linux

I am logged in as root

cp -R /home/username/ /dev/sda1/my_backup


cp -R /home/username /dev/sda1

I get following error:

cp: accessing '/dev/sda1/my_backup': not a directory

siawash 02-11-2009 12:54 PM

BTW it was when I tried to delete the tmp files that now I am prevented logging in KDE. I now realize i deleted a couple of files with the .kde extension which I should have done.

I have to learn a good backup method for the future. I prefer the console method.

repo 02-11-2009 01:04 PM

you first need to mount the drive

mount /dev/sda1 /mount

siawash 02-11-2009 01:08 PM

When i do

mount /dev/sda1 /mount

I get

mount: mount point /mount does not exist

repo 02-11-2009 01:15 PM

then you need to create it

mkdir /mount

siawash 02-11-2009 01:19 PM

i am now getting

mkdir /mount
mkdir: cannot crate directory '/mount': No space left on device

This very strange because the internal hard drive should have plenty of space
I am under the [root@username /]# directory

All times are GMT -5. The time now is 10:39 AM.