LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Desktop
User Name
Password
Linux - Desktop This forum is for the discussion of all Linux Software used in a desktop context.

Notices


Reply
  Search this Thread
Old 08-16-2017, 03:12 PM   #1
blnl
Member
 
Registered: Nov 2009
Location: The Netherlands
Distribution: Fedora
Posts: 89

Rep: Reputation: 0
ARandR issue in Fedora 25


I just upgraded to Fedora 25 (from Fedora 24). The first issue that I encountered is that ARandR does not work. After configuring display layout and pressing Apply, the following message is displayed.
Quote:
XRandR failed:
XRandR returned error code 1: xrandr: Configure crtc 0 failed
This is the output of xrandr command:
Code:
[boris@E7440 ~]$ xrandr
Screen 0: minimum 320 x 200, current 3840 x 1080, maximum 8192 x 8192
XWAYLAND0 connected (normal left inverted right x axis y axis)
   1920x1080     59.96 +
XWAYLAND1 connected (normal left inverted right x axis y axis)
   1920x1080     59.96 +
Can someone please help me with it? I don't like using All Settings => Displays => Arrange Combined Displays. Too many mouse clicks. I prefer a command line solution.

By the way, I also don't understand why the displays are named differently. Before it was eDP1 and DP1-1.
 
Old 08-16-2017, 06:31 PM   #2
AwesomeMachine
LQ Guru
 
Registered: Jan 2005
Location: USA and Italy
Distribution: Debian testing/sid; OpenSuSE; Fedora; Mint
Posts: 5,480

Rep: Reputation: 997Reputation: 997Reputation: 997Reputation: 997Reputation: 997Reputation: 997Reputation: 997Reputation: 997
Fedora 25 switched from X to wayland. That was a move bound to be full of bugs. Xrandr might not be compatible with fedora's wayland implementation. See this: https://forums.fedoraforum.org/showthread.php?t=312000
 
Old 08-16-2017, 07:25 PM   #3
syg00
LQ Veteran
 
Registered: Aug 2003
Location: Australia
Distribution: Lots ...
Posts: 17,167

Rep: Reputation: 2628Reputation: 2628Reputation: 2628Reputation: 2628Reputation: 2628Reputation: 2628Reputation: 2628Reputation: 2628Reputation: 2628Reputation: 2628Reputation: 2628
If you are going to be using Fedora (even a release or two behind) you have to expect things to change - because that's what Fedora is - and you'd better keep on top of the news.
Wayland is old news for Fedora, it has been optional for ages but is now default. It can still be turned off, but who knows for how much longer ?. As that link explains, due to the design differences, some things behave differently - if the devs responsible don't bother, their project won't work on wayland. That is the developers choice.
 
Old 08-17-2017, 07:22 AM   #4
blnl
Member
 
Registered: Nov 2009
Location: The Netherlands
Distribution: Fedora
Posts: 89

Original Poster
Rep: Reputation: 0
Thanks for the explanation. Now, I understand the root-cause of my issue.

By the way, I have no preference for X or wayland. Anything that works if just fine.

From the practical point of view, I must be able to quickly switch between different display configurations.
Q1: Is there a command line method to control the display configurations in wayland?
Q2: If not, how can I disable wayland and go back to X?
 
Old 08-17-2017, 07:38 AM   #5
syg00
LQ Veteran
 
Registered: Aug 2003
Location: Australia
Distribution: Lots ...
Posts: 17,167

Rep: Reputation: 2628Reputation: 2628Reputation: 2628Reputation: 2628Reputation: 2628Reputation: 2628Reputation: 2628Reputation: 2628Reputation: 2628Reputation: 2628Reputation: 2628
A1: No idea.
A2: see /etc/gdm/custom.conf
 
Old 08-17-2017, 07:48 AM   #6
blnl
Member
 
Registered: Nov 2009
Location: The Netherlands
Distribution: Fedora
Posts: 89

Original Poster
Rep: Reputation: 0
SOLUTION:

At login screen, there is an option to chose GNOME on Xorg.

In order to make this selection default, edit the following script:
Code:
[boris@E7440 ~]$ cat /etc/gdm/custom.conf
# GDM configuration storage

[daemon]
# Uncoment the line below to force the login screen to use Xorg
WaylandEnable=false

[security]

[xdmcp]

[chooser]

[debug]
# Uncomment the line below to turn on debugging
#Enable=true

[boris@E7440 ~]$ ./SetScreen_Monitor.DP1-1_R.sh
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
ArandR dual monitor issues KYJazzyJeff Linux - General 7 07-11-2015 09:24 PM
Login issue after upgrading Fedora Core 12 to Fedora 14 abcxxx123 Fedora 1 01-30-2011 03:54 PM
Fedora 13 Installation issue -- Unable to install multiple linux distributions ---partition issue navneethr Linux - General 6 12-23-2010 12:17 AM
Kaffeine not working in Fedora 12. Used to work in Fedora 11. Bug or a config issue? zimon Fedora 4 01-08-2010 02:45 AM
Building dual boot Windows 7 & Fedora 11 machine. Fedora 11 boot issue tedscott Fedora 0 11-14-2009 10:57 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Desktop

All times are GMT -5. The time now is 07:34 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration