LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Desktop
User Name
Password
Linux - Desktop This forum is for the discussion of all Linux Software used in a desktop context.

Notices


Reply
  Search this Thread
Old 05-24-2007, 12:22 AM   #1
100sTressZeN
LQ Newbie
 
Registered: May 2007
Posts: 18

Rep: Reputation: 0
3D Desktop with Nvidia Geforce 420Go 32MB


Hi guys..
First i would like to apoligise myself for my bad english i'm only sixteen and i'm portuguese...

I installed my drivers for my graphic card the 96.31 Legacy nvidia drivers and changed that part of xorg.conf from 'nvidia' to 'nv'... but i'm not able to have the 3D desktop and that 3D effects in my ubuntu 7.04 feisty..
can someone help me in order to put this thing working...?

Thank you very much
 
Old 05-24-2007, 12:50 AM   #2
ovidnet
LQ Newbie
 
Registered: Mar 2006
Location: Longueuil, Quebec
Distribution: Slackware, Ubuntu, Slax
Posts: 13

Rep: Reputation: 0
did you install beryl ?
take a look here first
http://wiki.beryl-project.org/wiki/I...eryl_on_Ubuntu
 
Old 05-24-2007, 04:07 AM   #3
samstar
Member
 
Registered: Apr 2007
Distribution: suse 10.2
Posts: 324

Rep: Reputation: 31
Quote:
Originally Posted by 100sTressZeN
changed that part of xorg.conf from 'nvidia' to 'nv'
Hi,

Change it the other way around. 'nvidia' is the driver you want to use.

Sam
 
Old 05-24-2007, 11:51 AM   #4
100sTressZeN
LQ Newbie
 
Registered: May 2007
Posts: 18

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by samstar
Hi,

Change it the other way around. 'nvidia' is the driver you want to use.

Sam
i can't do it because if i make it when i restart gnome my screen will get white and the graphic interface wouldn't load... so i have to go to text mode and rename xorg.conf to xorg.conf.anything then start gnome again change the xorg.conf.anything to xorg.conf and change 'nvidia' by 'nv' for graphic interface work...


Quote:
Originally Posted by ovidnet
did you install beryl ?
take a look here first
http://wiki.beryl-project.org/wiki/I...eryl_on_Ubuntu
i done it know.. but it still not working
i think that if i can solve the white screen crash of gnome i can put it working

please help me i would like to have 3D on ubuntu

Last edited by 100sTressZeN; 05-24-2007 at 11:54 AM.
 
Old 05-24-2007, 01:39 PM   #5
mariogarcia
Member
 
Registered: Sep 2005
Distribution: debian, solaris 10
Posts: 202

Rep: Reputation: 31
make sure you have aiglx loaded usually white screens are due to aiglx.
look if you have nvidia in the right paths. usually it's a problem with path if you have the latest xorg. you can simlink to where xorg want them. if you want 3D you definitively need nvidia and not nv.
 
Old 05-24-2007, 01:56 PM   #6
100sTressZeN
LQ Newbie
 
Registered: May 2007
Posts: 18

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by mariogarcia
make sure you have aiglx loaded usually white screens are due to aiglx.
look if you have nvidia in the right paths. usually it's a problem with path if you have the latest xorg. you can simlink to where xorg want them. if you want 3D you definitively need nvidia and not nv.
adicioname no msn sff... helderzito@gmail.com
 
Old 05-24-2007, 04:00 PM   #7
samstar
Member
 
Registered: Apr 2007
Distribution: suse 10.2
Posts: 324

Rep: Reputation: 31
Quote:
Originally Posted by 100sTressZeN
i can't do it because if i make it when i restart gnome my screen will get white and the graphic interface wouldn't load... so i have to go to text mode and rename xorg.conf to xorg.conf.anything then start gnome again change the xorg.conf.anything to xorg.conf and change 'nvidia' by 'nv' for graphic interface work...
After you get the white screen, go to text mode, and save for us '/var/log/xorg.0.log'. It may have information that will help us. It will be large, but please post it here.

Sam
 
Old 05-24-2007, 05:46 PM   #8
100sTressZeN
LQ Newbie
 
Registered: May 2007
Posts: 18

Original Poster
Rep: Reputation: 0
big thanks samstar.. finally some1 helps me out


here comes xorg.0.log download it from here because forum don't permit me to publish such a large post

http://heldersousa.com.sapo.pt/Xorg.0.log

thank you very much again
 
Old 05-24-2007, 05:59 PM   #9
Quakeboy02
Senior Member
 
Registered: Nov 2006
Distribution: Debian Linux 9 (stretch)
Posts: 3,358

Rep: Reputation: 126Reputation: 126
Quote:
(--) NV(0): Panel size is 1024 x 768
(II) NV(0): Panel is LVDS
(--) NV(0): VideoRAM: 16384 kBytes
(==) NV(0): Using gamma correction (1.0, 1.0, 1.0)
(II) NV(0): Builtin Default Monitor: Using hsync range of 31.50-48.55 kHz
(II) NV(0): Builtin Default Monitor: Using vrefresh range of 50.00-60.84 Hz
Did you post your xorg.conf? If so, I missed it. Your log says that it's getting the wrong amount of memory and horiz and vert ranges that make no sense to it. You might try this in the "Monitor" section of your xorg.conf file:
Quote:
HorizSync 30-80
VertRefresh 60-75
But we're probably going to need to see your xorg.conf if this doesn't work or if you don't understand what I posted. If you use "nv" in your xorg.conf, then you are not using the driver you installed from nvidia.
 
Old 05-24-2007, 06:15 PM   #10
100sTressZeN
LQ Newbie
 
Registered: May 2007
Posts: 18

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by Quakeboy02
Did you post your xorg.conf? If so, I missed it. Your log says that it's getting the wrong amount of memory and horiz and vert ranges that make no sense to it. You might try this in the "Monitor" section of your xorg.conf file:


But we're probably going to need to see your xorg.conf if this doesn't work or if you don't understand what I posted. If you use "nv" in your xorg.conf, then you are not using the driver you installed from nvidia.

here comes xorg.conf but it is currently disabled because if i enable it and reboot gnome i get a lovelly white screen

Quote:
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 1.0 (buildmeister@builder3) Thu Nov 9 17:55:20 PST 2006


Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
EndSection

Section "Files"
RgbPath "/usr/X11R6/lib/X11/rgb"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "type1"
Load "freetype"
Load "glx"
EndSection

Section "InputDevice"

# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

# generated from default
Identifier "Keyboard0"
Driver "kbd"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Unknown"
ModelName "Unknown"
HorizSync 30.0 - 110.0
VertRefresh 50.0 - 150.0
Option "DPMS"
EndSection

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
Option "AddARGBGLXVisuals" "True"
SubSection "Display"
Depth 24
Modes "1600x1200" "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
EndSection
 
Old 05-24-2007, 06:24 PM   #11
samstar
Member
 
Registered: Apr 2007
Distribution: suse 10.2
Posts: 324

Rep: Reputation: 31
Are you sure you've got an xorg.conf file in '/etc/X11'?

I saw this error right away:
(EE) Unable to locate/open config file

If you renamed the file to something else, rename it back, restart the computer, and give us the resulting /var/log/xorg.0.log file.

Sam
 
Old 05-24-2007, 06:28 PM   #12
samstar
Member
 
Registered: Apr 2007
Distribution: suse 10.2
Posts: 324

Rep: Reputation: 31
Ok, I just saw your new post. Enable this xorg.conf file, and reboot. When you get the large white screen, press '<ctrl> + <alt> + F1' and you will be taken to a text mode. Copy the new /var/log/xorg.0.log to your home directory (~) so it doesn't get overwritten, and post that one the same way you did the previous one.
 
Old 05-24-2007, 06:28 PM   #13
Quakeboy02
Senior Member
 
Registered: Nov 2006
Distribution: Debian Linux 9 (stretch)
Posts: 3,358

Rep: Reputation: 126Reputation: 126
So why not try
Quote:
HorizSync 30 - 80
VertRefresh 60 - 75
Modes "1024x768" "800x600" "640x480"
In the appropriate sections above and see whether it changes anything?
 
Old 05-24-2007, 06:34 PM   #14
100sTressZeN
LQ Newbie
 
Registered: May 2007
Posts: 18

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by samstar
Ok, I just saw your new post. Enable this xorg.conf file, and reboot. When you get the large white screen, press '<ctrl> + <alt> + F1' and you will be taken to a text mode. Copy the new /var/log/xorg.0.log to your home directory (~) so it doesn't get overwritten, and post that one the same way you did the previous one.
can tou say me which command should o i use...
i'm newbie
 
Old 05-24-2007, 06:44 PM   #15
100sTressZeN
LQ Newbie
 
Registered: May 2007
Posts: 18

Original Poster
Rep: Reputation: 0
Quote:
HorizSync 30 - 80
VertRefresh 60 - 75
Modes "1024x768" "800x600" "640x480"
still getting error
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
help editing xf86config for nvidia geforce mx440 after installing nvidia driver linguist Linux - Newbie 11 06-13-2006 06:31 AM
Change X refresh rate on Geforce 4MX/32MB with Compaq S710 crt monitor Xolo Linux - Software 6 06-28-2005 12:48 AM
nVidia RIVA TNT2 Model 64 (32MB PCI Card) Safearus Slackware 10 05-15-2004 05:47 PM
Matrox Mystique G200 or Nvidia TNT2 32MB itsjustme General 1 01-05-2004 05:00 AM
Install OpenGL for GeForce 2 MX 400 32MB linuxmojo Linux - Distributions 6 04-09-2002 10:58 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Desktop

All times are GMT -5. The time now is 11:39 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration