LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Desktop
User Name
Password
Linux - Desktop This forum is for the discussion of all Linux Software used in a desktop context.

Notices


Reply
  Search this Thread
Old 04-14-2008, 01:14 AM   #31
blackhole54
Senior Member
 
Registered: Mar 2006
Posts: 1,896

Rep: Reputation: 61

Quote:
Originally Posted by Digital Watches View Post
Code:
mount: mount point /media/MUSPELHEIM does not exist
I sounds like /media/MUSPELHEIM doesn't exist. (It must have been temporarily created before. I still haven't figured out the details of what's going on.) Create it and try mounting it again as a regular user (with that entry still in fstab):

Code:
sudo mkdir /media/MUSPELHEIM
EDIT: If that didn't exist, that is probably why it wasn't getting mounted at boot time when using the other fstab entry. Why don't you try what I just said, and if it works, remove the noauto and user options from the fstab entry (i.e., go back to what it was before) and see if it mounts correctly at boot time.

Last edited by blackhole54; 04-14-2008 at 01:20 AM.
 
Old 04-14-2008, 01:37 AM   #32
Digital Watches
LQ Newbie
 
Registered: Apr 2008
Posts: 28

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by blackhole54 View Post
I sounds like /media/MUSPELHEIM doesn't exist. (It must have been temporarily created before. I still haven't figured out the details of what's going on.) Create it and try mounting it again as a regular user (with that entry still in fstab):

Code:
sudo mkdir /media/MUSPELHEIM
EDIT: If that didn't exist, that is probably why it wasn't getting mounted at boot time when using the other fstab entry. Why don't you try what I just said, and if it works, remove the noauto and user options from the fstab entry (i.e., go back to what it was before) and see if it mounts correctly at boot time.
Sweet. Worked like a charm. Now I just need to figure out this dual monitor thing and I'm set. Any idea how to exit X to the satisfaction of a nvidia driver?
 
Old 04-15-2008, 12:08 AM   #33
blackhole54
Senior Member
 
Registered: Mar 2006
Posts: 1,896

Rep: Reputation: 61
Quote:
Originally Posted by Digital Watches View Post
Any idea how to exit X to the satisfaction of a nvidia driver?
I'm not sure exactly what you are trying to do, but if you take gdm down, X should go with it.

Of, course, you should not do this from with X! Switch to a virtual terminal (VT) by pressing one of ctr-alt-F1 through ctrl-alt-F6. In Ubunutu I usually skip F1 because it's filled with all the boot stuff. Log into your account. (In case you've never done this before, I'll let you know that when logging in at a VT -- or any other non-graphical login -- you don't get any feedback as you type in your password -- it looks like nothing is happening.) Once logged in you can issue the following commands to stop, start, or restart gdm Restart is just stop followed immediately by a start. I hope this is what you were looking for.

Code:
sudo invoke-rc.d gmd stop
sudo invoke-rc.d gmd start
sudo invoke-rc.d gmd restart
When you start or restart gdm the display will immediately (possibly after a little flickering) show the graphical screen. But you are still logged in to the VT. You can go back to the VT by pressing ctrl-alt-F[1-6] again.

EDIT: Depending on your Xorg.conf fie, you can also instantly kill X by (from within X) by pressing ctrl-alt-Backspace. This abruptly kills X w/o giving anything a chance to shutdown nicely. If you do this, gdm and X should restart after a few seconds and you'll be back at the graphical login.

Last edited by blackhole54; 04-15-2008 at 12:14 AM.
 
Old 04-15-2008, 07:34 PM   #34
Digital Watches
LQ Newbie
 
Registered: Apr 2008
Posts: 28

Original Poster
Rep: Reputation: 15
CURSES. Since I often work with ISO files that are larger than 4GB, at the advice of people on another thread, I backed up all the stuff on NIFLHEIM and reformatted it to EXT3. After installing IFS drivers on my windows environment, it works fine there, but it's having trouble mounting at boot on Ubuntu again. Here's the line I'm using in FSTAB:

Code:
# /dev/sdb4               
UUID=XXXXXXXX-XXXX-XXXX-XXXX-XXXXXXXXXXXX    /media/NIFLHEIM     ext3    umask=0    0 0
And the error I get when trying to mount manually from X is: "You do not have permission to mount 'Niflheim'"

If I do
Code:
sudo mount /media/NIFLHEIM
I get

Code:
mount: wrong fs type, bad option, bad superblock on /dev/sdb4,
       missing codepage or helper program, or other error
       In some cases useful info is found in syslog - try
       dmesg | tail  or so
Notably, as usual, I can mount it manually with a password if it's not in FSTAB

Sorry to be such a bother, but can anyone tell me what I'm doing wrong here? I plan to convert the MUSPELHEIM volume as well once I figure this out.
 
Old 04-16-2008, 01:33 AM   #35
blackhole54
Senior Member
 
Registered: Mar 2006
Posts: 1,896

Rep: Reputation: 61
The umask option is not valid with ext3. Try this:

Code:
# /dev/sdb4               
UUID=XXXXXXXX-XXXX-XXXX-XXXX-XXXXXXXXXXXX    /media/NIFLHEIM     ext3    defaults    0 0
BTW, the mount man page lists what options are valid with each type of filesystem and what they do. In most cases the same options that are valid for the mount command are valid in fstab. There are some exceptions.
 
Old 04-16-2008, 02:55 AM   #36
Digital Watches
LQ Newbie
 
Registered: Apr 2008
Posts: 28

Original Poster
Rep: Reputation: 15
Ah, okay, got it to mount, but it claims that Root is the owner, thus I can't write files without sudo. Any way to change that, or do I have to repartition the drive?
 
Old 04-16-2008, 11:51 PM   #37
blackhole54
Senior Member
 
Registered: Mar 2006
Posts: 1,896

Rep: Reputation: 61
Quote:
Originally Posted by Digital Watches View Post
Ah, okay, got it to mount, but it claims that Root is the owner, thus I can't write files without sudo. Any way to change that, or do I have to repartition the drive?
Ext3 uses standard *nix permissions. So you can use chown, chgrp, and chmod as usual. For example, to change it so you own everything on the partition, give the command (with the partition mounted):

Code:
sudo chown -R <your user name>: <mount point>
The colon (:) following the username means the group will also be changed to your login group. (In Ubuntu, by default this will be the same name as your user name.) After you own everything, you won't have to use sudo anymore if you just want to change permissions on the partition.

Just to kind of wrap this up and tie everything together concerning what we've discussed about mounting these filesystems, I'll point out that the umask=, uid=, etc options are used as work-arounds with vfat because vfat doesn't understand *nix permissions. So it's driver uses those mount options to "fake it." Which is where we began this thread: you were wondering why chown and chmod weren't working with vfat. I hope it all makes sense now.

Last edited by blackhole54; 04-16-2008 at 11:57 PM. Reason: options -> mount options; spelling
 
Old 04-21-2008, 02:43 AM   #38
Digital Watches
LQ Newbie
 
Registered: Apr 2008
Posts: 28

Original Poster
Rep: Reputation: 15
Cool, so now I have Niflheim running as an ext3 partition. I'll probably do that to Muspelheim later, but I don't have a pressing need to at the moment, since I'm only really using that partition to install larger applications on both OSes, and I don't imagine that will involve any large files (Certainly not over 4GB).

Meanwhile, I still can't get Nvidia's drivers to install. I successfully killed X, but going into the installation, it says I don't have libc headers for my distribution installed, and thus it can't compile a kernel. How do I install said headers?
 
Old 04-21-2008, 11:21 PM   #39
blackhole54
Senior Member
 
Registered: Mar 2006
Posts: 1,896

Rep: Reputation: 61
Quote:
Originally Posted by Digital Watches View Post
Meanwhile, I still can't get Nvidia's drivers to install. I successfully killed X, but going into the installation, it says I don't have libc headers for my distribution installed, and thus it can't compile a kernel. How do I install said headers?
I'm a little confused why a kernel needs to be compiled. While I'm rather at the edge of my knowledge here, I thought everything you needed could be downloaded as binaries w/o the need to compile anything.

Anyway, I've never compiled a Ubuntu kernel, and the kernels I have compiled didn't need anything extra installed. But I know there are articles on the Internet specifically about compiling a kernel in Ubuntu. If you really think you need to do this, I'd suggest searching for one of these articles; it will probably tell you what packages you need to download.

BTW, I quickly looked at the output of

Code:
apt-cache search libc | less
and didn't see any likely suspects. Maybe I just missed it.
 
Old 04-23-2008, 02:22 PM   #40
Digital Watches
LQ Newbie
 
Registered: Apr 2008
Posts: 28

Original Poster
Rep: Reputation: 15
Hm... Well, it does give the option to try to download a precompiled kernel online... but it never seems able to reach the server it needs, and then claims it needs to compile one itself, and then that since my libc headers aren't installed, it can't. I'll look for those articles. Thanks muchly for all the help.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Shared Partition on Dual boot permissions issue TuxLives Linux - Desktop 4 07-22-2007 05:35 AM
Questions about dual-boot partition scenario ericthered8 SUSE / openSUSE 2 09-09-2006 04:52 PM
Setting up Dual Monitors on GeForce 6600GT dual DVI card. monkiidansu Linux - Hardware 1 09-29-2005 02:21 PM
Nebie Questions- Partition, Format, Dual Boot Zychior Linux - General 3 09-13-2004 04:58 PM
TV's, CRT Monitors, LCD Monitors... refresh rates and other questions MasterC General 13 05-12-2003 04:00 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Desktop

All times are GMT -5. The time now is 02:52 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration