LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Desktop (https://www.linuxquestions.org/questions/linux-desktop-74/)
-   -   [Lubuntu] (Theme Issue) Mismatched Icons (https://www.linuxquestions.org/questions/linux-desktop-74/%5Blubuntu%5D-theme-issue-mismatched-icons-4175677987/)

KGIII 07-01-2020 08:04 PM

[Lubuntu] (Theme Issue) Mismatched Icons
 
You see this?

http://pix.toile-libre.org/upload/or...1593655751.png

Yeah! That's BS! It irks me far more than it should!

As you see, the icon on the left is properly themed. It's the right icon! It's the right icon even in the start/application menu.

Then...

I start the app and it doesn't have the right icon!

If you look, the other apps have the right icon. They're all a nice blue color, just as they should be. Not Google Chrome! No! No, that one wants to be all multi-colored and special!

I've tried yelling at it. I've tried searching to see how to change that one specific section - but found nothing. I've looked at the shortcut properties. I got nothing...

The OS is Lubuntu 18.04.4 LTS. That means the DE is LXDE.

It's trivial, but I'd like to fix it if possible.

KGIII 07-01-2020 09:14 PM

By the way, this is my desktop:

https://i.postimg.cc/hvVpjXcR/20200626-002-1.png

As you can see, it's way too sexy to be sullied by that Chrome icon!

ondoho 07-02-2020 04:04 AM

Quote:

Originally Posted by KGIII (Post 6140332)
You see this?

http://pix.toile-libre.org/upload/or...1593655751.png

Yeah! That's BS! It irks me far more than it should!

(...)

The OS is Lubuntu 18.04.4 LTS. That means the DE is LXDE.

Are you using the default lxpanel?
Is that Chrome, not Chromium? Isn't it understandable that a closed-source application from outside the repositories doesn't play ball? Why don't you use Chromium instead?
Even so, some workarounds are possible:
  • Can you find the icons in the browser's list of installed files? You could try to replace them with sth more suitable - this would need to be repeated after every browser upgrade.
  • If Chrome searches for icons elsewhere, try to place suitably named icons in e.g. /usr/share/pixmaps or /usr/share/icons/hicolor...
  • use a script around xseticon to change the icon after Chrom* has started
But my favourite workaround is this:
https://forums.bunsenlabs.org/viewto...d=58090#p58090
...and following posts by ohnonot...
https://forums.bunsenlabs.org/viewto...d=58155#p58155
https://forums.bunsenlabs.org/viewto...d=58222#p58222
Been using that method for years.

shruggy 07-02-2020 04:33 AM

Well, I don't use Google Chrome, but for Chromium I get:
Code:

$ apt-file list chromium-browser|grep desktop$
chromium-browser: /usr/share/applications/chromium-browser.desktop

Locate the .desktop file for Chrome and look inside for the icon it uses. E.g. here it's for firefox:
Code:

$ grep ^Icon= /usr/share/applications/firefox.desktop
Icon=firefox

If it's just the icon name like above then Chrome searches for it in standard places ondoho wrote about: /usr/share/icons/hicolor/..., /usr/share/pixmaps/.

If it's a path then it's the path to the icon file.

KGIII 07-02-2020 02:08 PM

Thanks! I resolved it.

For some reason, the theme was installed but not present in usr/share/themes. This means I have no idea where the theme was actually installed - but simply elevating my permissions with the file manager let me drag and drop it.

No specific info helped - but it all led me to the right place. So, thanks!

ondoho 07-03-2020 02:40 AM

^ screenshot to prove it! :D

KGIII 07-03-2020 07:55 AM

LOL Remind me. It's early morning so I'm outside w/my laptop, sucking up the cooler temperatures.

*makes note to self*

It started to sprinkle, so here you go:
http://pix.toile-libre.org/upload/or...1593788308.png

It's still not quite right - but it's close enough I think that's because there's a "high-color" theme and a more matte color theme. When I go through the /usr/share/themes folder, it's a damned mess. I *think* I installed some of the themes by copy/pasting the folders and not through the importation process and that's where the troubles (probably) began.

Also, it may have to do with the tornado of attempts that I made prior. I did stuff like hard-code icon paths in .desktop files and the likes. I made a true mess. I should probably preserve /home and reinstall, but it's not yet broken enough to warrant that.

ondoho 07-04-2020 03:30 AM

Icon themes go into /usr/share/icons, not /usr/share/themes, so I don't see how that could've helped.

In any case, it would mean that Chrome finds your icon only when it's under /usr/share? I find that unlikely, but then, it being a closed source app that does not come from your distro's repositories, anything is possible.

Did you even apply that blue ACYL (that's what it is, right?) theme session-wide before?

I think it's more likely you "accidentally did the right thing" when editing those .desktop files.

KGIII 07-04-2020 05:32 PM

I attribute it to dumb luck and trying everything - and I do mean everything.

And, yeah - I am pretty sure I installed it by the "customize look and feel" or directly with the OpenBox configuration app. Pretty sure...

Also, I drank last night and got bored. So, I now have a fresh install.

This amused me. It's amazing how quick I can put it back together again. I didn't even preserve home - but I did back my shit up and can just restore quite a bit of it by dragging and dropping.

I'll get to getting a good theme going and this time I'll take notes to make sure I can repeat getting the icon to work again.


All times are GMT -5. The time now is 05:15 AM.